ipset: Bump to 6.24

Included you'll find a patch to bump ipset to version 6.24. This
version supports the ip,fwmark set, which is needed for mwan3 1.6.

Signed-off-by: Jeroen Louwes <jeroen.louwes@gmail.com>

SVN-Revision: 44671
lede-17.01
John Crispin 2015-03-11 16:41:58 +00:00
parent a67cd94def
commit 5b04e0dc4e
2 changed files with 2 additions and 30 deletions

View File

@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipset
PKG_VERSION:=6.20.1
PKG_VERSION:=6.24
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ipset.netfilter.org
PKG_MD5SUM:=8af741492752fbf24d3a28a9d1473d40
PKG_MD5SUM:=8831b8f01458bf2abacc222884195a62
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=GPL-2.0

View File

@ -1,28 +0,0 @@
diff --git a/lib/parse.c b/lib/parse.c
index 8ea8542..440ef8f 100644
--- a/lib/parse.c
+++ b/lib/parse.c
@@ -1292,15 +1292,20 @@ ipset_parse_timeout(struct ipset_session *session,
enum ipset_opt opt, const char *str)
{
int err;
- unsigned long long num = 0;
+ unsigned long long llnum = 0;
+ uint32_t num = 0;
assert(session);
assert(opt == IPSET_OPT_TIMEOUT);
assert(str);
- err = string_to_number_ll(session, str, 0, UINT_MAX/1000, &num);
- if (err == 0)
+ err = string_to_number_ll(session, str, 0, UINT_MAX/1000, &llnum);
+ if (err == 0) {
+ /* Timeout is expected to be 32bits wide, so we have
+ to convert it here */
+ num = llnum;
return ipset_session_data_set(session, opt, &num);
+ }
return err;
}