musl: update to version 1.1.11

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 46772
lede-17.01
Felix Fietkau 2015-09-02 15:44:17 +00:00
parent 3d1890053c
commit 58ab3ad6b0
7 changed files with 5 additions and 3180 deletions

View File

@ -3,6 +3,6 @@ if USE_MUSL
config MUSL_VERSION config MUSL_VERSION
string string
depends on USE_MUSL depends on USE_MUSL
default "1.1.10" default "1.1.11"
endif endif

View File

@ -11,7 +11,7 @@ PKG_NAME:=musl
PKG_VERSION:=$(call qstrip,$(CONFIG_MUSL_VERSION)) PKG_VERSION:=$(call qstrip,$(CONFIG_MUSL_VERSION))
PKG_RELEASE=1 PKG_RELEASE=1
PKG_MD5SUM:=fc30892ee582c91920505bbd0021049f PKG_MD5SUM:=48be0777e32f374d387e9cf85e36ec4d
PKG_SOURCE_URL:=http://www.musl-libc.org/releases PKG_SOURCE_URL:=http://www.musl-libc.org/releases
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

File diff suppressed because it is too large Load Diff

View File

@ -1,29 +0,0 @@
From 2a502f995d041977f43f05556a3beba64df69858 Mon Sep 17 00:00:00 2001
From: Steven Barth <cyrus@openwrt.org>
Date: Tue, 18 Aug 2015 11:03:45 +0200
Subject: [PATCH] getsubopt: don't include leading = in value string
getsubopt incorrectly returns the delimiting = in the value string,
this patch fixes it by increasing the pointer position by one.
Signed-off-by: Steven Barth <cyrus@openwrt.org>
---
src/misc/getsubopt.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/misc/getsubopt.c b/src/misc/getsubopt.c
index dac9bf9..53ee957 100644
--- a/src/misc/getsubopt.c
+++ b/src/misc/getsubopt.c
@@ -15,7 +15,7 @@ int getsubopt(char **opt, char *const *keys, char **val)
size_t l = strlen(keys[i]);
if (strncmp(keys[i], s, l)) continue;
if (s[l] == '=')
- *val = s + l;
+ *val = s + l + 1;
else if (s[l]) continue;
return i;
}
--
2.1.4

View File

@ -33,7 +33,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
--- a/configure --- a/configure
+++ b/configure +++ b/configure
@@ -522,6 +522,10 @@ trycppif "_MIPSEL || __MIPSEL || __MIPSE @@ -538,6 +538,10 @@ trycppif "_MIPSEL || __MIPSEL || __MIPSE
trycppif __mips_soft_float "$t" && SUBARCH=${SUBARCH}-sf trycppif __mips_soft_float "$t" && SUBARCH=${SUBARCH}-sf
fi fi

View File

@ -31,7 +31,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
$(NOSSP_SRCS:%.c=%.o) $(NOSSP_SRCS:%.c=%.lo): CFLAGS += $(CFLAGS_NOSSP) $(NOSSP_SRCS:%.c=%.o) $(NOSSP_SRCS:%.c=%.lo): CFLAGS += $(CFLAGS_NOSSP)
$(CRT_LIBS:lib/%=crt/%): CFLAGS += -DCRT $(CRT_LIBS:lib/%=crt/%): CFLAGS += -DCRT
@@ -147,6 +148,11 @@ lib/libc.a: $(OBJS) @@ -155,6 +156,11 @@ lib/libc.a: $(OBJS)
$(AR) rc $@ $(OBJS) $(AR) rc $@ $(OBJS)
$(RANLIB) $@ $(RANLIB) $@

View File

@ -1,6 +1,6 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -187,7 +187,7 @@ $(DESTDIR)$(includedir)/%: include/% @@ -195,7 +195,7 @@ $(DESTDIR)$(includedir)/%: include/%
$(INSTALL) -D -m 644 $< $@ $(INSTALL) -D -m 644 $< $@
$(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(libdir)/libc.so $(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(libdir)/libc.so