mirror of https://github.com/hak5/openwrt.git
ar71xx: add kernel support for the Tube2H board
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 41649lede-17.01
parent
d7ae7bae57
commit
51c892053a
|
@ -103,6 +103,7 @@ CONFIG_ATH79_MACH_TL_WR841N_V1=y
|
|||
CONFIG_ATH79_MACH_TL_WR841N_V8=y
|
||||
CONFIG_ATH79_MACH_TL_WR841N_V9=y
|
||||
CONFIG_ATH79_MACH_TL_WR941ND=y
|
||||
CONFIG_ATH79_MACH_TUBE2H=y
|
||||
CONFIG_ATH79_MACH_UBNT=y
|
||||
CONFIG_ATH79_MACH_UBNT_XM=y
|
||||
CONFIG_ATH79_MACH_WHR_HP_G300N=y
|
||||
|
|
|
@ -0,0 +1,113 @@
|
|||
/*
|
||||
* ALFA NETWORK Tube2H board support
|
||||
*
|
||||
* Copyright (C) 2014 Gabor Juhos <juhosg@openwrt.org>
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify it
|
||||
* under the terms of the GNU General Public License version 2 as published
|
||||
* by the Free Software Foundation.
|
||||
*/
|
||||
|
||||
#include <linux/gpio.h>
|
||||
|
||||
#include <asm/mach-ath79/ath79.h>
|
||||
#include <asm/mach-ath79/ar71xx_regs.h>
|
||||
|
||||
#include "common.h"
|
||||
#include "dev-eth.h"
|
||||
#include "dev-gpio-buttons.h"
|
||||
#include "dev-leds-gpio.h"
|
||||
#include "dev-m25p80.h"
|
||||
#include "dev-wmac.h"
|
||||
#include "machtypes.h"
|
||||
|
||||
#define TUBE2H_GPIO_LED_SIGNAL4 0
|
||||
#define TUBE2H_GPIO_LED_SIGNAL3 1
|
||||
#define TUBE2H_GPIO_LED_SIGNAL2 13
|
||||
#define TUBE2H_GPIO_LED_LAN 17
|
||||
#define TUBE2H_GPIO_LED_SIGNAL1 27
|
||||
|
||||
#define TUBE2H_GPIO_BTN_RESET 12
|
||||
|
||||
#define TUBE2H_KEYS_POLL_INTERVAL 20 /* msecs */
|
||||
#define TUBE2H_KEYS_DEBOUNCE_INTERVAL (3 * TUBE2H_KEYS_POLL_INTERVAL)
|
||||
|
||||
#define TUBE2H_ART_ADDRESS 0x1f7f0000
|
||||
#define TUBE2H_LAN_MAC_OFFSET 0x06
|
||||
#define TUBE2H_CALDATA_OFFSET 0x1000
|
||||
|
||||
static struct gpio_led tube2h_leds_gpio[] __initdata = {
|
||||
{
|
||||
.name = "alfa:blue:lan",
|
||||
.gpio = TUBE2H_GPIO_LED_LAN,
|
||||
.active_low = 1,
|
||||
},
|
||||
{
|
||||
.name = "alfa:red:signal1",
|
||||
.gpio = TUBE2H_GPIO_LED_SIGNAL1,
|
||||
.active_low = 1,
|
||||
},
|
||||
{
|
||||
.name = "alfa:orange:signal2",
|
||||
.gpio = TUBE2H_GPIO_LED_SIGNAL2,
|
||||
.active_low = 0,
|
||||
},
|
||||
{
|
||||
.name = "alfa:green:signal3",
|
||||
.gpio = TUBE2H_GPIO_LED_SIGNAL3,
|
||||
.active_low = 0,
|
||||
},
|
||||
{
|
||||
.name = "alfa:green:signal4",
|
||||
.gpio = TUBE2H_GPIO_LED_SIGNAL4,
|
||||
.active_low = 0,
|
||||
},
|
||||
};
|
||||
|
||||
static struct gpio_keys_button tube2h_gpio_keys[] __initdata = {
|
||||
{
|
||||
.desc = "Reset button",
|
||||
.type = EV_KEY,
|
||||
.code = KEY_RESTART,
|
||||
.debounce_interval = TUBE2H_KEYS_DEBOUNCE_INTERVAL,
|
||||
.gpio = TUBE2H_GPIO_BTN_RESET,
|
||||
.active_low = 1,
|
||||
},
|
||||
};
|
||||
|
||||
static void __init tube2h_setup(void)
|
||||
{
|
||||
u8 *art = (u8 *) KSEG1ADDR(TUBE2H_ART_ADDRESS);
|
||||
u32 t;
|
||||
|
||||
ath79_gpio_function_disable(AR933X_GPIO_FUNC_JTAG_DISABLE |
|
||||
AR933X_GPIO_FUNC_ETH_SWITCH_LED0_EN |
|
||||
AR933X_GPIO_FUNC_ETH_SWITCH_LED1_EN |
|
||||
AR933X_GPIO_FUNC_ETH_SWITCH_LED2_EN |
|
||||
AR933X_GPIO_FUNC_ETH_SWITCH_LED3_EN |
|
||||
AR933X_GPIO_FUNC_ETH_SWITCH_LED4_EN);
|
||||
|
||||
/* Ensure that GPIO26 and GPIO27 are controllable by software */
|
||||
t = ath79_reset_rr(AR933X_RESET_REG_BOOTSTRAP);
|
||||
t |= AR933X_BOOTSTRAP_MDIO_GPIO_EN;
|
||||
ath79_reset_wr(AR933X_RESET_REG_BOOTSTRAP, t);
|
||||
|
||||
ath79_register_wmac(art + TUBE2H_CALDATA_OFFSET, NULL);
|
||||
|
||||
ath79_register_m25p80(NULL);
|
||||
|
||||
ath79_register_leds_gpio(-1, ARRAY_SIZE(tube2h_leds_gpio),
|
||||
tube2h_leds_gpio);
|
||||
ath79_register_gpio_keys_polled(-1, TUBE2H_KEYS_POLL_INTERVAL,
|
||||
ARRAY_SIZE(tube2h_gpio_keys),
|
||||
tube2h_gpio_keys);
|
||||
|
||||
ath79_init_mac(ath79_eth0_data.mac_addr,
|
||||
art + TUBE2H_LAN_MAC_OFFSET, 0);
|
||||
ath79_register_mdio(0, 0x0);
|
||||
ath79_register_eth(0);
|
||||
}
|
||||
|
||||
MIPS_MACHINE(ATH79_MACH_TUBE2H, "TUBE2H", "ALFA NETWORK Tube2H",
|
||||
tube2h_setup);
|
||||
|
|
@ -0,0 +1,38 @@
|
|||
--- a/arch/mips/ath79/machtypes.h
|
||||
+++ b/arch/mips/ath79/machtypes.h
|
||||
@@ -141,6 +141,7 @@ enum ath79_mach_type {
|
||||
ATH79_MACH_TL_WR841N_V9, /* TP-LINK TL-WR841N/ND v9 */
|
||||
ATH79_MACH_TL_WR842N_V2, /* TP-LINK TL-WR842N/ND v2 */
|
||||
ATH79_MACH_TL_WR941ND, /* TP-LINK TL-WR941ND */
|
||||
+ ATH79_MACH_TUBE2H, /* Alfa Network Tube2H */
|
||||
ATH79_MACH_UBNT_AIRROUTER, /* Ubiquiti AirRouter */
|
||||
ATH79_MACH_UBNT_BULLET_M, /* Ubiquiti Bullet M */
|
||||
ATH79_MACH_UBNT_LSSR71, /* Ubiquiti LS-SR71 */
|
||||
--- a/arch/mips/ath79/Kconfig
|
||||
+++ b/arch/mips/ath79/Kconfig
|
||||
@@ -29,6 +29,15 @@ config ATH79_MACH_ALFA_NX
|
||||
select ATH79_DEV_LEDS_GPIO
|
||||
select ATH79_DEV_M25P80
|
||||
|
||||
+config ATH79_MACH_TUBE2H
|
||||
+ bool "ALFA Network Tube2H board support"
|
||||
+ select SOC_AR933X
|
||||
+ select ATH79_DEV_ETH
|
||||
+ select ATH79_DEV_GPIO_BUTTONS
|
||||
+ select ATH79_DEV_LEDS_GPIO
|
||||
+ select ATH79_DEV_M25P80
|
||||
+ select ATH79_DEV_WMAC
|
||||
+
|
||||
config ATH79_MACH_ALL0258N
|
||||
bool "Allnet ALL0258N support"
|
||||
select SOC_AR724X
|
||||
--- a/arch/mips/ath79/Makefile
|
||||
+++ b/arch/mips/ath79/Makefile
|
||||
@@ -116,6 +116,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WR1043ND_V2)
|
||||
obj-$(CONFIG_ATH79_MACH_TL_WR2543N) += mach-tl-wr2543n.o
|
||||
obj-$(CONFIG_ATH79_MACH_TL_WR703N) += mach-tl-wr703n.o
|
||||
obj-$(CONFIG_ATH79_MACH_TL_WR720N_V3) += mach-tl-wr720n-v3.o
|
||||
+obj-$(CONFIG_ATH79_MACH_TUBE2H) += mach-tube2h.o
|
||||
obj-$(CONFIG_ATH79_MACH_UBNT) += mach-ubnt.o
|
||||
obj-$(CONFIG_ATH79_MACH_UBNT_XM) += mach-ubnt-xm.o
|
||||
obj-$(CONFIG_ATH79_MACH_WHR_HP_G300N) += mach-whr-hp-g300n.o
|
Loading…
Reference in New Issue