mirror of https://github.com/hak5/openwrt.git
generic: fix patching error on kernel 5.4
Fixes a build error seen when applying the kernel patches.
Applying patch generic/435-mtd-add-routerbootpart-parser-config.patch
patching file drivers/mtd/parsers/Kconfig
Hunk #1 FAILED at 160.
1 out of 1 hunk FAILED -- rejects in file drivers/mtd/parsers/Kconfig
patching file drivers/mtd/parsers/Makefile
Hunk #1 FAILED at 10.
1 out of 1 hunk FAILED -- rejects in file drivers/mtd/parsers/Makefile
This was missed as 5.4 is currently set as testing kernel
while the main kernel being used is 4.19
Fixes: 2976e423dc
("generic: routerboot partition build bits")
Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
master
parent
5e50515fa6
commit
51a7184a7d
|
@ -16,10 +16,10 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
|
||||||
|
|
||||||
--- a/drivers/mtd/parsers/Kconfig
|
--- a/drivers/mtd/parsers/Kconfig
|
||||||
+++ b/drivers/mtd/parsers/Kconfig
|
+++ b/drivers/mtd/parsers/Kconfig
|
||||||
@@ -160,3 +160,12 @@ config MTD_REDBOOT_PARTS_READONLY
|
@@ -176,3 +176,12 @@ config MTD_MYLOADER_PARTS
|
||||||
'FIS directory' images, enable this option.
|
|
||||||
|
|
||||||
endif # MTD_REDBOOT_PARTS
|
You will still need the parsing functions to be called by the driver
|
||||||
|
for your particular device. It won't happen automatically.
|
||||||
+
|
+
|
||||||
+config MTD_ROUTERBOOT_PARTS
|
+config MTD_ROUTERBOOT_PARTS
|
||||||
+ tristate "RouterBoot flash partition parser"
|
+ tristate "RouterBoot flash partition parser"
|
||||||
|
@ -31,8 +31,10 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
|
||||||
+ formatted DTS.
|
+ formatted DTS.
|
||||||
--- a/drivers/mtd/parsers/Makefile
|
--- a/drivers/mtd/parsers/Makefile
|
||||||
+++ b/drivers/mtd/parsers/Makefile
|
+++ b/drivers/mtd/parsers/Makefile
|
||||||
@@ -10,3 +10,4 @@
|
@@ -9,4 +9,5 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
||||||
|
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
|
||||||
obj-$(CONFIG_MTD_SHARPSL_PARTS) += sharpslpart.o
|
obj-$(CONFIG_MTD_SHARPSL_PARTS) += sharpslpart.o
|
||||||
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
||||||
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
-obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
||||||
|
+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
||||||
+obj-$(CONFIG_MTD_ROUTERBOOT_PARTS) += routerbootpart.o
|
+obj-$(CONFIG_MTD_ROUTERBOOT_PARTS) += routerbootpart.o
|
||||||
|
|
Loading…
Reference in New Issue