mirror of https://github.com/hak5/openwrt.git
iproute2: q_cake: Also print nonat, nowash and no-ack-filter keywords
Pull in latest upstream tweaks:
Similar to the previous patch for no-split-gso, the negative keywords for
'nat', 'wash' and 'ack-filter' were not printed either. Add those as well.
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
(cherry picked from commit 033f02b9b5
)
openwrt-18.06
parent
e60be11330
commit
4f6ad3c13a
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=iproute2
|
||||
PKG_VERSION:=4.16.0
|
||||
PKG_RELEASE:=7
|
||||
PKG_RELEASE:=8
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
|
||||
|
|
|
@ -854,7 +854,7 @@
|
|||
TCMODULES += e_bpf.o
|
||||
--- /dev/null
|
||||
+++ b/tc/q_cake.c
|
||||
@@ -0,0 +1,801 @@
|
||||
@@ -0,0 +1,805 @@
|
||||
+// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
|
||||
+
|
||||
+/*
|
||||
|
@ -1325,6 +1325,8 @@
|
|||
+
|
||||
+ if (nat)
|
||||
+ print_string(PRINT_FP, NULL, "nat ", NULL);
|
||||
+ else
|
||||
+ print_string(PRINT_FP, NULL, "nonat ", NULL);
|
||||
+ print_bool(PRINT_JSON, "nat", NULL, nat);
|
||||
+
|
||||
+ if (tb[TCA_CAKE_WASH] &&
|
||||
|
@ -1365,6 +1367,8 @@
|
|||
+
|
||||
+ if (wash)
|
||||
+ print_string(PRINT_FP, NULL, "wash ", NULL);
|
||||
+ else
|
||||
+ print_string(PRINT_FP, NULL, "nowash ", NULL);
|
||||
+ print_bool(PRINT_JSON, "wash", NULL, wash);
|
||||
+
|
||||
+ if (ingress)
|
||||
|
@ -1377,7 +1381,7 @@
|
|||
+ else if (ack_filter == CAKE_ACK_FILTER)
|
||||
+ print_string(PRINT_ANY, "ack-filter", "ack-filter ", "enabled");
|
||||
+ else
|
||||
+ print_string(PRINT_JSON, "ack-filter", NULL, "disabled");
|
||||
+ print_string(PRINT_ANY, "ack-filter", "no-ack-filter ", "disabled");
|
||||
+
|
||||
+ if (split_gso)
|
||||
+ print_string(PRINT_FP, NULL, "split-gso ", NULL);
|
||||
|
|
Loading…
Reference in New Issue