mirror of https://github.com/hak5/openwrt.git
kernel: Update to version 4.4.194
Compile and runtime tested on lantiq. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>lede-17.01
parent
0082e90e4f
commit
4f6837180e
|
@ -3,10 +3,10 @@
|
|||
LINUX_RELEASE?=1
|
||||
|
||||
LINUX_VERSION-3.18 = .43
|
||||
LINUX_VERSION-4.4 = .184
|
||||
LINUX_VERSION-4.4 = .194
|
||||
|
||||
LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
|
||||
LINUX_KERNEL_HASH-4.4.184 = 6543232fc082485c1088830b9456e1a6e511239e4bf98817b0166ee62cafc3ca
|
||||
LINUX_KERNEL_HASH-4.4.194 = 7f63e893f1a178c25646a302ae7425423a3f1b72fc5d6895a2716e4bb6b8744f
|
||||
|
||||
ifdef KERNEL_PATCHVER
|
||||
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
|
||||
|
|
|
@ -12,7 +12,7 @@
|
|||
# ZLIB_INFLATE; DECOMPRESS_GZIP is just a wrapper.)
|
||||
--- a/lib/Makefile
|
||||
+++ b/lib/Makefile
|
||||
@@ -108,6 +108,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
|
||||
@@ -109,6 +109,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
|
||||
obj-$(CONFIG_RAID6_PQ) += raid6/
|
||||
obj-$(CONFIG_LZMA_COMPRESS) += lzma/
|
||||
obj-$(CONFIG_LZMA_DECOMPRESS) += lzma/
|
||||
|
|
|
@ -10,7 +10,7 @@
|
|||
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -1121,6 +1121,9 @@ config MIPS_MSC
|
||||
@@ -1119,6 +1119,9 @@ config MIPS_MSC
|
||||
config MIPS_NILE4
|
||||
bool
|
||||
|
||||
|
|
|
@ -202,7 +202,7 @@
|
|||
+subsys_initcall(ar5312_gpio_init);
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -118,6 +118,7 @@ config ATH25
|
||||
@@ -119,6 +119,7 @@ config ATH25
|
||||
select SYS_SUPPORTS_BIG_ENDIAN
|
||||
select SYS_SUPPORTS_32BIT_KERNEL
|
||||
select SYS_HAS_EARLY_PRINTK
|
||||
|
|
|
@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|||
|
||||
--- a/drivers/spi/spi-bcm2835.c
|
||||
+++ b/drivers/spi/spi-bcm2835.c
|
||||
@@ -686,6 +686,8 @@ static int bcm2835_spi_setup(struct spi_
|
||||
@@ -687,6 +687,8 @@ static int bcm2835_spi_setup(struct spi_
|
||||
{
|
||||
int err;
|
||||
struct gpio_chip *chip;
|
||||
|
@ -28,7 +28,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|||
/*
|
||||
* sanity checking the native-chipselects
|
||||
*/
|
||||
@@ -702,15 +704,42 @@ static int bcm2835_spi_setup(struct spi_
|
||||
@@ -703,15 +705,42 @@ static int bcm2835_spi_setup(struct spi_
|
||||
"setup: only two native chip-selects are supported\n");
|
||||
return -EINVAL;
|
||||
}
|
||||
|
|
|
@ -659,7 +659,7 @@ dwc_otg: Remove duplicate gadget probe/unregister function
|
|||
}
|
||||
--- a/drivers/usb/core/hub.c
|
||||
+++ b/drivers/usb/core/hub.c
|
||||
@@ -5014,7 +5014,7 @@ static void port_event(struct usb_hub *h
|
||||
@@ -5021,7 +5021,7 @@ static void port_event(struct usb_hub *h
|
||||
if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
|
||||
u16 status = 0, unused;
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ Subject: [PATCH] config: Enable CONFIG_MEMCG, but leave it disabled (due to
|
|||
|
||||
--- a/kernel/cgroup.c
|
||||
+++ b/kernel/cgroup.c
|
||||
@@ -5315,7 +5315,7 @@ int __init cgroup_init_early(void)
|
||||
@@ -5321,7 +5321,7 @@ int __init cgroup_init_early(void)
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
@ -19,7 +19,7 @@ Subject: [PATCH] config: Enable CONFIG_MEMCG, but leave it disabled (due to
|
|||
|
||||
/**
|
||||
* cgroup_init - cgroup initialization
|
||||
@@ -5811,6 +5811,27 @@ static int __init cgroup_disable(char *s
|
||||
@@ -5817,6 +5817,27 @@ static int __init cgroup_disable(char *s
|
||||
}
|
||||
__setup("cgroup_disable=", cgroup_disable);
|
||||
|
||||
|
|
|
@ -28,7 +28,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|||
i2c0: i2c@7e205000 {
|
||||
--- a/drivers/spi/spi-bcm2835.c
|
||||
+++ b/drivers/spi/spi-bcm2835.c
|
||||
@@ -705,6 +705,7 @@ static int bcm2835_spi_setup(struct spi_
|
||||
@@ -706,6 +706,7 @@ static int bcm2835_spi_setup(struct spi_
|
||||
return -EINVAL;
|
||||
}
|
||||
|
||||
|
@ -36,7 +36,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|||
/* now translate native cs to GPIO */
|
||||
/* first look for chip select pins in the devices pin groups */
|
||||
for (pingroup_index = 0;
|
||||
@@ -759,6 +760,7 @@ static int bcm2835_spi_setup(struct spi_
|
||||
@@ -760,6 +761,7 @@ static int bcm2835_spi_setup(struct spi_
|
||||
* so we are setting it here explicitly
|
||||
*/
|
||||
gpio_set_value(spi->cs_gpio, (spi->mode & SPI_CS_HIGH) ? 0 : 1);
|
||||
|
|
|
@ -9,7 +9,7 @@ Subject: [PATCH] spi-bcm2835: Remove unused code
|
|||
|
||||
--- a/drivers/spi/spi-bcm2835.c
|
||||
+++ b/drivers/spi/spi-bcm2835.c
|
||||
@@ -677,17 +677,8 @@ static void bcm2835_spi_set_cs(struct sp
|
||||
@@ -678,17 +678,8 @@ static void bcm2835_spi_set_cs(struct sp
|
||||
bcm2835_wr(bs, BCM2835_SPI_CS, cs);
|
||||
}
|
||||
|
||||
|
@ -27,7 +27,7 @@ Subject: [PATCH] spi-bcm2835: Remove unused code
|
|||
/*
|
||||
* sanity checking the native-chipselects
|
||||
*/
|
||||
@@ -705,63 +696,6 @@ static int bcm2835_spi_setup(struct spi_
|
||||
@@ -706,63 +697,6 @@ static int bcm2835_spi_setup(struct spi_
|
||||
return -EINVAL;
|
||||
}
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -207,6 +207,9 @@ config BCM63XX
|
||||
@@ -208,6 +208,9 @@ config BCM63XX
|
||||
select SYNC_R4K
|
||||
select DMA_NONCOHERENT
|
||||
select IRQ_MIPS_CPU
|
||||
|
|
|
@ -4105,6 +4105,7 @@ CONFIG_TCP_CONG_CUBIC=y
|
|||
# CONFIG_TERANETICS_PHY is not set
|
||||
# CONFIG_TEST_BPF is not set
|
||||
# CONFIG_TEST_FIRMWARE is not set
|
||||
# CONFIG_TEST_HASH is not set
|
||||
# CONFIG_TEST_HEXDUMP is not set
|
||||
# CONFIG_TEST_KSTRTOX is not set
|
||||
# CONFIG_TEST_LIST_SORT is not set
|
||||
|
|
|
@ -27,7 +27,7 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
|
|||
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -2756,10 +2756,10 @@ choice
|
||||
@@ -2754,10 +2754,10 @@ choice
|
||||
the documented boot protocol using a device tree.
|
||||
|
||||
config MIPS_RAW_APPENDED_DTB
|
||||
|
@ -40,7 +40,7 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
|
|||
(e.g. cat vmlinux.bin <filename>.dtb > vmlinux_w_dtb).
|
||||
|
||||
This is meant as a backward compatibility convenience for those
|
||||
@@ -2771,24 +2771,6 @@ choice
|
||||
@@ -2769,24 +2769,6 @@ choice
|
||||
look like a DTB header after a reboot if no actual DTB is appended
|
||||
to vmlinux.bin. Do not leave this option active in a production kernel
|
||||
if you don't intend to always append a DTB.
|
||||
|
|
|
@ -82,7 +82,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
|
|||
/* Gobi 1000 QMI/wwan interface number is 3 according to qcserial */
|
||||
#define QMI_GOBI1K_DEVICE(vend, prod) \
|
||||
QMI_FIXED_INTF(vend, prod, 3)
|
||||
@@ -916,6 +940,8 @@ static const struct usb_device_id produc
|
||||
@@ -917,6 +941,8 @@ static const struct usb_device_id produc
|
||||
{QMI_FIXED_INTF(0x03f0, 0x9d1d, 1)}, /* HP lt4120 Snapdragon X5 LTE */
|
||||
{QMI_FIXED_INTF(0x22de, 0x9061, 3)}, /* WeTelecom WPD-600N */
|
||||
{QMI_FIXED_INTF(0x1e0e, 0x9001, 5)}, /* SIMCom 7230E */
|
||||
|
|
|
@ -19,7 +19,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -1622,6 +1622,7 @@ config CPU_CAVIUM_OCTEON
|
||||
@@ -1620,6 +1620,7 @@ config CPU_CAVIUM_OCTEON
|
||||
select USB_EHCI_BIG_ENDIAN_MMIO if CPU_BIG_ENDIAN
|
||||
select USB_OHCI_BIG_ENDIAN_MMIO if CPU_BIG_ENDIAN
|
||||
select MIPS_L1_CACHE_SHIFT_7
|
||||
|
@ -27,7 +27,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
help
|
||||
The Cavium Octeon processor is a highly integrated chip containing
|
||||
many ethernet hardware widgets for networking tasks. The processor
|
||||
@@ -1917,6 +1918,9 @@ config MIPS_MALTA_PM
|
||||
@@ -1915,6 +1916,9 @@ config MIPS_MALTA_PM
|
||||
bool
|
||||
default y
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -639,12 +639,12 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
||||
@@ -640,12 +640,12 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
||||
KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)
|
||||
|
||||
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
static int absolute_percpu = 0;
|
||||
static char symbol_prefix_char = '\0';
|
||||
static unsigned long long kernel_start_addr = 0;
|
||||
@@ -403,6 +404,9 @@ static void write_src(void)
|
||||
@@ -406,6 +407,9 @@ static void write_src(void)
|
||||
|
||||
free(markers);
|
||||
|
||||
|
@ -18,7 +18,7 @@
|
|||
output_label("kallsyms_token_table");
|
||||
off = 0;
|
||||
for (i = 0; i < 256; i++) {
|
||||
@@ -461,6 +465,9 @@ static void *find_token(unsigned char *s
|
||||
@@ -464,6 +468,9 @@ static void *find_token(unsigned char *s
|
||||
{
|
||||
int i;
|
||||
|
||||
|
@ -28,7 +28,7 @@
|
|||
for (i = 0; i < len - 1; i++) {
|
||||
if (str[i] == token[0] && str[i+1] == token[1])
|
||||
return &str[i];
|
||||
@@ -533,6 +540,9 @@ static void optimize_result(void)
|
||||
@@ -536,6 +543,9 @@ static void optimize_result(void)
|
||||
{
|
||||
int i, best;
|
||||
|
||||
|
@ -38,7 +38,7 @@
|
|||
/* using the '\0' symbol last allows compress_symbols to use standard
|
||||
* fast string functions */
|
||||
for (i = 255; i >= 0; i--) {
|
||||
@@ -703,7 +713,9 @@ int main(int argc, char **argv)
|
||||
@@ -706,7 +716,9 @@ int main(int argc, char **argv)
|
||||
} else if (strncmp(argv[i], "--page-offset=", 14) == 0) {
|
||||
const char *p = &argv[i][14];
|
||||
kernel_start_addr = strtoull(p, NULL, 16);
|
||||
|
|
|
@ -4,7 +4,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
|
||||
--- a/arch/mips/vdso/Makefile
|
||||
+++ b/arch/mips/vdso/Makefile
|
||||
@@ -28,11 +28,11 @@ aflags-vdso := $(ccflags-vdso) \
|
||||
@@ -30,11 +30,11 @@ aflags-vdso := $(ccflags-vdso) \
|
||||
# the comments on that file.
|
||||
#
|
||||
ifndef CONFIG_CPU_MIPSR6
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/vdso/Makefile
|
||||
+++ b/arch/mips/vdso/Makefile
|
||||
@@ -77,7 +77,7 @@ $(obj-vdso): KBUILD_AFLAGS := $(aflags-v
|
||||
@@ -79,7 +79,7 @@ $(obj-vdso): KBUILD_AFLAGS := $(aflags-v
|
||||
|
||||
$(obj)/vdso.lds: KBUILD_CPPFLAGS := $(ccflags-vdso) $(native-abi)
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
$(call if_changed,vdsold)
|
||||
|
||||
$(obj)/vdso-image.c: $(obj)/vdso.so.dbg $(obj)/genvdso FORCE
|
||||
@@ -111,7 +111,7 @@ $(obj)/vdso-o32.lds: KBUILD_CPPFLAGS :=
|
||||
@@ -113,7 +113,7 @@ $(obj)/vdso-o32.lds: KBUILD_CPPFLAGS :=
|
||||
$(obj)/vdso-o32.lds: $(src)/vdso.lds.S FORCE
|
||||
$(call if_changed_dep,cpp_lds_S)
|
||||
|
||||
|
@ -18,7 +18,7 @@
|
|||
$(call if_changed,vdsold)
|
||||
|
||||
$(obj)/vdso-o32-image.c: VDSO_NAME := o32
|
||||
@@ -147,7 +147,7 @@ $(obj)/vdso-n32.lds: KBUILD_CPPFLAGS :=
|
||||
@@ -149,7 +149,7 @@ $(obj)/vdso-n32.lds: KBUILD_CPPFLAGS :=
|
||||
$(obj)/vdso-n32.lds: $(src)/vdso.lds.S FORCE
|
||||
$(call if_changed_dep,cpp_lds_S)
|
||||
|
||||
|
|
|
@ -79,7 +79,7 @@
|
|||
#include <linux/mutex.h>
|
||||
#include <linux/err.h>
|
||||
#include <linux/of.h>
|
||||
@@ -2869,3 +2870,5 @@ static int __init regmap_initcall(void)
|
||||
@@ -2871,3 +2872,5 @@ static int __init regmap_initcall(void)
|
||||
return 0;
|
||||
}
|
||||
postcore_initcall(regmap_initcall);
|
||||
|
|
|
@ -8,7 +8,7 @@ Acked-by: Rob Landley <rob@landley.net>
|
|||
---
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -1036,9 +1036,6 @@ config FW_ARC
|
||||
@@ -1034,9 +1034,6 @@ config FW_ARC
|
||||
config ARCH_MAY_HAVE_PC_FDC
|
||||
bool
|
||||
|
||||
|
@ -18,7 +18,7 @@ Acked-by: Rob Landley <rob@landley.net>
|
|||
config CEVT_BCM1480
|
||||
bool
|
||||
|
||||
@@ -2796,6 +2793,18 @@ choice
|
||||
@@ -2794,6 +2791,18 @@ choice
|
||||
bool "Bootloader kernel arguments if available"
|
||||
endchoice
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -1127,6 +1127,10 @@ config SYNC_R4K
|
||||
@@ -1125,6 +1125,10 @@ config SYNC_R4K
|
||||
config MIPS_MACHINE
|
||||
def_bool n
|
||||
|
||||
|
|
|
@ -26,7 +26,7 @@ v2: incorporated changes suggested by Jonas Gorski
|
|||
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -2728,6 +2728,20 @@ config MIPS_O32_FP64_SUPPORT
|
||||
@@ -2726,6 +2726,20 @@ config MIPS_O32_FP64_SUPPORT
|
||||
|
||||
If unsure, say N.
|
||||
|
||||
|
|
|
@ -40,7 +40,7 @@ Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
|
|||
;----------------------------------------------------------------
|
||||
--- a/arch/arc/kernel/setup.c
|
||||
+++ b/arch/arc/kernel/setup.c
|
||||
@@ -366,6 +366,8 @@ static inline int is_kernel(unsigned lon
|
||||
@@ -364,6 +364,8 @@ static inline int is_kernel(unsigned lon
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
@ -49,7 +49,7 @@ Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
|
|||
void __init setup_arch(char **cmdline_p)
|
||||
{
|
||||
#ifdef CONFIG_ARC_UBOOT_SUPPORT
|
||||
@@ -379,7 +381,7 @@ void __init setup_arch(char **cmdline_p)
|
||||
@@ -377,7 +379,7 @@ void __init setup_arch(char **cmdline_p)
|
||||
#endif
|
||||
{
|
||||
/* No, so try the embedded one */
|
||||
|
|
|
@ -1081,7 +1081,7 @@
|
|||
ifdef CONFIG_FUNCTION_TRACER
|
||||
ORIG_CFLAGS := $(KBUILD_CFLAGS)
|
||||
KBUILD_CFLAGS = $(subst $(CC_FLAGS_FTRACE),,$(ORIG_CFLAGS))
|
||||
@@ -96,6 +106,8 @@ obj-$(CONFIG_LZ4HC_COMPRESS) += lz4/
|
||||
@@ -97,6 +107,8 @@ obj-$(CONFIG_LZ4HC_COMPRESS) += lz4/
|
||||
obj-$(CONFIG_LZ4_DECOMPRESS) += lz4/
|
||||
obj-$(CONFIG_XZ_DEC) += xz/
|
||||
obj-$(CONFIG_RAID6_PQ) += raid6/
|
||||
|
|
|
@ -22,7 +22,7 @@ Link: https://bugzilla.kernel.org/show_bug.cgi?id=109581
|
|||
|
||||
--- a/net/sched/sch_codel.c
|
||||
+++ b/net/sched/sch_codel.c
|
||||
@@ -79,11 +79,17 @@ static struct sk_buff *codel_qdisc_deque
|
||||
@@ -80,11 +80,17 @@ static struct sk_buff *codel_qdisc_deque
|
||||
|
||||
skb = codel_dequeue(sch, &q->params, &q->vars, &q->stats, dequeue);
|
||||
|
||||
|
|
|
@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
if (!net_eq(dev_net(dev), sock_net(sk)))
|
||||
goto drop;
|
||||
|
||||
@@ -3148,6 +3150,7 @@ static int packet_create(struct net *net
|
||||
@@ -3155,6 +3157,7 @@ static int packet_create(struct net *net
|
||||
mutex_init(&po->pg_vec_lock);
|
||||
po->rollover = NULL;
|
||||
po->prot_hook.func = packet_rcv;
|
||||
|
@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
|
||||
if (sock->type == SOCK_PACKET)
|
||||
po->prot_hook.func = packet_rcv_spkt;
|
||||
@@ -3806,6 +3809,16 @@ packet_setsockopt(struct socket *sock, i
|
||||
@@ -3813,6 +3816,16 @@ packet_setsockopt(struct socket *sock, i
|
||||
po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
|
||||
return 0;
|
||||
}
|
||||
|
@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
default:
|
||||
return -ENOPROTOOPT;
|
||||
}
|
||||
@@ -3858,6 +3871,13 @@ static int packet_getsockopt(struct sock
|
||||
@@ -3865,6 +3878,13 @@ static int packet_getsockopt(struct sock
|
||||
case PACKET_VNET_HDR:
|
||||
val = po->has_vnet_hdr;
|
||||
break;
|
||||
|
|
|
@ -135,14 +135,14 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
struct igmpv3_report *ih;
|
||||
struct igmpv3_grec *grec;
|
||||
int i;
|
||||
@@ -1043,12 +1067,13 @@ static int br_ip4_multicast_igmp3_report
|
||||
@@ -1045,12 +1069,13 @@ static int br_ip4_multicast_igmp3_report
|
||||
continue;
|
||||
}
|
||||
|
||||
+ src = eth_hdr(skb)->h_source;
|
||||
if ((type == IGMPV3_CHANGE_TO_INCLUDE ||
|
||||
type == IGMPV3_MODE_IS_INCLUDE) &&
|
||||
ntohs(grec->grec_nsrcs) == 0) {
|
||||
nsrcs == 0) {
|
||||
- br_ip4_multicast_leave_group(br, port, group, vid);
|
||||
+ br_ip4_multicast_leave_group(br, port, group, vid, src);
|
||||
} else {
|
||||
|
@ -151,7 +151,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
if (err)
|
||||
break;
|
||||
}
|
||||
@@ -1063,6 +1088,7 @@ static int br_ip6_multicast_mld2_report(
|
||||
@@ -1065,6 +1090,7 @@ static int br_ip6_multicast_mld2_report(
|
||||
struct sk_buff *skb,
|
||||
u16 vid)
|
||||
{
|
||||
|
@ -159,9 +159,9 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
struct icmp6hdr *icmp6h;
|
||||
struct mld2_grec *grec;
|
||||
int i;
|
||||
@@ -1114,10 +1140,10 @@ static int br_ip6_multicast_mld2_report(
|
||||
@@ -1119,10 +1145,10 @@ static int br_ip6_multicast_mld2_report(
|
||||
grec->grec_type == MLD2_MODE_IS_INCLUDE) &&
|
||||
ntohs(*nsrcs) == 0) {
|
||||
nsrcs == 0) {
|
||||
br_ip6_multicast_leave_group(br, port, &grec->grec_mca,
|
||||
- vid);
|
||||
+ vid, src);
|
||||
|
@ -172,7 +172,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
if (err)
|
||||
break;
|
||||
}
|
||||
@@ -1432,7 +1458,8 @@ br_multicast_leave_group(struct net_brid
|
||||
@@ -1436,7 +1462,8 @@ br_multicast_leave_group(struct net_brid
|
||||
struct net_bridge_port *port,
|
||||
struct br_ip *group,
|
||||
struct bridge_mcast_other_query *other_query,
|
||||
|
@ -182,7 +182,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
{
|
||||
struct net_bridge_mdb_htable *mdb;
|
||||
struct net_bridge_mdb_entry *mp;
|
||||
@@ -1456,7 +1483,7 @@ br_multicast_leave_group(struct net_brid
|
||||
@@ -1460,7 +1487,7 @@ br_multicast_leave_group(struct net_brid
|
||||
for (pp = &mp->ports;
|
||||
(p = mlock_dereference(*pp, br)) != NULL;
|
||||
pp = &p->next) {
|
||||
|
@ -191,7 +191,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
continue;
|
||||
|
||||
rcu_assign_pointer(*pp, p->next);
|
||||
@@ -1519,7 +1546,7 @@ br_multicast_leave_group(struct net_brid
|
||||
@@ -1523,7 +1550,7 @@ br_multicast_leave_group(struct net_brid
|
||||
for (p = mlock_dereference(mp->ports, br);
|
||||
p != NULL;
|
||||
p = mlock_dereference(p->next, br)) {
|
||||
|
@ -200,7 +200,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
continue;
|
||||
|
||||
if (!hlist_unhashed(&p->mglist) &&
|
||||
@@ -1537,8 +1564,8 @@ out:
|
||||
@@ -1541,8 +1568,8 @@ out:
|
||||
|
||||
static void br_ip4_multicast_leave_group(struct net_bridge *br,
|
||||
struct net_bridge_port *port,
|
||||
|
@ -211,7 +211,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
{
|
||||
struct br_ip br_group;
|
||||
struct bridge_mcast_own_query *own_query;
|
||||
@@ -1553,14 +1580,14 @@ static void br_ip4_multicast_leave_group
|
||||
@@ -1557,14 +1584,14 @@ static void br_ip4_multicast_leave_group
|
||||
br_group.vid = vid;
|
||||
|
||||
br_multicast_leave_group(br, port, &br_group, &br->ip4_other_query,
|
||||
|
@ -228,7 +228,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
{
|
||||
struct br_ip br_group;
|
||||
struct bridge_mcast_own_query *own_query;
|
||||
@@ -1575,7 +1602,7 @@ static void br_ip6_multicast_leave_group
|
||||
@@ -1579,7 +1606,7 @@ static void br_ip6_multicast_leave_group
|
||||
br_group.vid = vid;
|
||||
|
||||
br_multicast_leave_group(br, port, &br_group, &br->ip6_other_query,
|
||||
|
@ -237,7 +237,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
}
|
||||
#endif
|
||||
|
||||
@@ -1584,6 +1611,7 @@ static int br_multicast_ipv4_rcv(struct
|
||||
@@ -1588,6 +1615,7 @@ static int br_multicast_ipv4_rcv(struct
|
||||
struct sk_buff *skb,
|
||||
u16 vid)
|
||||
{
|
||||
|
@ -245,7 +245,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
struct sk_buff *skb_trimmed = NULL;
|
||||
struct igmphdr *ih;
|
||||
int err;
|
||||
@@ -1600,12 +1628,13 @@ static int br_multicast_ipv4_rcv(struct
|
||||
@@ -1604,12 +1632,13 @@ static int br_multicast_ipv4_rcv(struct
|
||||
|
||||
BR_INPUT_SKB_CB(skb)->igmp = 1;
|
||||
ih = igmp_hdr(skb);
|
||||
|
@ -260,7 +260,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
break;
|
||||
case IGMPV3_HOST_MEMBERSHIP_REPORT:
|
||||
err = br_ip4_multicast_igmp3_report(br, port, skb_trimmed, vid);
|
||||
@@ -1614,7 +1643,7 @@ static int br_multicast_ipv4_rcv(struct
|
||||
@@ -1618,7 +1647,7 @@ static int br_multicast_ipv4_rcv(struct
|
||||
err = br_ip4_multicast_query(br, port, skb_trimmed, vid);
|
||||
break;
|
||||
case IGMP_HOST_LEAVE_MESSAGE:
|
||||
|
@ -269,7 +269,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
break;
|
||||
}
|
||||
|
||||
@@ -1630,6 +1659,7 @@ static int br_multicast_ipv6_rcv(struct
|
||||
@@ -1634,6 +1663,7 @@ static int br_multicast_ipv6_rcv(struct
|
||||
struct sk_buff *skb,
|
||||
u16 vid)
|
||||
{
|
||||
|
@ -277,7 +277,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
struct sk_buff *skb_trimmed = NULL;
|
||||
struct mld_msg *mld;
|
||||
int err;
|
||||
@@ -1649,8 +1679,9 @@ static int br_multicast_ipv6_rcv(struct
|
||||
@@ -1653,8 +1683,9 @@ static int br_multicast_ipv6_rcv(struct
|
||||
|
||||
switch (mld->mld_type) {
|
||||
case ICMPV6_MGM_REPORT:
|
||||
|
@ -288,7 +288,7 @@ Implement optinal multicast->unicast conversion for igmp snooping
|
|||
break;
|
||||
case ICMPV6_MLD2_REPORT:
|
||||
err = br_ip6_multicast_mld2_report(br, port, skb_trimmed, vid);
|
||||
@@ -1659,7 +1690,8 @@ static int br_multicast_ipv6_rcv(struct
|
||||
@@ -1663,7 +1694,8 @@ static int br_multicast_ipv6_rcv(struct
|
||||
err = br_ip6_multicast_query(br, port, skb_trimmed, vid);
|
||||
break;
|
||||
case ICMPV6_MGM_REDUCTION:
|
||||
|
|
|
@ -51,7 +51,7 @@
|
|||
EXPORT_SYMBOL(default_qdisc_ops);
|
||||
|
||||
/* Main transmission queue. */
|
||||
@@ -731,7 +731,7 @@ static void attach_one_default_qdisc(str
|
||||
@@ -735,7 +735,7 @@ static void attach_one_default_qdisc(str
|
||||
void *_unused)
|
||||
{
|
||||
struct Qdisc *qdisc;
|
||||
|
|
|
@ -15,7 +15,7 @@
|
|||
|
||||
--- a/drivers/net/phy/phy_device.c
|
||||
+++ b/drivers/net/phy/phy_device.c
|
||||
@@ -995,6 +995,9 @@ int genphy_update_link(struct phy_device
|
||||
@@ -1001,6 +1001,9 @@ int genphy_update_link(struct phy_device
|
||||
{
|
||||
int status;
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/phy_device.c
|
||||
+++ b/drivers/net/phy/phy_device.c
|
||||
@@ -734,6 +734,9 @@ void phy_detach(struct phy_device *phyde
|
||||
@@ -740,6 +740,9 @@ void phy_detach(struct phy_device *phyde
|
||||
struct mii_bus *bus;
|
||||
int i;
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@
|
|||
static struct amd_chipset_info {
|
||||
struct pci_dev *nb_dev;
|
||||
struct pci_dev *smbus_dev;
|
||||
@@ -458,6 +460,10 @@ void usb_amd_dev_put(void)
|
||||
@@ -465,6 +467,10 @@ void usb_amd_dev_put(void)
|
||||
}
|
||||
EXPORT_SYMBOL_GPL(usb_amd_dev_put);
|
||||
|
||||
|
@ -21,7 +21,7 @@
|
|||
/*
|
||||
* Make sure the controller is completely inactive, unable to
|
||||
* generate interrupts or do DMA.
|
||||
@@ -537,8 +543,17 @@ reset_needed:
|
||||
@@ -544,8 +550,17 @@ reset_needed:
|
||||
uhci_reset_hc(pdev, base);
|
||||
return 1;
|
||||
}
|
||||
|
@ -39,7 +39,7 @@
|
|||
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
|
||||
{
|
||||
u16 cmd;
|
||||
@@ -1103,3 +1118,4 @@ static void quirk_usb_early_handoff(stru
|
||||
@@ -1110,3 +1125,4 @@ static void quirk_usb_early_handoff(stru
|
||||
}
|
||||
DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
|
||||
PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);
|
||||
|
|
|
@ -111,7 +111,7 @@
|
|||
if (!root_irq_dir)
|
||||
--- a/kernel/time/timer_list.c
|
||||
+++ b/kernel/time/timer_list.c
|
||||
@@ -399,6 +399,8 @@ static int __init init_timer_list_procfs
|
||||
@@ -400,6 +400,8 @@ static int __init init_timer_list_procfs
|
||||
{
|
||||
struct proc_dir_entry *pe;
|
||||
|
||||
|
@ -122,7 +122,7 @@
|
|||
return -ENOMEM;
|
||||
--- a/mm/vmalloc.c
|
||||
+++ b/mm/vmalloc.c
|
||||
@@ -2689,6 +2689,8 @@ static const struct file_operations proc
|
||||
@@ -2698,6 +2698,8 @@ static const struct file_operations proc
|
||||
|
||||
static int __init proc_vmalloc_init(void)
|
||||
{
|
||||
|
@ -133,7 +133,7 @@
|
|||
}
|
||||
--- a/mm/vmstat.c
|
||||
+++ b/mm/vmstat.c
|
||||
@@ -1574,10 +1574,12 @@ static int __init setup_vmstat(void)
|
||||
@@ -1588,10 +1588,12 @@ static int __init setup_vmstat(void)
|
||||
cpu_notifier_register_done();
|
||||
#endif
|
||||
#ifdef CONFIG_PROC_FS
|
||||
|
|
|
@ -27,7 +27,7 @@
|
|||
int val = 0;
|
||||
int edge = 0;
|
||||
|
||||
@@ -176,7 +176,7 @@ static unsigned int ltq_startup_eiu_irq(
|
||||
@@ -177,7 +177,7 @@ static unsigned int ltq_startup_eiu_irq(
|
||||
|
||||
ltq_enable_irq(d);
|
||||
for (i = 0; i < MAX_EIU; i++) {
|
||||
|
@ -36,7 +36,7 @@
|
|||
/* by default we are low level triggered */
|
||||
ltq_eiu_settype(d, IRQF_TRIGGER_LOW);
|
||||
/* clear all pending */
|
||||
@@ -198,7 +198,7 @@ static void ltq_shutdown_eiu_irq(struct
|
||||
@@ -199,7 +199,7 @@ static void ltq_shutdown_eiu_irq(struct
|
||||
|
||||
ltq_disable_irq(d);
|
||||
for (i = 0; i < MAX_EIU; i++) {
|
||||
|
@ -45,7 +45,7 @@
|
|||
/* disable */
|
||||
ltq_eiu_w32(ltq_eiu_r32(LTQ_EIU_EXIN_INEN) & ~BIT(i),
|
||||
LTQ_EIU_EXIN_INEN);
|
||||
@@ -343,10 +343,10 @@ static int icu_map(struct irq_domain *d,
|
||||
@@ -344,10 +344,10 @@ static int icu_map(struct irq_domain *d,
|
||||
return 0;
|
||||
|
||||
for (i = 0; i < exin_avail; i++)
|
||||
|
@ -58,7 +58,7 @@
|
|||
|
||||
return 0;
|
||||
}
|
||||
@@ -441,14 +441,14 @@ int __init icu_of_init(struct device_nod
|
||||
@@ -442,14 +442,14 @@ int __init icu_of_init(struct device_nod
|
||||
eiu_node = of_find_compatible_node(NULL, NULL, "lantiq,eiu-xway");
|
||||
if (eiu_node && !of_address_to_resource(eiu_node, 0, &res)) {
|
||||
/* find out how many external irq sources we have */
|
||||
|
|
|
@ -18,7 +18,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
|
||||
--- a/arch/mips/lantiq/irq.c
|
||||
+++ b/arch/mips/lantiq/irq.c
|
||||
@@ -271,6 +271,11 @@ static void ltq_hw5_irqdispatch(void)
|
||||
@@ -272,6 +272,11 @@ static void ltq_hw5_irqdispatch(void)
|
||||
DEFINE_HWx_IRQDISPATCH(5)
|
||||
#endif
|
||||
|
||||
|
@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
#ifdef CONFIG_MIPS_MT_SMP
|
||||
void __init arch_init_ipiirq(int irq, struct irqaction *action)
|
||||
{
|
||||
@@ -315,23 +320,19 @@ static struct irqaction irq_call = {
|
||||
@@ -316,23 +321,19 @@ static struct irqaction irq_call = {
|
||||
asmlinkage void plat_irq_dispatch(void)
|
||||
{
|
||||
unsigned int pending = read_c0_status() & read_c0_cause() & ST0_IM;
|
||||
|
@ -64,7 +64,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
}
|
||||
|
||||
static int icu_map(struct irq_domain *d, unsigned int irq, irq_hw_number_t hw)
|
||||
@@ -356,11 +357,6 @@ static const struct irq_domain_ops irq_d
|
||||
@@ -357,11 +358,6 @@ static const struct irq_domain_ops irq_d
|
||||
.map = icu_map,
|
||||
};
|
||||
|
||||
|
@ -76,7 +76,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
int __init icu_of_init(struct device_node *node, struct device_node *parent)
|
||||
{
|
||||
struct device_node *eiu_node;
|
||||
@@ -392,7 +388,7 @@ int __init icu_of_init(struct device_nod
|
||||
@@ -393,7 +389,7 @@ int __init icu_of_init(struct device_nod
|
||||
mips_cpu_irq_init();
|
||||
|
||||
for (i = 0; i < MAX_IM; i++)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -2224,6 +2224,12 @@ config MIPS_VPE_LOADER
|
||||
@@ -2222,6 +2222,12 @@ config MIPS_VPE_LOADER
|
||||
Includes a loader for loading an elf relocatable object
|
||||
onto another VPE and running it.
|
||||
|
||||
|
|
|
@ -163,7 +163,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||
/**
|
||||
* phy_prepare_link - prepares the PHY layer to monitor link status
|
||||
* @phydev: target phy_device struct
|
||||
@@ -659,6 +672,7 @@ int phy_attach_direct(struct net_device
|
||||
@@ -662,6 +675,7 @@ int phy_attach_direct(struct net_device
|
||||
goto error;
|
||||
}
|
||||
|
||||
|
|
|
@ -85,7 +85,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||
obj-$(CONFIG_AQUANTIA_PHY) += aquantia.o
|
||||
--- a/drivers/net/phy/phy_device.c
|
||||
+++ b/drivers/net/phy/phy_device.c
|
||||
@@ -754,6 +754,7 @@ void phy_detach(struct phy_device *phyde
|
||||
@@ -760,6 +760,7 @@ void phy_detach(struct phy_device *phyde
|
||||
phydev->attached_dev->phydev = NULL;
|
||||
phydev->attached_dev = NULL;
|
||||
phy_suspend(phydev);
|
||||
|
|
|
@ -14,7 +14,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -586,6 +586,8 @@ config RALINK
|
||||
@@ -587,6 +587,8 @@ config RALINK
|
||||
select CLKDEV_LOOKUP
|
||||
select ARCH_HAS_RESET_CONTROLLER
|
||||
select RESET_CONTROLLER
|
||||
|
|
|
@ -14,7 +14,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -588,6 +588,9 @@ config RALINK
|
||||
@@ -589,6 +589,9 @@ config RALINK
|
||||
select RESET_CONTROLLER
|
||||
select PINCTRL
|
||||
select PINCTRL_RT2880
|
||||
|
|
|
@ -123,7 +123,7 @@
|
|||
};
|
||||
--- a/arch/um/os-Linux/file.c
|
||||
+++ b/arch/um/os-Linux/file.c
|
||||
@@ -535,6 +535,8 @@ int os_create_unix_socket(const char *fi
|
||||
@@ -536,6 +536,8 @@ int os_create_unix_socket(const char *fi
|
||||
|
||||
addr.sun_family = AF_UNIX;
|
||||
|
||||
|
|
Loading…
Reference in New Issue