mirror of https://github.com/hak5/openwrt.git
parent
ec495381c0
commit
4f1fa57c09
|
@ -3,9 +3,9 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=freeradius
|
||||
PKG_VERSION:=1.0.5
|
||||
PKG_VERSION:=1.1.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=00d06fc31e3b8279f6456d25401c81cb
|
||||
PKG_MD5SUM:=b38b24f6352090fdb571b9e8da52e12e
|
||||
|
||||
PKG_SOURCE_URL:=ftp://ftp.freeradius.org/pub/radius/ \
|
||||
http://freeradius.portal-to-web.de/ \
|
||||
|
@ -38,6 +38,7 @@ PKG_CONFIGURE_OPTIONS := \
|
|||
--without-rlm_example \
|
||||
--without-rlm_ippool \
|
||||
--without-rlm_krb5 \
|
||||
--without-rlm_otp \
|
||||
--without-rlm_pam \
|
||||
--without-rlm_perl \
|
||||
--without-rlm_python \
|
||||
|
@ -51,10 +52,11 @@ PKG_CONFIGURE_OPTIONS := \
|
|||
--without-rlm_sql_oracle \
|
||||
--without-rlm_sql_sybase \
|
||||
--without-rlm_sql_unixodbc \
|
||||
--without-rlm_sql_log \
|
||||
--without-rlm_unix \
|
||||
--without-rlm_x99-token \
|
||||
|
||||
ifneq ($(BR2_PACKAGE_FREERADIUS_MOD_LDAP),)
|
||||
PKG_CONFIGURE_LIBS += -lcrypto -lssl
|
||||
PKG_CONFIGURE_OPTIONS += \
|
||||
--with-rlm_ldap-include-dir="$(STAGING_DIR)/usr/include" \
|
||||
--with-rlm_ldap-lib-dir="$(STAGING_DIR)/usr/lib"
|
||||
|
@ -62,9 +64,11 @@ else
|
|||
PKG_CONFIGURE_OPTIONS += --without-rlm_ldap
|
||||
endif
|
||||
ifneq ($(BR2_PACKAGE_FREERADIUS_MOD_SQL_MYSQL),)
|
||||
PKG_CONFIGURE_LIBS += -lz
|
||||
PKG_CONFIGURE_OPTIONS += \
|
||||
--with-mysql-include-dir="$(STAGING_DIR)/usr/include/mysql" \
|
||||
--with-mysql-lib-dir="$(STAGING_DIR)/usr/lib/mysql"
|
||||
--with-mysql-include-dir="$(STAGING_DIR)/usr/include" \
|
||||
--with-mysql-lib-dir="$(STAGING_DIR)/usr/lib/mysql" \
|
||||
--without-threads
|
||||
else
|
||||
PKG_CONFIGURE_OPTIONS += --without-rlm_sql_mysql
|
||||
endif
|
||||
|
@ -142,10 +146,10 @@ $(eval $(call PKG_mod_template,FREERADIUS_MOD_SQLCOUNTER,rlm_sqlcounter,))
|
|||
$(PKG_BUILD_DIR)/.configured:
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
sys_lib_dlsearch_path_spec="$(STAGING_DIR)/usr/lib $(STAGING_DIR)/lib" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -L$(PKG_INSTALL_DIR)/usr/lib/freeradius" \
|
||||
LIBS="$(PKG_CONFIGURE_LIBS)" \
|
||||
sys_lib_search_path_spec="$(STAGING_DIR)/usr/lib $(STAGING_DIR)/lib" \
|
||||
MYSQL_CONFIG="no" \
|
||||
./configure \
|
||||
|
@ -192,7 +196,7 @@ $(IPKG_FREERADIUS):
|
|||
install -m0755 -d $(IDIR_FREERADIUS)/usr/share/freeradius
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/freeradius/dictionary \
|
||||
$(IDIR_FREERADIUS)/usr/share/freeradius/
|
||||
for f in cisco freeradius microsoft tunnel wispr; do \
|
||||
for f in freeradius freeradius.internal rfc2865 rfc2866 rfc2867 rfc2868 rfc2869 rfc3162 rfc3576 rfc3580 microsoft wispr; do \
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/freeradius/dictionary.$${f} \
|
||||
$(IDIR_FREERADIUS)/usr/share/freeradius/ ; \
|
||||
done
|
||||
|
@ -218,7 +222,7 @@ $(IPKG_FREERADIUS_DEMOCERTS):
|
|||
|
||||
$(IPKG_FREERADIUS_UTILS):
|
||||
install -m0755 -d $(IDIR_FREERADIUS_UTILS)/usr/bin
|
||||
for f in radclient radeapclient; do \
|
||||
for f in radclient; do \
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/$${f} \
|
||||
$(IDIR_FREERADIUS_UTILS)/usr/bin/ ; \
|
||||
done
|
||||
|
|
|
@ -1,100 +1,149 @@
|
|||
--- freeradius-1.0.3/share/dictionary.orig 2005-06-07 09:36:04.000000000 +0200
|
||||
+++ freeradius-1.0.3/share/dictionary 2005-06-07 09:42:58.000000000 +0200
|
||||
@@ -50,56 +50,56 @@
|
||||
# directive to the end of the file if you want to see the old names
|
||||
# in the logfiles, INSTEAD OF the new names.
|
||||
diff -ruN freeradius-1.1.1-old/share/dictionary freeradius-1.1.1-new/share/dictionary
|
||||
--- freeradius-1.1.1-old/share/dictionary 2006-03-16 23:03:11.000000000 +0100
|
||||
+++ freeradius-1.1.1-new/share/dictionary 2006-05-22 09:09:08.000000000 +0200
|
||||
@@ -52,7 +52,7 @@
|
||||
# this directive to the end of this file if you want to see the
|
||||
# old names in the logfiles, INSTEAD OF the new names.
|
||||
#
|
||||
-$INCLUDE dictionary.compat
|
||||
+#$INCLUDE dictionary.compat
|
||||
|
||||
#
|
||||
# Include the RFC dictionaries next.
|
||||
@@ -73,75 +73,75 @@
|
||||
#
|
||||
# Include vendor dictionaries after the standard ones.
|
||||
#
|
||||
-$INCLUDE dictionary.compat # compability issues
|
||||
-$INCLUDE dictionary.3com
|
||||
-$INCLUDE dictionary.3gpp
|
||||
-$INCLUDE dictionary.3gpp2
|
||||
-$INCLUDE dictionary.acc
|
||||
-$INCLUDE dictionary.airespace
|
||||
-$INCLUDE dictionary.alcatel
|
||||
-$INCLUDE dictionary.alteon
|
||||
-$INCLUDE dictionary.aruba
|
||||
-$INCLUDE dictionary.ascend
|
||||
-$INCLUDE dictionary.bay
|
||||
-$INCLUDE dictionary.bintec
|
||||
-$INCLUDE dictionary.cablelabs
|
||||
-$INCLUDE dictionary.cabletron
|
||||
+#$INCLUDE dictionary.compat # compability issues
|
||||
-$INCLUDE dictionary.cisco
|
||||
+#$INCLUDE dictionary.3com
|
||||
+#$INCLUDE dictionary.3gpp
|
||||
+#$INCLUDE dictionary.3gpp2
|
||||
+#$INCLUDE dictionary.acc
|
||||
+#$INCLUDE dictionary.airespace
|
||||
+#$INCLUDE dictionary.alcatel
|
||||
+#$INCLUDE dictionary.alteon
|
||||
+#$INCLUDE dictionary.aruba
|
||||
+#$INCLUDE dictionary.ascend
|
||||
+#$INCLUDE dictionary.bay
|
||||
+#$INCLUDE dictionary.bintec
|
||||
+#$INCLUDE dictionary.cablelabs
|
||||
+#$INCLUDE dictionary.cabletron
|
||||
$INCLUDE dictionary.cisco
|
||||
+#$INCLUDE dictionary.cisco
|
||||
#
|
||||
# This is the same as the altiga dictionary.
|
||||
# The Cisco VPN300 dictionary is the same as the altiga one.
|
||||
# You shouldn't use both at the same time.
|
||||
#
|
||||
#$INCLUDE dictionary.cisco.vpn3000
|
||||
-$INCLUDE dictionary.cisco.vpn5000
|
||||
-$INCLUDE dictionary.cisco.bbsm
|
||||
-$INCLUDE dictionary.colubris
|
||||
-$INCLUDE dictionary.cosine
|
||||
-$INCLUDE dictionary.epygi
|
||||
-$INCLUDE dictionary.erx
|
||||
-$INCLUDE dictionary.ericsson
|
||||
-$INCLUDE dictionary.extreme
|
||||
+#$INCLUDE dictionary.cisco.vpn5000
|
||||
+#$INCLUDE dictionary.cisco.bbsm
|
||||
+#$INCLUDE dictionary.colubris
|
||||
+#$INCLUDE dictionary.cosine
|
||||
+#$INCLUDE dictionary.epygi
|
||||
+#$INCLUDE dictionary.erx
|
||||
+#$INCLUDE dictionary.ericsson
|
||||
+#$INCLUDE dictionary.extreme
|
||||
$INCLUDE dictionary.freeradius
|
||||
-$INCLUDE dictionary.fortinet
|
||||
-$INCLUDE dictionary.foundry
|
||||
-$INCLUDE dictionary.gandalf
|
||||
-$INCLUDE dictionary.garderos
|
||||
-$INCLUDE dictionary.gemtek
|
||||
-$INCLUDE dictionary.issanni
|
||||
-$INCLUDE dictionary.itk
|
||||
-$INCLUDE dictionary.ipunplugged
|
||||
-$INCLUDE dictionary.juniper
|
||||
-$INCLUDE dictionary.karlnet
|
||||
-$INCLUDE dictionary.livingston
|
||||
-$INCLUDE dictionary.localweb
|
||||
-$INCLUDE dictionary.lucent
|
||||
-$INCLUDE dictionary.hp
|
||||
+#$INCLUDE dictionary.fortinet
|
||||
+#$INCLUDE dictionary.foundry
|
||||
+#$INCLUDE dictionary.gandalf
|
||||
+#$INCLUDE dictionary.garderos
|
||||
+#$INCLUDE dictionary.gemtek
|
||||
+#$INCLUDE dictionary.issanni
|
||||
+#$INCLUDE dictionary.itk
|
||||
+#$INCLUDE dictionary.ipunplugged
|
||||
+#$INCLUDE dictionary.juniper
|
||||
+#$INCLUDE dictionary.karlnet
|
||||
+#$INCLUDE dictionary.livingston
|
||||
+#$INCLUDE dictionary.localweb
|
||||
+#$INCLUDE dictionary.lucent
|
||||
+#$INCLUDE dictionary.hp
|
||||
$INCLUDE dictionary.microsoft
|
||||
-$INCLUDE dictionary.mikrotik
|
||||
-$INCLUDE dictionary.navini
|
||||
-$INCLUDE dictionary.netscreen
|
||||
-$INCLUDE dictionary.ntua
|
||||
-$INCLUDE dictionary.nomadix
|
||||
-$INCLUDE dictionary.nortel
|
||||
-$INCLUDE dictionary.packeteer
|
||||
-$INCLUDE dictionary.propel
|
||||
-$INCLUDE dictionary.quintum
|
||||
-$INCLUDE dictionary.redback
|
||||
-$INCLUDE dictionary.redcreek
|
||||
-$INCLUDE dictionary.roaringpenguin
|
||||
-$INCLUDE dictionary.shasta
|
||||
-$INCLUDE dictionary.shiva
|
||||
-$INCLUDE dictionary.sonicwall
|
||||
-$INCLUDE dictionary.springtide
|
||||
-$INCLUDE dictionary.starent
|
||||
-$INCLUDE dictionary.telebit
|
||||
-$INCLUDE dictionary.trapeze
|
||||
-$INCLUDE dictionary.t_systems_nova
|
||||
-$INCLUDE dictionary.usr
|
||||
-$INCLUDE dictionary.valemount
|
||||
-$INCLUDE dictionary.versanet
|
||||
-$INCLUDE dictionary.waverider
|
||||
+#$INCLUDE dictionary.mikrotik
|
||||
+#$INCLUDE dictionary.navini
|
||||
+#$INCLUDE dictionary.netscreen
|
||||
+#$INCLUDE dictionary.ntua
|
||||
+#$INCLUDE dictionary.nomadix
|
||||
+#$INCLUDE dictionary.nortel
|
||||
+#$INCLUDE dictionary.packeteer
|
||||
+#$INCLUDE dictionary.propel
|
||||
+#$INCLUDE dictionary.quintum
|
||||
+#$INCLUDE dictionary.redback
|
||||
+#$INCLUDE dictionary.redcreek
|
||||
+#$INCLUDE dictionary.roaringpenguin
|
||||
+#$INCLUDE dictionary.shasta
|
||||
+#$INCLUDE dictionary.shiva
|
||||
+#$INCLUDE dictionary.sonicwall
|
||||
+#$INCLUDE dictionary.springtide
|
||||
+#$INCLUDE dictionary.starent
|
||||
+#$INCLUDE dictionary.telebit
|
||||
+#$INCLUDE dictionary.trapeze
|
||||
$INCLUDE dictionary.tunnel
|
||||
-$INCLUDE dictionary.usr
|
||||
-$INCLUDE dictionary.valemount
|
||||
-$INCLUDE dictionary.versanet
|
||||
+#$INCLUDE dictionary.t_systems_nova
|
||||
+#$INCLUDE dictionary.usr
|
||||
+#$INCLUDE dictionary.valemount
|
||||
+#$INCLUDE dictionary.versanet
|
||||
+#$INCLUDE dictionary.waverider
|
||||
$INCLUDE dictionary.wispr
|
||||
-$INCLUDE dictionary.xedia
|
||||
-$INCLUDE dictionary.xylan
|
||||
+#$INCLUDE dictionary.xedia
|
||||
+#$INCLUDE dictionary.xylan
|
||||
|
||||
#
|
||||
# The following are the proper new names. Use these.
|
||||
# And finally the server internal attributes.
|
|
@ -1,7 +1,7 @@
|
|||
diff -ruN freeradius-1.0.4-old/raddb/eap.conf freeradius-1.0.4-new/raddb/eap.conf
|
||||
--- freeradius-1.0.4-old/raddb/eap.conf 2004-04-15 20:34:41.000000000 +0200
|
||||
+++ freeradius-1.0.4-new/raddb/eap.conf 2005-06-18 18:53:06.000000000 +0200
|
||||
@@ -72,8 +72,8 @@
|
||||
diff -ruN freeradius-1.1.1-old/raddb/eap.conf freeradius-1.1.1-new/raddb/eap.conf
|
||||
--- freeradius-1.1.1-old/raddb/eap.conf 2006-01-04 15:29:29.000000000 +0100
|
||||
+++ freeradius-1.1.1-new/raddb/eap.conf 2006-05-22 23:29:11.000000000 +0200
|
||||
@@ -73,8 +73,8 @@
|
||||
# User-Password, or the NT-Password attributes.
|
||||
# 'System' authentication is impossible with LEAP.
|
||||
#
|
||||
|
@ -11,8 +11,8 @@ diff -ruN freeradius-1.0.4-old/raddb/eap.conf freeradius-1.0.4-new/raddb/eap.con
|
|||
+# }
|
||||
|
||||
# Generic Token Card.
|
||||
#
|
||||
@@ -86,7 +86,7 @@
|
||||
#
|
||||
@@ -87,7 +87,7 @@
|
||||
# the users password will go over the wire in plain-text,
|
||||
# for anyone to see.
|
||||
#
|
||||
|
@ -21,7 +21,7 @@ diff -ruN freeradius-1.0.4-old/raddb/eap.conf freeradius-1.0.4-new/raddb/eap.con
|
|||
# The default challenge, which many clients
|
||||
# ignore..
|
||||
#challenge = "Password: "
|
||||
@@ -103,8 +103,8 @@
|
||||
@@ -104,8 +104,8 @@
|
||||
# configured for the request, and do the
|
||||
# authentication itself.
|
||||
#
|
||||
|
@ -32,7 +32,7 @@ diff -ruN freeradius-1.0.4-old/raddb/eap.conf freeradius-1.0.4-new/raddb/eap.con
|
|||
|
||||
## EAP-TLS
|
||||
#
|
||||
@@ -272,7 +272,7 @@
|
||||
@@ -283,7 +283,7 @@
|
||||
# of MS-CHAPv2 in EAP by Cisco, which FreeRADIUS does not
|
||||
# currently support.
|
||||
#
|
||||
|
@ -42,9 +42,9 @@ diff -ruN freeradius-1.0.4-old/raddb/eap.conf freeradius-1.0.4-new/raddb/eap.con
|
|||
+# }
|
||||
}
|
||||
|
||||
diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/radiusd.conf.in
|
||||
--- freeradius-1.0.4-old/raddb/radiusd.conf.in 2005-06-12 00:20:40.000000000 +0200
|
||||
+++ freeradius-1.0.4-new/raddb/radiusd.conf.in 2005-06-18 18:53:32.000000000 +0200
|
||||
diff -ruN freeradius-1.1.1-old/raddb/radiusd.conf.in freeradius-1.1.1-new/raddb/radiusd.conf.in
|
||||
--- freeradius-1.1.1-old/raddb/radiusd.conf.in 2006-02-10 16:12:02.000000000 +0100
|
||||
+++ freeradius-1.1.1-new/raddb/radiusd.conf.in 2006-05-22 23:33:53.000000000 +0200
|
||||
@@ -31,13 +31,13 @@
|
||||
|
||||
# Location of config and logfiles.
|
||||
|
@ -57,7 +57,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
# tail of this file.
|
||||
#
|
||||
-log_file = ${logdir}/radius.log
|
||||
+log_file = ${localstatedir}/log/radiusd.log
|
||||
+log_file = ${logdir}/radiusd.log
|
||||
|
||||
#
|
||||
# libdir: Where to find the rlm_* modules.
|
||||
|
@ -95,11 +95,11 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
# Now in another file, because it is very large.
|
||||
#
|
||||
-$INCLUDE ${confdir}/eap.conf
|
||||
+# $INCLUDE ${confdir}/eap.conf
|
||||
+#$INCLUDE ${confdir}/eap.conf
|
||||
|
||||
# Microsoft CHAP authentication
|
||||
#
|
||||
@@ -1034,8 +1034,8 @@
|
||||
@@ -1046,8 +1046,8 @@
|
||||
#
|
||||
files {
|
||||
usersfile = ${confdir}/users
|
||||
|
@ -110,7 +110,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
# If you want to use the old Cistron 'users' file
|
||||
# with FreeRADIUS, you should change the next line
|
||||
@@ -1168,7 +1168,7 @@
|
||||
@@ -1221,7 +1221,7 @@
|
||||
# For MS-SQL, use: ${confdir}/mssql.conf
|
||||
# For Oracle, use: ${confdir}/oraclesql.conf
|
||||
#
|
||||
|
@ -119,7 +119,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
|
||||
# For Cisco VoIP specific accounting with Postgresql,
|
||||
@@ -1536,7 +1536,7 @@
|
||||
@@ -1694,7 +1694,7 @@
|
||||
# The entire command line (and output) must fit into 253 bytes.
|
||||
#
|
||||
# e.g. Framed-Pool = `%{exec:/bin/echo foo}`
|
||||
|
@ -128,7 +128,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
#
|
||||
# The expression module doesn't do authorization,
|
||||
@@ -1549,7 +1549,7 @@
|
||||
@@ -1707,7 +1707,7 @@
|
||||
# listed in any other section. See 'doc/rlm_expr' for
|
||||
# more information.
|
||||
#
|
||||
|
@ -137,7 +137,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
#
|
||||
# We add the counter module here so that it registers
|
||||
@@ -1576,7 +1576,7 @@
|
||||
@@ -1734,7 +1734,7 @@
|
||||
# 'raddb/huntgroups' files.
|
||||
#
|
||||
# It also adds the %{Client-IP-Address} attribute to the request.
|
||||
|
@ -146,7 +146,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
#
|
||||
# If you want to have a log of authentication requests,
|
||||
@@ -1589,7 +1589,7 @@
|
||||
@@ -1747,7 +1747,7 @@
|
||||
#
|
||||
# The chap module will set 'Auth-Type := CHAP' if we are
|
||||
# handling a CHAP request and Auth-Type has not already been set
|
||||
|
@ -155,16 +155,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
#
|
||||
# If the users are logging in with an MS-CHAP-Challenge
|
||||
@@ -1597,7 +1597,7 @@
|
||||
# the MS-CHAP-Challenge attribute, and add 'Auth-Type := MS-CHAP'
|
||||
# to the request, which will cause the server to then use
|
||||
# the mschap module for authentication.
|
||||
- mschap
|
||||
+# mschap
|
||||
|
||||
#
|
||||
# If you have a Cisco SIP server authenticating against
|
||||
@@ -1617,7 +1617,7 @@
|
||||
@@ -1775,7 +1775,7 @@
|
||||
# Otherwise, when the first style of realm doesn't match,
|
||||
# the other styles won't be checked.
|
||||
#
|
||||
|
@ -173,7 +164,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
# ntdomain
|
||||
|
||||
#
|
||||
@@ -1626,11 +1626,11 @@
|
||||
@@ -1784,11 +1784,11 @@
|
||||
#
|
||||
# It also sets the EAP-Type attribute in the request
|
||||
# attribute list to the EAP type from the packet.
|
||||
|
@ -187,7 +178,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
#
|
||||
# Look in an SQL database. The schema of the database
|
||||
@@ -1684,24 +1684,24 @@
|
||||
@@ -1842,24 +1842,24 @@
|
||||
# PAP authentication, when a back-end database listed
|
||||
# in the 'authorize' section supplies a password. The
|
||||
# password can be clear-text, or encrypted.
|
||||
|
@ -221,7 +212,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
#
|
||||
# If you have a Cisco SIP server authenticating against
|
||||
@@ -1719,7 +1719,7 @@
|
||||
@@ -1877,7 +1877,7 @@
|
||||
# containing CHAP-Password attributes CANNOT be authenticated
|
||||
# against /etc/passwd! See the FAQ for details.
|
||||
#
|
||||
|
@ -230,7 +221,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
# Uncomment it if you want to use ldap for authentication
|
||||
#
|
||||
@@ -1732,7 +1732,7 @@
|
||||
@@ -1890,7 +1890,7 @@
|
||||
|
||||
#
|
||||
# Allow EAP authentication.
|
||||
|
@ -239,7 +230,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
}
|
||||
|
||||
|
||||
@@ -1740,12 +1740,12 @@
|
||||
@@ -1898,12 +1898,12 @@
|
||||
# Pre-accounting. Decide which accounting type to use.
|
||||
#
|
||||
preacct {
|
||||
|
@ -254,7 +245,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
#
|
||||
# Look for IPASS-style 'realm/', and if not found, look for
|
||||
@@ -1755,12 +1755,12 @@
|
||||
@@ -1913,12 +1913,12 @@
|
||||
# Accounting requests are generally proxied to the same
|
||||
# home server as authentication requests.
|
||||
# IPASS
|
||||
|
@ -269,7 +260,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
}
|
||||
|
||||
#
|
||||
@@ -1771,20 +1771,20 @@
|
||||
@@ -1929,20 +1929,20 @@
|
||||
# Create a 'detail'ed log of the packets.
|
||||
# Note that accounting requests which are proxied
|
||||
# are also logged in the detail file.
|
||||
|
@ -293,7 +284,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
# sradutmp
|
||||
|
||||
# Return an address to the IP Pool when we see a stop record.
|
||||
@@ -1807,7 +1807,7 @@
|
||||
@@ -1970,7 +1970,7 @@
|
||||
# or rlm_sql module can handle this.
|
||||
# The rlm_sql module is *much* faster
|
||||
session {
|
||||
|
@ -302,7 +293,7 @@ diff -ruN freeradius-1.0.4-old/raddb/radiusd.conf.in freeradius-1.0.4-new/raddb/
|
|||
|
||||
#
|
||||
# See "Simultaneous Use Checking Querie" in sql.conf
|
||||
@@ -1904,5 +1904,5 @@
|
||||
@@ -2073,5 +2073,5 @@
|
||||
# hidden inside of the EAP packet, and the end server will
|
||||
# reject the EAP request.
|
||||
#
|
|
@ -1,42 +0,0 @@
|
|||
diff -ruN freeradius-1.0.5-old/src/modules/rlm_sql/drivers/rules.mak freeradius-1.0.5-new/src/modules/rlm_sql/drivers/rules.mak
|
||||
--- freeradius-1.0.5-old/src/modules/rlm_sql/drivers/rules.mak 2003-06-05 22:16:54.000000000 +0200
|
||||
+++ freeradius-1.0.5-new/src/modules/rlm_sql/drivers/rules.mak 2005-10-03 05:33:39.000000000 +0200
|
||||
@@ -67,7 +67,7 @@
|
||||
#
|
||||
#######################################################################
|
||||
$(TARGET).a: $(STATIC_OBJS)
|
||||
- $(LIBTOOL) --mode=link $(LD) -module -static $(CFLAGS) $(RLM_SQL_CFLAGS) $^ -o $@
|
||||
+ $(LIBTOOL) --mode=link $(LD) -module -static $(CFLAGS) $(RLM_SQL_CFLAGS) $(LDFLAGS) $^ -o $@
|
||||
|
||||
#
|
||||
# If the module is in the list of static modules, then the "dynamic"
|
||||
@@ -93,7 +93,7 @@
|
||||
$(TARGET).la: $(DYNAMIC_OBJS)
|
||||
$(LIBTOOL) --mode=link $(CC) -release $(RADIUSD_VERSION) \
|
||||
-module $(LINK_MODE) $(CFLAGS) \
|
||||
- $(RLM_SQL_CFLAGS) -o $@ -rpath $(libdir) $^ $(RLM_SQL_LIBS)
|
||||
+ $(RLM_SQL_CFLAGS) $(LDFLAGS) -o $@ -rpath $(libdir) $^ $(RLM_SQL_LIBS)
|
||||
|
||||
#######################################################################
|
||||
#
|
||||
diff -ruN freeradius-1.0.5-old/src/modules/rules.mak freeradius-1.0.5-new/src/modules/rules.mak
|
||||
--- freeradius-1.0.5-old/src/modules/rules.mak 2005-07-31 14:48:01.000000000 +0200
|
||||
+++ freeradius-1.0.5-new/src/modules/rules.mak 2005-10-03 05:35:05.000000000 +0200
|
||||
@@ -71,7 +71,7 @@
|
||||
#######################################################################
|
||||
$(TARGET).a: $(STATIC_OBJS)
|
||||
$(LIBTOOL) --mode=link $(LD) \
|
||||
- -module -static $(CFLAGS) $(RLM_CFLAGS) $^ -o $@
|
||||
+ -module -static $(CFLAGS) $(RLM_CFLAGS) $(LDFLAGS) $(RLM_LDFLAGS) $^ -o $@
|
||||
|
||||
#
|
||||
# If the module is in the list of static modules, then the "dynamic"
|
||||
@@ -96,7 +96,7 @@
|
||||
|
||||
$(TARGET).la: $(DYNAMIC_OBJS)
|
||||
$(LIBTOOL) --mode=link $(CC) -release $(RADIUSD_VERSION) \
|
||||
- -module $(LINK_MODE) $(LDFLAGS) $(RLM_LDFLAGS) \
|
||||
+ -module $(LINK_MODE) $(CFLAGS) $(RLM_CFLAGS) $(LDFLAGS) $(RLM_LDFLAGS) \
|
||||
-o $@ -rpath $(libdir) $^ $(RLM_LIBS) $(LIBS)
|
||||
|
||||
#######################################################################
|
File diff suppressed because it is too large
Load Diff
|
@ -1,20 +1,6 @@
|
|||
diff -ruN freeradius-1.0.5-old/src/modules/rlm_ldap/configure.in freeradius-1.0.5-new/src/modules/rlm_ldap/configure.in
|
||||
--- freeradius-1.0.5-old/src/modules/rlm_ldap/configure.in 2005-08-22 16:50:46.000000000 +0200
|
||||
+++ freeradius-1.0.5-new/src/modules/rlm_ldap/configure.in 2005-12-07 08:20:15.000000000 +0100
|
||||
@@ -90,6 +90,10 @@
|
||||
dnl Static linking will probably not work, but nobody ever
|
||||
dnl complained about it.
|
||||
smart_try_dir=$rlm_ldap_lib_dir
|
||||
+
|
||||
+ AC_SMART_CHECK_LIB(sasl, sasl_encode)
|
||||
+ AC_SMART_CHECK_LIB(lber, ber_init)
|
||||
+
|
||||
if test "x$rlm_ldap_with_threads" = "xyes"; then
|
||||
AC_SMART_CHECK_LIB(ldap_r, ldap_init)
|
||||
if test "x$ac_cv_lib_ldap_r_ldap_init" != "xyes"; then
|
||||
diff -ruN freeradius-1.0.5-old/src/modules/rlm_ldap/configure freeradius-1.0.5-new/src/modules/rlm_ldap/configure
|
||||
--- freeradius-1.0.5-old/src/modules/rlm_ldap/configure 2005-08-22 16:53:52.000000000 +0200
|
||||
+++ freeradius-1.0.5-new/src/modules/rlm_ldap/configure 2005-12-07 08:20:41.000000000 +0100
|
||||
diff -ruN freeradius-1.1.1-old/src/modules/rlm_ldap/configure freeradius-1.1.1-new/src/modules/rlm_ldap/configure
|
||||
--- freeradius-1.1.1-old/src/modules/rlm_ldap/configure 2005-12-08 20:32:53.000000000 +0100
|
||||
+++ freeradius-1.1.1-new/src/modules/rlm_ldap/configure 2006-05-21 19:54:07.000000000 +0200
|
||||
@@ -929,13 +929,311 @@
|
||||
fi
|
||||
|
||||
|
@ -53,8 +39,8 @@ diff -ruN freeradius-1.0.5-old/src/modules/rlm_ldap/configure freeradius-1.0.5-n
|
|||
+ if test "x$smart_lib" != "x"; then
|
||||
+ break;
|
||||
+ fi
|
||||
+ LIBS="$old_LIBS"
|
||||
+ done
|
||||
+ LIBS="$old_LIBS"
|
||||
+fi
|
||||
+
|
||||
+if test "x$smart_lib" = "x"; then
|
||||
|
@ -155,8 +141,8 @@ diff -ruN freeradius-1.0.5-old/src/modules/rlm_ldap/configure freeradius-1.0.5-n
|
|||
+ if test "x$smart_lib" != "x"; then
|
||||
+ break;
|
||||
+ fi
|
||||
+ LIBS="$old_LIBS"
|
||||
+ done
|
||||
+ LIBS="$old_LIBS"
|
||||
+fi
|
||||
+
|
||||
+if test "x$smart_lib" != "x"; then
|
||||
|
@ -201,8 +187,8 @@ diff -ruN freeradius-1.0.5-old/src/modules/rlm_ldap/configure freeradius-1.0.5-n
|
|||
+ if test "x$smart_lib" != "x"; then
|
||||
+ break;
|
||||
+ fi
|
||||
+ LIBS="$old_LIBS"
|
||||
+ done
|
||||
+ LIBS="$old_LIBS"
|
||||
+fi
|
||||
+
|
||||
+if test "x$smart_lib" = "x"; then
|
||||
|
@ -303,8 +289,8 @@ diff -ruN freeradius-1.0.5-old/src/modules/rlm_ldap/configure freeradius-1.0.5-n
|
|||
+ if test "x$smart_lib" != "x"; then
|
||||
+ break;
|
||||
+ fi
|
||||
+ LIBS="$old_LIBS"
|
||||
+ done
|
||||
+ LIBS="$old_LIBS"
|
||||
+fi
|
||||
+
|
||||
+if test "x$smart_lib" != "x"; then
|
||||
|
@ -574,3 +560,17 @@ diff -ruN freeradius-1.0.5-old/src/modules/rlm_ldap/configure freeradius-1.0.5-n
|
|||
rm -rf conftest*
|
||||
eval "ac_cv_func_ldap_int_tls_config=yes"
|
||||
else
|
||||
diff -ruN freeradius-1.1.1-old/src/modules/rlm_ldap/configure.in freeradius-1.1.1-new/src/modules/rlm_ldap/configure.in
|
||||
--- freeradius-1.1.1-old/src/modules/rlm_ldap/configure.in 2005-08-22 16:50:46.000000000 +0200
|
||||
+++ freeradius-1.1.1-new/src/modules/rlm_ldap/configure.in 2006-05-21 19:51:25.000000000 +0200
|
||||
@@ -90,6 +90,10 @@
|
||||
dnl Static linking will probably not work, but nobody ever
|
||||
dnl complained about it.
|
||||
smart_try_dir=$rlm_ldap_lib_dir
|
||||
+
|
||||
+ AC_SMART_CHECK_LIB(sasl, sasl_encode)
|
||||
+ AC_SMART_CHECK_LIB(lber, ber_init)
|
||||
+
|
||||
if test "x$rlm_ldap_with_threads" = "xyes"; then
|
||||
AC_SMART_CHECK_LIB(ldap_r, ldap_init)
|
||||
if test "x$ac_cv_lib_ldap_r_ldap_init" != "xyes"; then
|
|
@ -1,88 +0,0 @@
|
|||
diff -ruN freeradius-1.0.2-orig/src/modules/rlm_sql/drivers/rlm_sql_mysql/configure freeradius-1.0.2-2/src/modules/rlm_sql/drivers/rlm_sql_mysql/configure
|
||||
--- freeradius-1.0.2-orig/src/modules/rlm_sql/drivers/rlm_sql_mysql/configure 2004-05-31 16:20:40.000000000 +0200
|
||||
+++ freeradius-1.0.2-2/src/modules/rlm_sql/drivers/rlm_sql_mysql/configure 2005-03-13 23:05:13.000000000 +0100
|
||||
@@ -947,26 +947,6 @@
|
||||
echo $ac_n "checking for mysql/mysql.h""... $ac_c" 1>&6
|
||||
echo "configure:949: checking for mysql/mysql.h" >&5
|
||||
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 952 "configure"
|
||||
-#include "confdefs.h"
|
||||
-#include <mysql/mysql.h>
|
||||
-int main() {
|
||||
-int a = 1;
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:959: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
||||
- rm -rf conftest*
|
||||
- MYSQL_INCLUDE=" "
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- MYSQL_INCLUDE=
|
||||
-
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
-
|
||||
if test "x$MYSQL_INCLUDE" = "x"; then
|
||||
old_CFLAGS="$CFLAGS"
|
||||
|
||||
@@ -974,14 +954,14 @@
|
||||
for try in $mysql_include_dir /usr/local/include /usr/local/mysql/include ; do
|
||||
CFLAGS="$old_CFLAGS -I$try"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
-#line 978 "configure"
|
||||
+#line 958 "configure"
|
||||
#include "confdefs.h"
|
||||
#include <mysql/mysql.h>
|
||||
int main() {
|
||||
int a = 1;
|
||||
; return 0; }
|
||||
EOF
|
||||
-if { (eval echo configure:985: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
||||
+if { (eval echo configure:965: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
||||
rm -rf conftest*
|
||||
MYSQL_INCLUDE="-I$try"
|
||||
else
|
||||
@@ -1016,7 +996,7 @@
|
||||
|
||||
|
||||
echo $ac_n "checking for mysql_init in -lmysqlclient""... $ac_c" 1>&6
|
||||
-echo "configure:1020: checking for mysql_init in -lmysqlclient" >&5
|
||||
+echo "configure:1000: checking for mysql_init in -lmysqlclient" >&5
|
||||
|
||||
old_LIBS="$LIBS"
|
||||
|
||||
@@ -1024,14 +1004,14 @@
|
||||
for try in $mysql_lib_dir /usr/lib /usr/lib/mysql /usr/local/lib/mysql /usr/local/mysql/lib/mysql; do
|
||||
LIBS="$old_LIBS -L$try -lmysqlclient"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
-#line 1028 "configure"
|
||||
+#line 1008 "configure"
|
||||
#include "confdefs.h"
|
||||
extern char mysql_init();
|
||||
int main() {
|
||||
mysql_init()
|
||||
; return 0; }
|
||||
EOF
|
||||
-if { (eval echo configure:1035: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
+if { (eval echo configure:1015: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
rm -rf conftest*
|
||||
MYSQL_LIBS="-L$try -lmysqlclient $old_LIBS"
|
||||
else
|
||||
diff -ruN freeradius-1.0.2-orig/src/modules/rlm_sql/drivers/rlm_sql_mysql/configure.in freeradius-1.0.2-2/src/modules/rlm_sql/drivers/rlm_sql_mysql/configure.in
|
||||
--- freeradius-1.0.2-orig/src/modules/rlm_sql/drivers/rlm_sql_mysql/configure.in 2004-01-22 19:23:19.000000000 +0100
|
||||
+++ freeradius-1.0.2-2/src/modules/rlm_sql/drivers/rlm_sql_mysql/configure.in 2005-03-13 23:05:13.000000000 +0100
|
||||
@@ -38,11 +38,6 @@
|
||||
|
||||
AC_MSG_CHECKING([for mysql/mysql.h])
|
||||
|
||||
- AC_TRY_COMPILE([#include <mysql/mysql.h>], [int a = 1;],
|
||||
- MYSQL_INCLUDE=" ",
|
||||
- MYSQL_INCLUDE=
|
||||
- )
|
||||
-
|
||||
if test "x$MYSQL_INCLUDE" = "x"; then
|
||||
old_CFLAGS="$CFLAGS"
|
||||
|
|
@ -0,0 +1,11 @@
|
|||
diff -ruN freeradius-1.1.1-old/Makefile freeradius-1.1.1-new/Makefile
|
||||
--- freeradius-1.1.1-old/Makefile 2005-04-11 23:18:27.000000000 +0200
|
||||
+++ freeradius-1.1.1-new/Makefile 2006-05-22 08:27:44.000000000 +0200
|
||||
@@ -38,6 +38,7 @@
|
||||
install:
|
||||
$(INSTALL) -d -m 755 $(R)$(sbindir)
|
||||
$(INSTALL) -d -m 755 $(R)$(bindir)
|
||||
+ $(INSTALL) -d -m 755 $(R)$(libdir)
|
||||
$(INSTALL) -d -m 755 $(R)$(raddbdir)
|
||||
$(INSTALL) -d -m 755 $(R)$(mandir)
|
||||
$(INSTALL) -d -m 755 $(R)$(RUNDIR)
|
|
@ -0,0 +1,27 @@
|
|||
diff -ruN freeradius-1.1.1-old/src/modules/rlm_eap/Makefile.in freeradius-1.1.1-new/src/modules/rlm_eap/Makefile.in
|
||||
--- freeradius-1.1.1-old/src/modules/rlm_eap/Makefile.in 2006-02-10 20:47:08.000000000 +0100
|
||||
+++ freeradius-1.1.1-new/src/modules/rlm_eap/Makefile.in 2006-05-22 08:25:44.000000000 +0200
|
||||
@@ -10,7 +10,6 @@
|
||||
RLM_LIBS = libeap/libeap.la $(LIBLTDL)
|
||||
RLM_INSTALL = install-subdirs
|
||||
RLM_SUBDIRS = libeap @eaptypes@
|
||||
-RLM_UTILS = radeapclient
|
||||
|
||||
#
|
||||
# Not using shared libraries, add in ALL known static modules
|
||||
@@ -29,15 +28,8 @@
|
||||
|
||||
$(LT_OBJS): $(HEADERS)
|
||||
|
||||
-radeapclient: radeapclient.lo $(CLIENTLIBS)
|
||||
- $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) $(RLM_LDFLAGS) -static -o radeapclient radeapclient.lo $(CLIENTLIBS) $(LIBS)
|
||||
-
|
||||
-radeapclient.lo: radeapclient.c $(HEADERS)
|
||||
- $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(RLM_CFLAGS) -c radeapclient.c
|
||||
-
|
||||
install-subdirs:
|
||||
@$(MAKE) $(MFLAGS) WHAT_TO_MAKE=install common
|
||||
- $(LIBTOOL) --mode=install $(INSTALL) -m 755 $(INSTALLSTRIP) radeapclient$(EXEEXT) $(R)$(bindir)
|
||||
|
||||
common:
|
||||
@for dir in $(RLM_SUBDIRS); do \
|
Loading…
Reference in New Issue