mirror of https://github.com/hak5/openwrt.git
update madwifi, see #385, 105-radiotap_endian_fix.patch is integrated upstream
SVN-Revision: 3528lede-17.01
parent
3b8164e5fe
commit
4af0526e7e
|
@ -4,9 +4,9 @@ include $(TOPDIR)/rules.mk
|
||||||
include ../../rules.mk
|
include ../../rules.mk
|
||||||
|
|
||||||
PKG_NAME:=madwifi-ng
|
PKG_NAME:=madwifi-ng
|
||||||
PKG_VERSION:=r1456-20060225
|
PKG_VERSION:=r1475-20060317
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=27ccc5ba2e463fd8bee6da74d717731d
|
PKG_MD5SUM:=b25d4b4d790e890564109348b1ff9005
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://snapshots.madwifi.org/$(PKG_NAME)
|
PKG_SOURCE_URL:=http://snapshots.madwifi.org/$(PKG_NAME)
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
|
|
@ -1,21 +0,0 @@
|
||||||
diff -Nur madwifi-ng-r1451-20060212/net80211/ieee80211_monitor.c madwifi-ng-r1451-20060212-patch/net80211/ieee80211_monitor.c
|
|
||||||
--- madwifi-ng-r1451-20060212/net80211/ieee80211_monitor.c 2006-02-01 15:07:11.000000000 -0500
|
|
||||||
+++ madwifi-ng-r1451-20060212-patch/net80211/ieee80211_monitor.c 2006-02-21 22:17:35.000000000 -0500
|
|
||||||
@@ -296,7 +296,7 @@
|
|
||||||
sizeof(struct ath_tx_radiotap_header));
|
|
||||||
memset(th, 0, sizeof(struct ath_tx_radiotap_header));
|
|
||||||
th->wt_ihdr.it_version = 0;
|
|
||||||
- th->wt_ihdr.it_len = sizeof(struct ath_tx_radiotap_header);
|
|
||||||
+ th->wt_ihdr.it_len = cpu_to_le16(sizeof(struct ath_tx_radiotap_header));
|
|
||||||
th->wt_ihdr.it_present = ATH_TX_RADIOTAP_PRESENT;
|
|
||||||
th->wt_flags = 0;
|
|
||||||
th->wt_rate = rate;
|
|
||||||
@@ -315,7 +315,7 @@
|
|
||||||
sizeof(struct ath_rx_radiotap_header));
|
|
||||||
memset(th, 0, sizeof(struct ath_rx_radiotap_header));
|
|
||||||
th->wr_ihdr.it_version = 0;
|
|
||||||
- th->wr_ihdr.it_len = sizeof(struct ath_rx_radiotap_header);
|
|
||||||
+ th->wr_ihdr.it_len = cpu_to_le16(sizeof(struct ath_rx_radiotap_header));
|
|
||||||
th->wr_ihdr.it_present = ATH_RX_RADIOTAP_PRESENT;
|
|
||||||
th->wr_flags = 0;
|
|
||||||
th->wr_rate = rate;
|
|
Loading…
Reference in New Issue