mirror of https://github.com/hak5/openwrt.git
bcm27xx-userland: update to latest version
Remove upstream cmake fix. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>master
parent
0b7ad6f7f0
commit
49737c359c
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2019 OpenWrt.org
|
||||
# Copyright (C) 2019-2020 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bcm27xx-userland
|
||||
PKG_VERSION:=42ec119e03eb8dffc7c83e2ac0e665e333abbef6
|
||||
PKG_VERSION:=06bc6daa02137ca72b7a2104afad81e82a44de17
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/raspberrypi/userland/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=cb0f1d653fdb9975783f30359277d9de2868607381e081796eac68745e3e8324
|
||||
PKG_HASH:=cf4dff40a2f4ec38bc7e42a80b989df1bf88e12d714f7e681f83c4e5a588f5c9
|
||||
|
||||
PKG_FLAGS:=nonshared
|
||||
|
||||
|
@ -48,8 +48,13 @@ endef
|
|||
|
||||
define Package/bcm27xx-userland/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtmerge $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtparam $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtoverlay $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/raspistill $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/raspivid $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/raspividyuv $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/raspiyuv $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tvservice $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vcgencmd $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vcmailbox $(1)/usr/bin
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/interface/vmcs_host/CMakeLists.txt
|
||||
+++ b/interface/vmcs_host/CMakeLists.txt
|
||||
@@ -24,7 +24,7 @@ if(NOT ARM64)
|
||||
|
||||
# ILCS pulls in EGL for the ILCS/EGL surface API support
|
||||
target_link_libraries(vcilcs brcmEGL brcmGLESv2 khrn_client vchiq_arm vcos)
|
||||
- set(INSTALL_TARGETS "${INSTALL_TARGETS} vcilcs")
|
||||
+ set(INSTALL_TARGETS ${INSTALL_TARGETS} vcilcs)
|
||||
endif()
|
||||
|
||||
# vchostif needs ilcore as well (vmcs_main pulls it in)
|
Loading…
Reference in New Issue