mirror of https://github.com/hak5/openwrt.git
parent
b2f4f696bf
commit
4228768e31
|
@ -173,16 +173,17 @@
|
||||||
if(strcmp(progname, "athstats") == 0)
|
if(strcmp(progname, "athstats") == 0)
|
||||||
--- a/tools/Makefile
|
--- a/tools/Makefile
|
||||||
+++ b/tools/Makefile
|
+++ b/tools/Makefile
|
||||||
@@ -48,6 +48,8 @@ endif
|
@@ -48,14 +48,16 @@ endif
|
||||||
|
|
||||||
all: compile
|
all: compile
|
||||||
|
|
||||||
+DEBUG = -DAR_DEBUG
|
+DEBUG = -DAR_DEBUG
|
||||||
+
|
+
|
||||||
ALLPROGS= athstats 80211stats athkey athchans athctrl \
|
ALLPROGS= athstats 80211stats athkey athchans athctrl \
|
||||||
athdebug 80211debug wlanconfig ath_info
|
- athdebug 80211debug wlanconfig ath_info
|
||||||
|
+ $(if $(DEBUG),athdebug 80211debug) wlanconfig ath_info
|
||||||
|
|
||||||
@@ -55,7 +57,7 @@ OBJS= $(patsubst %,%.o,$(ALLPROGS))
|
OBJS= $(patsubst %,%.o,$(ALLPROGS))
|
||||||
|
|
||||||
INCS= -I. -I../ath -I$(HAL) -I$(TOP) -I$(ATH_HAL)
|
INCS= -I. -I../ath -I$(HAL) -I$(TOP) -I$(ATH_HAL)
|
||||||
CFLAGS= -g -O2 -Wall
|
CFLAGS= -g -O2 -Wall
|
||||||
|
|
|
@ -568,7 +568,7 @@
|
||||||
|
|
||||||
-ALLPROGS= athstats 80211stats athkey athchans athctrl \
|
-ALLPROGS= athstats 80211stats athkey athchans athctrl \
|
||||||
+ALLPROGS= athstats 80211stats athkey athchans \
|
+ALLPROGS= athstats 80211stats athkey athchans \
|
||||||
athdebug 80211debug wlanconfig ath_info
|
$(if $(DEBUG),athdebug 80211debug) wlanconfig ath_info
|
||||||
|
|
||||||
OBJS= $(patsubst %,%.o,$(ALLPROGS))
|
OBJS= $(patsubst %,%.o,$(ALLPROGS))
|
||||||
--- a/tools/athctrl.c
|
--- a/tools/athctrl.c
|
||||||
|
|
Loading…
Reference in New Issue