mirror of https://github.com/hak5/openwrt.git
parent
ad06ff1186
commit
3d32fb2ab5
|
@ -156,7 +156,7 @@
|
|||
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -874,6 +874,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
|
||||
@@ -875,6 +875,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
|
||||
config SYNC_R4K
|
||||
bool
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -877,6 +877,10 @@ config SYNC_R4K
|
||||
@@ -878,6 +878,10 @@ config SYNC_R4K
|
||||
config MIPS_MACHINE
|
||||
def_bool n
|
||||
|
||||
|
|
|
@ -8,7 +8,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
|||
--
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -862,6 +862,17 @@ config I8259
|
||||
@@ -863,6 +863,17 @@ config I8259
|
||||
config MIPS_BONITO64
|
||||
bool
|
||||
|
||||
|
|
|
@ -23,7 +23,7 @@
|
|||
/* The Mellanox Tavor device gives false positive parity errors
|
||||
* Mark this device with a broken_parity_status, to allow
|
||||
* PCI scanning code to "skip" this now blacklisted device.
|
||||
@@ -1923,7 +1924,9 @@ static void __devinit fixup_rev1_53c810(
|
||||
@@ -1943,7 +1944,9 @@ static void __devinit fixup_rev1_53c810(
|
||||
}
|
||||
}
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
|
||||
|
@ -33,7 +33,7 @@
|
|||
/* Enable 1k I/O space granularity on the Intel P64H2 */
|
||||
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
|
||||
{
|
||||
@@ -2596,6 +2599,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
||||
@@ -2616,6 +2619,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x1518, quirk_i82576_sriov);
|
||||
|
||||
#endif /* CONFIG_PCI_IOV */
|
||||
|
|
|
@ -10,7 +10,7 @@
|
|||
#define FB_ACCEL_NEOMAGIC_NM2093 92 /* NeoMagic NM2093 */
|
||||
--- a/include/linux/Kbuild
|
||||
+++ b/include/linux/Kbuild
|
||||
@@ -138,6 +138,8 @@ header-y += generic_serial.h
|
||||
@@ -137,6 +137,8 @@ header-y += generic_serial.h
|
||||
header-y += genetlink.h
|
||||
header-y += gfs2_ondisk.h
|
||||
header-y += gigaset_dev.h
|
||||
|
|
|
@ -14,7 +14,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
|
|||
4 files changed, 334 insertions(+)
|
||||
|
||||
--- /dev/null
|
||||
+++ linux-2.6.36-rc7/include/linux/spi/spi_gpio_old.h
|
||||
+++ b/include/linux/spi/spi_gpio_old.h
|
||||
@@ -0,0 +1,73 @@
|
||||
+/*
|
||||
+ * spi_gpio interface to platform code
|
||||
|
@ -90,7 +90,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
|
|||
+
|
||||
+#endif /* _LINUX_SPI_SPI_GPIO */
|
||||
--- /dev/null
|
||||
+++ linux-2.6.36-rc7/drivers/spi/spi_gpio_old.c
|
||||
+++ b/drivers/spi/spi_gpio_old.c
|
||||
@@ -0,0 +1,251 @@
|
||||
+/*
|
||||
+ * Bitbanging SPI bus driver using GPIO API
|
||||
|
@ -343,8 +343,8 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
|
|||
+MODULE_AUTHOR("Michael Buesch");
|
||||
+MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
|
||||
+MODULE_LICENSE("GPL v2");
|
||||
--- linux-2.6.36-rc7.orig/drivers/spi/Kconfig
|
||||
+++ linux-2.6.36-rc7/drivers/spi/Kconfig
|
||||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -143,6 +143,15 @@ config SPI_GPIO
|
||||
GPIO operations, you should be able to leverage that for better
|
||||
speed with a custom version of this driver; see the source code.
|
||||
|
@ -361,8 +361,8 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
|
|||
config SPI_IMX
|
||||
tristate "Freescale i.MX SPI controllers"
|
||||
depends on ARCH_MXC
|
||||
--- linux-2.6.36-rc7.orig/drivers/spi/Makefile
|
||||
+++ linux-2.6.36-rc7/drivers/spi/Makefile
|
||||
--- a/drivers/spi/Makefile
|
||||
+++ b/drivers/spi/Makefile
|
||||
@@ -23,6 +23,7 @@ obj-$(CONFIG_SPI_DW_PCI) += dw_spi_pci.
|
||||
obj-$(CONFIG_SPI_DW_MMIO) += dw_spi_mmio.o
|
||||
obj-$(CONFIG_SPI_EP93XX) += ep93xx_spi.o
|
||||
|
|
|
@ -829,7 +829,7 @@
|
|||
+be done automatically.
|
||||
--- a/MAINTAINERS
|
||||
+++ b/MAINTAINERS
|
||||
@@ -2662,6 +2662,11 @@ T: git git://git.kernel.org/pub/scm/linu
|
||||
@@ -2679,6 +2679,11 @@ T: git git://git.kernel.org/pub/scm/linu
|
||||
S: Maintained
|
||||
F: drivers/media/video/gspca/
|
||||
|
||||
|
|
Loading…
Reference in New Issue