mirror of https://github.com/hak5/openwrt.git
bzip2: add linker option LDFLAGS
if gcc not linker whith this LDFLAGS, "file libbz2.so.1.0.8" will
recognize as pie executable ELF file ( which should be shared object).
this because the file command version before 5.36 not recognize
correctly.
Signed-off-by: leo chung <gewalalb@gmail.com>
(cherry picked from commit 56ab58fb6c
)
openwrt-19.07
parent
ddff739d15
commit
3b1d71ffd8
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/Makefile-libbz2_so
|
||||||
|
+++ b/Makefile-libbz2_so
|
||||||
|
@@ -35,7 +35,7 @@ OBJS= blocksort.o \
|
||||||
|
bzlib.o
|
||||||
|
|
||||||
|
all: $(OBJS)
|
||||||
|
- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.8 $(OBJS)
|
||||||
|
+ $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 $(LDFLAGS) -o libbz2.so.1.0.8 $(OBJS)
|
||||||
|
$(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.8
|
||||||
|
rm -f libbz2.so.1.0
|
||||||
|
ln -s libbz2.so.1.0.8 libbz2.so.1.0
|
Loading…
Reference in New Issue