mirror of https://github.com/hak5/openwrt.git
kernel: bump 4.9 to 4.9.188
Refreshed all patches. Compile-tested on: ar71xx Runtime-tested on: ar71xx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>openwrt-18.06
parent
0a4a82a431
commit
349714a491
|
@ -2,10 +2,10 @@
|
||||||
|
|
||||||
LINUX_RELEASE?=1
|
LINUX_RELEASE?=1
|
||||||
|
|
||||||
LINUX_VERSION-4.9 = .187
|
LINUX_VERSION-4.9 = .188
|
||||||
LINUX_VERSION-4.14 = .136
|
LINUX_VERSION-4.14 = .136
|
||||||
|
|
||||||
LINUX_KERNEL_HASH-4.9.187 = 014bcd042cd25e073539c17bd34c616a936b19787a9c6a4c35d36a4f28afd1c7
|
LINUX_KERNEL_HASH-4.9.188 = 27539853b25d1830fe81b108f39249c6ddf8b47257cdba09404ba0949863e222
|
||||||
LINUX_KERNEL_HASH-4.14.136 = 268dff959216e59437a8f9db7c2cea3a1ada8a4c72232dc5b7f83ecca12bdf70
|
LINUX_KERNEL_HASH-4.14.136 = 268dff959216e59437a8f9db7c2cea3a1ada8a4c72232dc5b7f83ecca12bdf70
|
||||||
|
|
||||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||||
|
|
|
@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||||
|
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -406,8 +406,8 @@ KERNELRELEASE = $(shell cat include/conf
|
@@ -407,8 +407,8 @@ KERNELRELEASE = $(shell cat include/conf
|
||||||
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
|
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
|
||||||
|
|
||||||
export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION
|
export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION
|
||||||
|
|
|
@ -20,5 +20,5 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||||
-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
||||||
+KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
|
+KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
|
||||||
GCC_PLUGINS_CFLAGS :=
|
GCC_PLUGINS_CFLAGS :=
|
||||||
|
CLANG_FLAGS :=
|
||||||
|
|
||||||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
|
||||||
|
|
|
@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||||
|
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1227,7 +1227,6 @@ all: modules
|
@@ -1228,7 +1228,6 @@ all: modules
|
||||||
|
|
||||||
PHONY += modules
|
PHONY += modules
|
||||||
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
|
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
|
||||||
|
@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||||
@$(kecho) ' Building modules, stage 2.';
|
@$(kecho) ' Building modules, stage 2.';
|
||||||
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
|
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
|
||||||
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
|
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
|
||||||
@@ -1257,7 +1256,6 @@ _modinst_:
|
@@ -1258,7 +1257,6 @@ _modinst_:
|
||||||
rm -f $(MODLIB)/build ; \
|
rm -f $(MODLIB)/build ; \
|
||||||
ln -s $(CURDIR) $(MODLIB)/build ; \
|
ln -s $(CURDIR) $(MODLIB)/build ; \
|
||||||
fi
|
fi
|
||||||
|
|
|
@ -21,9 +21,9 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
||||||
|
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -401,6 +401,11 @@ KBUILD_CFLAGS_MODULE := -DMODULE
|
@@ -402,6 +402,11 @@ KBUILD_LDFLAGS_MODULE = -T $(srctree)/sc
|
||||||
KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
|
|
||||||
GCC_PLUGINS_CFLAGS :=
|
GCC_PLUGINS_CFLAGS :=
|
||||||
|
CLANG_FLAGS :=
|
||||||
|
|
||||||
+ifdef CONFIG_LD_DEAD_CODE_DATA_ELIMINATION
|
+ifdef CONFIG_LD_DEAD_CODE_DATA_ELIMINATION
|
||||||
+KBUILD_CFLAGS_KERNEL += $(call cc-option,-ffunction-sections,)
|
+KBUILD_CFLAGS_KERNEL += $(call cc-option,-ffunction-sections,)
|
||||||
|
@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
||||||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
||||||
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|
||||||
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
|
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
|
||||||
@@ -651,11 +656,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
@@ -652,11 +657,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
||||||
KBUILD_CFLAGS += $(call cc-disable-warning, address-of-packed-member)
|
KBUILD_CFLAGS += $(call cc-disable-warning, address-of-packed-member)
|
||||||
KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)
|
KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)
|
||||||
|
|
||||||
|
|
|
@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||||
|
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -657,12 +657,12 @@ KBUILD_CFLAGS += $(call cc-option,-fdata
|
@@ -658,12 +658,12 @@ KBUILD_CFLAGS += $(call cc-option,-fdata
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
||||||
|
|
|
@ -18,7 +18,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||||
|
|
||||||
--- a/arch/mips/lantiq/irq.c
|
--- a/arch/mips/lantiq/irq.c
|
||||||
+++ b/arch/mips/lantiq/irq.c
|
+++ b/arch/mips/lantiq/irq.c
|
||||||
@@ -271,6 +271,11 @@ static void ltq_hw5_irqdispatch(void)
|
@@ -272,6 +272,11 @@ static void ltq_hw5_irqdispatch(void)
|
||||||
DEFINE_HWx_IRQDISPATCH(5)
|
DEFINE_HWx_IRQDISPATCH(5)
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||||
#ifdef CONFIG_MIPS_MT_SMP
|
#ifdef CONFIG_MIPS_MT_SMP
|
||||||
void __init arch_init_ipiirq(int irq, struct irqaction *action)
|
void __init arch_init_ipiirq(int irq, struct irqaction *action)
|
||||||
{
|
{
|
||||||
@@ -315,23 +320,19 @@ static struct irqaction irq_call = {
|
@@ -316,23 +321,19 @@ static struct irqaction irq_call = {
|
||||||
asmlinkage void plat_irq_dispatch(void)
|
asmlinkage void plat_irq_dispatch(void)
|
||||||
{
|
{
|
||||||
unsigned int pending = read_c0_status() & read_c0_cause() & ST0_IM;
|
unsigned int pending = read_c0_status() & read_c0_cause() & ST0_IM;
|
||||||
|
@ -64,7 +64,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||||
}
|
}
|
||||||
|
|
||||||
static int icu_map(struct irq_domain *d, unsigned int irq, irq_hw_number_t hw)
|
static int icu_map(struct irq_domain *d, unsigned int irq, irq_hw_number_t hw)
|
||||||
@@ -356,11 +357,6 @@ static const struct irq_domain_ops irq_d
|
@@ -357,11 +358,6 @@ static const struct irq_domain_ops irq_d
|
||||||
.map = icu_map,
|
.map = icu_map,
|
||||||
};
|
};
|
||||||
|
|
||||||
|
@ -76,7 +76,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||||
int __init icu_of_init(struct device_node *node, struct device_node *parent)
|
int __init icu_of_init(struct device_node *node, struct device_node *parent)
|
||||||
{
|
{
|
||||||
struct device_node *eiu_node;
|
struct device_node *eiu_node;
|
||||||
@@ -392,7 +388,7 @@ int __init icu_of_init(struct device_nod
|
@@ -393,7 +389,7 @@ int __init icu_of_init(struct device_nod
|
||||||
mips_cpu_irq_init();
|
mips_cpu_irq_init();
|
||||||
|
|
||||||
for (i = 0; i < MAX_IM; i++)
|
for (i = 0; i < MAX_IM; i++)
|
||||||
|
|
|
@ -738,7 +738,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
||||||
};
|
};
|
||||||
--- a/arch/arm/boot/dts/rk3288.dtsi
|
--- a/arch/arm/boot/dts/rk3288.dtsi
|
||||||
+++ b/arch/arm/boot/dts/rk3288.dtsi
|
+++ b/arch/arm/boot/dts/rk3288.dtsi
|
||||||
@@ -1109,7 +1109,7 @@
|
@@ -1110,7 +1110,7 @@
|
||||||
#address-cells = <0>;
|
#address-cells = <0>;
|
||||||
|
|
||||||
reg = <0xffc01000 0x1000>,
|
reg = <0xffc01000 0x1000>,
|
||||||
|
|
Loading…
Reference in New Issue