mirror of https://github.com/hak5/openwrt.git
parent
cc0f0c2a30
commit
32ac162630
|
@ -9,19 +9,18 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=comgt
|
PKG_NAME:=comgt
|
||||||
PKG_VERSION:=0.3
|
PKG_VERSION:=0.32
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tgz
|
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
|
||||||
PKG_SOURCE_URL:=http://www.pharscape.org/3G/comgt
|
PKG_SOURCE_URL:=@SF/comgt
|
||||||
PKG_MD5SUM:=cd32663025ed94a0ee623a689989f3c3
|
PKG_MD5SUM:=db2452680c3d953631299e331daf49ef
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
|
||||||
PKG_UNPACK:=mkdir -p $(PKG_BUILD_DIR); zcat $(DL_DIR)/$(PKG_SOURCE) | $(TAR) -C $(PKG_BUILD_DIR) $(TAR_OPTIONS)
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
|
||||||
define Package/comgt
|
define Package/comgt
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
|
|
|
@ -1,32 +1,126 @@
|
||||||
--- gcom-0.3.x/Makefile 2006-01-04 17:05:28.000000000 +0200
|
diff -rhNp comgt.0.32/Makefile gcom-032/Makefile
|
||||||
+++ gcom-0.3/Makefile 2006-02-26 13:02:07.000000000 +0200
|
*** comgt.0.32/Makefile 2007-02-10 19:07:58.723709368 +0100
|
||||||
@@ -20,8 +20,6 @@
|
--- gcom-032/Makefile 2007-02-10 19:18:26.764232696 +0100
|
||||||
#
|
***************
|
||||||
# $Id$
|
*** 1,7 ****
|
||||||
#
|
#
|
||||||
-LIB = -L/usr/local/lib
|
! # Makefile - build and install the comgt package
|
||||||
-INC = -I/usr/local/include
|
# Copyright (C) 2005 Martin Gregorie
|
||||||
EXE = /usr/local/bin
|
- # Copyright (C) 2006 Paul Hardwick
|
||||||
MAN = /usr/share/man/man1
|
#
|
||||||
CPROG = gcom
|
# This program is free software; you can redistribute it and/or modify
|
||||||
@@ -29,9 +27,6 @@
|
# it under the terms of the GNU General Public License as published by
|
||||||
BIN = $(CPROG) $(SCRIPT)
|
--- 1,6 ----
|
||||||
MANP = gcom.1 sigmon.1
|
#
|
||||||
|
! # Makefile - build and install the gmon package
|
||||||
-CFLAGS = -c
|
# Copyright (C) 2005 Martin Gregorie
|
||||||
-LDFLAGS =
|
#
|
||||||
-
|
# This program is free software; you can redistribute it and/or modify
|
||||||
all: $(BIN)
|
# it under the terms of the GNU General Public License as published by
|
||||||
|
***************
|
||||||
install:
|
*** 17,79 ****
|
||||||
@@ -53,8 +48,8 @@
|
# along with this program; if not, write to the Free Software
|
||||||
|
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||||
|
#
|
||||||
gcom: gcom.o
|
! # martin@gregorie.org, paul@peck.org.uk
|
||||||
- cc gcom.o $(LDFLAGS) -o gcom
|
#
|
||||||
+ $(CC) gcom.o $(LDFLAGS) -o gcom
|
! # $Id: Makefile,v 1.4 2006/10/20 14:30:19 pharscape Exp $
|
||||||
|
#
|
||||||
gcom.o: gcom.c gcom.h
|
- #
|
||||||
- cc gcom.c $(CFLAGS)
|
-
|
||||||
+ $(CC) -c $(CFLAGS) gcom.c
|
- LIB = -L/usr/local/lib
|
||||||
|
- INC = -I/usr/local/include
|
||||||
|
EXE = /usr/local/bin
|
||||||
|
MAN = /usr/share/man/man1
|
||||||
|
! CPROG = comgt
|
||||||
|
! SCRIPTPATH = /etc/comgt/
|
||||||
|
! SCRIPTSRC = ./scripts/
|
||||||
|
! BIN = $(CPROG)
|
||||||
|
! MANP = comgt.1 sigmon.1
|
||||||
|
!
|
||||||
|
! CFLAGS = -c
|
||||||
|
! LDFLAGS =
|
||||||
|
|
||||||
|
all: $(BIN)
|
||||||
|
|
||||||
|
install:
|
||||||
|
chmod a-w $(BIN)
|
||||||
|
chmod u+rw $(BIN)
|
||||||
|
chmod a+x $(BIN)
|
||||||
|
! cp $(BIN) $(EXE)
|
||||||
|
chmod a-wx $(MANP)
|
||||||
|
chmod u+rw $(MANP)
|
||||||
|
chmod a+r $(MANP)
|
||||||
|
cp $(MANP) $(MAN)
|
||||||
|
- -mkdir $(SCRIPTPATH)
|
||||||
|
- chmod a-w $(SCRIPTPATH)
|
||||||
|
- chmod u+rw $(SCRIPTPATH)
|
||||||
|
- chmod a+x $(SCRIPTPATH)
|
||||||
|
- cp -f $(SCRIPTSRC)* $(SCRIPTPATH)
|
||||||
|
- chmod a-w $(SCRIPTPATH)*
|
||||||
|
- chmod u+rw $(SCRIPTPATH)*
|
||||||
|
- chmod a+x $(SCRIPTPATH)*
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
cd $(EXE); rm $(BIN)
|
||||||
|
cd $(MAN); rm $(MANP)
|
||||||
|
- -rm -r $(SCRIPTPATH)
|
||||||
|
|
||||||
|
clean:
|
||||||
|
! -rm *.o
|
||||||
|
! -rm $(CPROG)
|
||||||
|
! -rm *~
|
||||||
|
! -rm $(SCRIPTSRC)*~
|
||||||
|
|
||||||
|
|
||||||
|
! comgt: comgt.o
|
||||||
|
! cc comgt.o $(LDFLAGS) -o comgt
|
||||||
|
|
||||||
|
! comgt.o: comgt.c comgt.h
|
||||||
|
! cc comgt.c $(CFLAGS)
|
||||||
|
|
||||||
|
--- 16,56 ----
|
||||||
|
# along with this program; if not, write to the Free Software
|
||||||
|
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||||
|
#
|
||||||
|
! # martin@gregorie.org
|
||||||
|
#
|
||||||
|
! # $Id$
|
||||||
|
#
|
||||||
|
EXE = /usr/local/bin
|
||||||
|
MAN = /usr/share/man/man1
|
||||||
|
! CPROG = gcom
|
||||||
|
! SCRIPT = sigmon
|
||||||
|
! BIN = $(CPROG) $(SCRIPT)
|
||||||
|
! MANP = gcom.1 sigmon.1
|
||||||
|
|
||||||
|
all: $(BIN)
|
||||||
|
|
||||||
|
install:
|
||||||
|
+ mv ($BIN} {$BIN2}
|
||||||
|
chmod a-w $(BIN)
|
||||||
|
chmod u+rw $(BIN)
|
||||||
|
chmod a+x $(BIN)
|
||||||
|
! cp $(BIN) $(EXE)/gcom
|
||||||
|
chmod a-wx $(MANP)
|
||||||
|
chmod u+rw $(MANP)
|
||||||
|
chmod a+r $(MANP)
|
||||||
|
cp $(MANP) $(MAN)
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
cd $(EXE); rm $(BIN)
|
||||||
|
cd $(MAN); rm $(MANP)
|
||||||
|
|
||||||
|
clean:
|
||||||
|
! rm *.o $(CPROG)
|
||||||
|
|
||||||
|
|
||||||
|
! gcom: gcom.o
|
||||||
|
! $(CC) gcom.o $(LDFLAGS) -o gcom
|
||||||
|
|
||||||
|
! gcom.o: comgt.c comgt.h
|
||||||
|
! $(CC) -c $(CFLAGS) comgt.c -o gcom.o
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue