mirror of https://github.com/hak5/openwrt.git
uboot-mediatek: update to latest version
Signed-off-by: John Crispin <john@phrozen.org>master
parent
729a75c3b2
commit
2ddd8387a7
|
@ -1,9 +1,8 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_VERSION:=2020.04
|
PKG_VERSION:=2020.07
|
||||||
PKG_RELEASE:=2
|
PKG_HASH:=c1f5bf9ee6bb6e648edbf19ce2ca9452f614b08a9f886f1a566aa42e8cf05f6a
|
||||||
PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/u-boot.mk
|
include $(INCLUDE_DIR)/u-boot.mk
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
File diff suppressed because it is too large
Load Diff
|
@ -5,7 +5,6 @@ index 6b9fbd7e22..fb2a004803 100644
|
||||||
@@ -52,3 +52,13 @@ CONFIG_TIMER=y
|
@@ -52,3 +52,13 @@ CONFIG_TIMER=y
|
||||||
CONFIG_WDT_MTK=y
|
CONFIG_WDT_MTK=y
|
||||||
CONFIG_LZMA=y
|
CONFIG_LZMA=y
|
||||||
# CONFIG_EFI_LOADER is not set
|
|
||||||
+CONFIG_CMD_BOOTZ=y
|
+CONFIG_CMD_BOOTZ=y
|
||||||
+CONFIG_OF_LIBFDT_OVERLAY=y
|
+CONFIG_OF_LIBFDT_OVERLAY=y
|
||||||
+#enables savenenv-command
|
+#enables savenenv-command
|
||||||
|
|
|
@ -37,11 +37,10 @@ diff --git a/env/fat.c b/env/fat.c
|
||||||
index 35a1955e63..63aced9317 100644
|
index 35a1955e63..63aced9317 100644
|
||||||
--- a/env/fat.c
|
--- a/env/fat.c
|
||||||
+++ b/env/fat.c
|
+++ b/env/fat.c
|
||||||
@@ -29,6 +29,36 @@
|
@@ -29,6 +29,34 @@
|
||||||
# endif
|
# define LOADENV
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
+#if defined(CMD_SAVEENV) || defined(CMD_LOADENV)
|
|
||||||
+__weak int mmc_get_env_dev(void)
|
+__weak int mmc_get_env_dev(void)
|
||||||
+{
|
+{
|
||||||
+#ifdef CONFIG_SYS_MMC_ENV_DEV
|
+#ifdef CONFIG_SYS_MMC_ENV_DEV
|
||||||
|
@ -69,11 +68,10 @@ index 35a1955e63..63aced9317 100644
|
||||||
+ return CONFIG_ENV_FAT_DEVICE_AND_PART;
|
+ return CONFIG_ENV_FAT_DEVICE_AND_PART;
|
||||||
+#endif
|
+#endif
|
||||||
+}
|
+}
|
||||||
+#endif
|
|
||||||
+
|
+
|
||||||
#ifdef CMD_SAVEENV
|
|
||||||
static int env_fat_save(void)
|
static int env_fat_save(void)
|
||||||
{
|
{
|
||||||
|
env_t __aligned(ARCH_DMA_MINALIGN) env_new;
|
||||||
@@ -43,7 +71,7 @@ static int env_fat_save(void)
|
@@ -43,7 +71,7 @@ static int env_fat_save(void)
|
||||||
return err;
|
return err;
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue