SSB: Update the watchdog fix to the patch version that will go upstream.

SVN-Revision: 10494
lede-17.01
Michael Büsch 2008-02-19 11:58:20 +00:00
parent b926d7695b
commit 27e288859c
3 changed files with 133 additions and 56 deletions

View File

@ -2,7 +2,7 @@
* Copyright (C) 2004 Florian Schirmer (jolt@tuxbox.org) * Copyright (C) 2004 Florian Schirmer (jolt@tuxbox.org)
* Copyright (C) 2005 Waldemar Brodkorb <wbx@openwrt.org> * Copyright (C) 2005 Waldemar Brodkorb <wbx@openwrt.org>
* Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org> * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
* Copyright (C) 2006 Michael Buesch * Copyright (C) 2006-2008 Michael Buesch <mb@bu3sch.de>
* *
* This program is free software; you can redistribute it and/or modify it * This program is free software; you can redistribute it and/or modify it
* under the terms of the GNU General Public License as published by the * under the terms of the GNU General Public License as published by the
@ -38,6 +38,7 @@
#include <asm/cfe.h> #include <asm/cfe.h>
#include <linux/pm.h> #include <linux/pm.h>
#include <linux/ssb/ssb.h> #include <linux/ssb/ssb.h>
#include <linux/ssb/ssb_embedded.h>
#include <nvram.h> #include <nvram.h>
@ -55,7 +56,8 @@ static void bcm47xx_machine_restart(char *command)
*/ */
/* Set the watchdog timer to reset immediately */ /* Set the watchdog timer to reset immediately */
ssb_chipco_watchdog_timer_set(&ssb.chipco, 1); if (ssb_watchdog_timer_set(&ssb, 1))
printk(KERN_EMERG "SSB watchdog-triggered reboot failed!\n");
while (1) while (1)
cpu_relax(); cpu_relax();
} }
@ -64,7 +66,8 @@ static void bcm47xx_machine_halt(void)
{ {
/* Disable interrupts and watchdog and spin forever */ /* Disable interrupts and watchdog and spin forever */
local_irq_disable(); local_irq_disable();
ssb_chipco_watchdog_timer_set(&ssb.chipco, 0); if (ssb_watchdog_timer_set(&ssb, 0))
printk(KERN_EMERG "Failed to disable SSB watchdog!\n");
while (1) while (1)
cpu_relax(); cpu_relax();
} }

View File

@ -1,59 +1,133 @@
Index: linux-2.6.23.16/drivers/ssb/driver_mipscore.c Index: linux-2.6.23.16/drivers/ssb/Kconfig
=================================================================== ===================================================================
--- linux-2.6.23.16.orig/drivers/ssb/driver_mipscore.c 2008-02-19 02:13:15.000000000 +0100 --- linux-2.6.23.16.orig/drivers/ssb/Kconfig 2008-02-19 12:38:31.000000000 +0100
+++ linux-2.6.23.16/drivers/ssb/driver_mipscore.c 2008-02-19 02:13:17.000000000 +0100 +++ linux-2.6.23.16/drivers/ssb/Kconfig 2008-02-19 12:43:58.000000000 +0100
@@ -31,6 +31,19 @@ static inline void mips_write32(struct s @@ -105,6 +105,12 @@ config SSB_DRIVER_MIPS
ssb_write32(mcore->dev, offset, value);
}
+/* Set chip watchdog reset timer to fire in 'ticks' backplane cycles */ If unsure, say N
+int
+ssb_watchdog(struct ssb_bus *bus, uint ticks) +# Assumption: We are on embedded, if we compile the MIPS core.
+{ +config SSB_EMBEDDED
+ /* instant NMI */ + bool
+ if (bus->chipco.dev) + depends on SSB_DRIVER_MIPS
+ ssb_write32(bus->chipco.dev, SSB_CHIPCO_WATCHDOG, ticks); + default y
+ else if (bus->extif.dev)
+ ssb_write32(bus->extif.dev, SSB_EXTIF_WATCHDOG, ticks);
+ return 0;
+}
+EXPORT_SYMBOL(ssb_watchdog);
+ +
static const u32 ipsflag_irq_mask[] = { config SSB_DRIVER_EXTIF
0, bool "SSB Broadcom EXTIF core driver (EXPERIMENTAL)"
SSB_IPSFLAG_IRQ1, depends on SSB_DRIVER_MIPS && EXPERIMENTAL
Index: linux-2.6.23.16/include/linux/ssb/ssb_driver_mips.h Index: linux-2.6.23.16/drivers/ssb/Makefile
=================================================================== ===================================================================
--- linux-2.6.23.16.orig/include/linux/ssb/ssb_driver_mips.h 2008-02-19 02:13:15.000000000 +0100 --- linux-2.6.23.16.orig/drivers/ssb/Makefile 2008-02-19 12:38:31.000000000 +0100
+++ linux-2.6.23.16/include/linux/ssb/ssb_driver_mips.h 2008-02-19 02:13:17.000000000 +0100 +++ linux-2.6.23.16/drivers/ssb/Makefile 2008-02-19 12:43:58.000000000 +0100
@@ -30,6 +30,8 @@ extern u32 ssb_cpu_clock(struct ssb_mips @@ -1,5 +1,6 @@
# core
ssb-y += main.o scan.o
+ssb-$(CONFIG_SSB_EMBEDDED) += embedded.o
extern unsigned int ssb_mips_irq(struct ssb_device *dev); # host support
ssb-$(CONFIG_SSB_PCIHOST) += pci.o pcihost_wrapper.o
+/* Set watchdog reset timer to fire in 'ticks' backplane cycles */ Index: linux-2.6.23.16/drivers/ssb/driver_extif.c
+extern int ssb_watchdog(struct ssb_bus *bus, uint ticks);
#else /* CONFIG_SSB_DRIVER_MIPS */
Index: linux-2.6.23.16/arch/mips/bcm947xx/setup.c
=================================================================== ===================================================================
--- linux-2.6.23.16.orig/arch/mips/bcm947xx/setup.c 2008-02-19 02:13:15.000000000 +0100 --- linux-2.6.23.16.orig/drivers/ssb/driver_extif.c 2008-02-19 12:38:34.000000000 +0100
+++ linux-2.6.23.16/arch/mips/bcm947xx/setup.c 2008-02-19 02:13:17.000000000 +0100 +++ linux-2.6.23.16/drivers/ssb/driver_extif.c 2008-02-19 12:45:13.000000000 +0100
@@ -55,7 +55,7 @@ static void bcm47xx_machine_restart(char @@ -35,6 +35,12 @@ static inline void extif_write32_masked(
*/ extif_write32(extif, offset, value);
/* Set the watchdog timer to reset immediately */
- ssb_chipco_watchdog_timer_set(&ssb.chipco, 1);
+ ssb_watchdog(&ssb, 1);
while (1)
cpu_relax();
} }
@@ -64,7 +64,7 @@ static void bcm47xx_machine_halt(void)
+void ssb_extif_watchdog_timer_set(struct ssb_extif *extif,
+ u32 ticks)
+{
+ extif_write32(extif, SSB_EXTIF_WATCHDOG, ticks);
+}
+
#ifdef CONFIG_SSB_SERIAL
static bool serial_exists(u8 *regs)
{
Index: linux-2.6.23.16/drivers/ssb/embedded.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-2.6.23.16/drivers/ssb/embedded.c 2008-02-19 12:43:58.000000000 +0100
@@ -0,0 +1,26 @@
+/*
+ * Sonics Silicon Backplane
+ * Embedded systems support code
+ *
+ * Copyright 2005-2008, Broadcom Corporation
+ * Copyright 2006-2008, Michael Buesch <mb@bu3sch.de>
+ *
+ * Licensed under the GNU/GPL. See COPYING for details.
+ */
+
+#include <linux/ssb/ssb.h>
+#include <linux/ssb/ssb_embedded.h>
+
+
+int ssb_watchdog_timer_set(struct ssb_bus *bus, u32 ticks)
+{
+ if (ssb_chipco_available(&bus->chipco)) {
+ ssb_chipco_watchdog_timer_set(&bus->chipco, ticks);
+ return 0;
+ }
+ if (ssb_extif_available(&bus->extif)) {
+ ssb_extif_watchdog_timer_set(&bus->extif, ticks);
+ return 0;
+ }
+ return -ENODEV;
+}
Index: linux-2.6.23.16/include/linux/ssb/ssb_driver_chipcommon.h
===================================================================
--- linux-2.6.23.16.orig/include/linux/ssb/ssb_driver_chipcommon.h 2008-02-19 12:38:34.000000000 +0100
+++ linux-2.6.23.16/include/linux/ssb/ssb_driver_chipcommon.h 2008-02-19 12:43:58.000000000 +0100
@@ -360,6 +360,11 @@ struct ssb_chipcommon {
u16 fast_pwrup_delay;
};
+static inline bool ssb_chipco_available(struct ssb_chipcommon *cc)
+{
+ return (cc->dev != NULL);
+}
+
extern void ssb_chipcommon_init(struct ssb_chipcommon *cc);
#include <linux/pm.h>
Index: linux-2.6.23.16/include/linux/ssb/ssb_driver_extif.h
===================================================================
--- linux-2.6.23.16.orig/include/linux/ssb/ssb_driver_extif.h 2008-02-19 12:38:34.000000000 +0100
+++ linux-2.6.23.16/include/linux/ssb/ssb_driver_extif.h 2008-02-19 12:47:03.000000000 +0100
@@ -170,6 +170,9 @@ extern void ssb_extif_get_clockcontrol(s
extern void ssb_extif_timing_init(struct ssb_extif *extif,
unsigned long ns);
+extern void ssb_extif_watchdog_timer_set(struct ssb_extif *extif,
+ u32 ticks);
+
#ifdef CONFIG_SSB_SERIAL
extern int ssb_extif_serial_init(struct ssb_extif *extif,
struct ssb_serial_port *ports);
@@ -224,5 +227,11 @@ void ssb_extif_get_clockcontrol(struct s
{ {
/* Disable interrupts and watchdog and spin forever */
local_irq_disable();
- ssb_chipco_watchdog_timer_set(&ssb.chipco, 0);
+ ssb_watchdog(&ssb, 0);
while (1)
cpu_relax();
} }
+static inline
+void ssb_extif_watchdog_timer_set(struct ssb_extif *extif,
+ u32 ticks)
+{
+}
+
#endif /* CONFIG_SSB_DRIVER_EXTIF */
#endif /* LINUX_SSB_EXTIFCORE_H_ */
Index: linux-2.6.23.16/include/linux/ssb/ssb_embedded.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-2.6.23.16/include/linux/ssb/ssb_embedded.h 2008-02-19 12:43:58.000000000 +0100
@@ -0,0 +1,10 @@
+#ifndef LINUX_SSB_EMBEDDED_H_
+#define LINUX_SSB_EMBEDDED_H_
+
+#include <linux/types.h>
+#include <linux/ssb/ssb.h>
+
+
+extern int ssb_watchdog_timer_set(struct ssb_bus *bus, u32 ticks);
+
+#endif /* LINUX_SSB_EMBEDDED_H_ */

View File

@ -1,8 +1,8 @@
Index: linux-2.6.23.16/drivers/ssb/main.c Index: linux-2.6.23.16/drivers/ssb/main.c
=================================================================== ===================================================================
--- linux-2.6.23.16.orig/drivers/ssb/main.c 2008-02-19 02:24:48.000000000 +0100 --- linux-2.6.23.16.orig/drivers/ssb/main.c 2008-02-19 12:38:34.000000000 +0100
+++ linux-2.6.23.16/drivers/ssb/main.c 2008-02-19 02:27:59.000000000 +0100 +++ linux-2.6.23.16/drivers/ssb/main.c 2008-02-19 12:48:25.000000000 +0100
@@ -1164,7 +1164,9 @@ static int __init ssb_modinit(void) @@ -1163,7 +1163,9 @@ static int __init ssb_modinit(void)
/* ssb must be initialized after PCI but before the ssb drivers. /* ssb must be initialized after PCI but before the ssb drivers.
* That means we must use some initcall between subsys_initcall * That means we must use some initcall between subsys_initcall
* and device_initcall. */ * and device_initcall. */