mirror of https://github.com/hak5/openwrt.git
parent
4c04f649fe
commit
25097a0ab2
|
@ -2,6 +2,7 @@ config BR2_PACKAGE_NMAP
|
||||||
prompt "nmap.............................. Network exploration and/or security auditing utility"
|
prompt "nmap.............................. Network exploration and/or security auditing utility"
|
||||||
tristate
|
tristate
|
||||||
default m if CONFIG_DEVEL
|
default m if CONFIG_DEVEL
|
||||||
|
select BR2_PACKAGE_LIBDNET
|
||||||
select BR2_PACKAGE_LIBPCAP
|
select BR2_PACKAGE_LIBPCAP
|
||||||
select BR2_PACKAGE_LIBPCRE
|
select BR2_PACKAGE_LIBPCRE
|
||||||
select BR2_PACKAGE_UCLIBCXX
|
select BR2_PACKAGE_UCLIBCXX
|
||||||
|
|
|
@ -3,9 +3,9 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=nmap
|
PKG_NAME:=nmap
|
||||||
PKG_VERSION:=3.81
|
PKG_VERSION:=4.01
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=0713306dda85aee2c95ef31b4b7d2838
|
PKG_MD5SUM:=09c259837b24f6c7385c2c1c49760a7c
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://download.insecure.org/nmap/dist
|
PKG_SOURCE_URL:=http://download.insecure.org/nmap/dist
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
@ -50,6 +50,7 @@ $(PKG_BUILD_DIR)/.configured:
|
||||||
$(DISABLE_NLS) \
|
$(DISABLE_NLS) \
|
||||||
--without-openssl \
|
--without-openssl \
|
||||||
--without-nmapfe \
|
--without-nmapfe \
|
||||||
|
--with-libdnet="$(STAGING_DIR)/usr" \
|
||||||
--with-libpcap="$(STAGING_DIR)/usr" \
|
--with-libpcap="$(STAGING_DIR)/usr" \
|
||||||
--with-libpcre="$(STAGING_DIR)/usr" \
|
--with-libpcre="$(STAGING_DIR)/usr" \
|
||||||
);
|
);
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
Package: nmap
|
Package: nmap
|
||||||
Priority: optional
|
Priority: optional
|
||||||
Section: net
|
Section: net
|
||||||
Depends: libgcc, libpcap, libpcre, uclibc++
|
Depends: libgcc, libdnet, libpcap, libpcre, uclibc++
|
||||||
Description: Nmap is a free open source utility for network exploration or security auditing.
|
Description: Nmap is a free open source utility for network exploration or security auditing.
|
||||||
|
|
|
@ -1,11 +1,11 @@
|
||||||
diff -urN nmap-3.81.old/configure nmap-3.81.dev/configure
|
diff -urN nmap-4.01.old/configure nmap-4.01.dev/configure
|
||||||
--- nmap-3.81.old/configure 2004-10-17 05:49:33.000000000 +0200
|
--- nmap-4.01.old/configure 2006-02-01 19:18:42.000000000 -0700
|
||||||
+++ nmap-3.81.dev/configure 2005-04-26 14:47:42.000000000 +0200
|
+++ nmap-4.01.dev/configure 2006-03-29 23:14:28.000000000 -0700
|
||||||
@@ -1339,12 +1339,6 @@
|
@@ -1341,12 +1341,6 @@
|
||||||
fi
|
fi
|
||||||
fi
|
fi
|
||||||
|
|
||||||
-libpcapdir=libpcap-possiblymodified
|
-libpcapdir=libpcap
|
||||||
-
|
-
|
||||||
-
|
-
|
||||||
-pcredir=libpcre
|
-pcredir=libpcre
|
||||||
|
@ -14,25 +14,28 @@ diff -urN nmap-3.81.old/configure nmap-3.81.dev/configure
|
||||||
ac_config_headers="$ac_config_headers config.h"
|
ac_config_headers="$ac_config_headers config.h"
|
||||||
|
|
||||||
|
|
||||||
diff -urN nmap-3.81.old/Makefile.in nmap-3.81.dev/Makefile.in
|
diff -urN nmap-4.01.old/Makefile.in nmap-4.01.dev/Makefile.in
|
||||||
--- nmap-3.81.old/Makefile.in 2005-02-07 07:14:03.000000000 +0100
|
--- nmap-4.01.old/Makefile.in 2006-02-09 19:22:27.000000000 -0700
|
||||||
+++ nmap-3.81.dev/Makefile.in 2005-04-26 14:52:39.000000000 +0200
|
+++ nmap-4.01.dev/Makefile.in 2006-03-29 23:14:12.000000000 -0700
|
||||||
@@ -29,7 +29,7 @@
|
@@ -29,7 +29,7 @@
|
||||||
# CFLAGS = $(DEFS) $(INCLS)
|
# CFLAGS = $(DEFS) $(INCLS)
|
||||||
STATIC =
|
STATIC =
|
||||||
LDFLAGS = @LDFLAGS@ $(STATIC)
|
LDFLAGS = @LDFLAGS@ $(STATIC)
|
||||||
-LIBS = @LIBNBASE_LIBS@ @LIBNSOCK_LIBS@ @LIBPCRE_LIBS@ @LIBPCAP_LIBS@ @OPENSSL_LIBS@ @LIBS@
|
-LIBS = @LIBNBASE_LIBS@ @LIBNSOCK_LIBS@ @LIBPCRE_LIBS@ @LIBPCAP_LIBS@ @OPENSSL_LIBS@ @LIBDNET_LIBS@ @LIBS@
|
||||||
+LIBS = @LIBNBASE_LIBS@ @LIBNSOCK_LIBS@ -lpcre -lpcap @OPENSSL_LIBS@ @LIBS@
|
+LIBS = @LIBNBASE_LIBS@ @LIBNSOCK_LIBS@ -lpcre -lpcap @OPENSSL_LIBS@ -ldnet @LIBS@
|
||||||
# LIBS = -lefence @LIBS@
|
# LIBS = -lefence @LIBS@
|
||||||
# LIBS = -lrmalloc @LIBS@
|
# LIBS = -lrmalloc @LIBS@
|
||||||
SHTOOL = ./shtool
|
SHTOOL = ./shtool
|
||||||
@@ -69,12 +69,6 @@
|
@@ -68,15 +68,6 @@
|
||||||
# all of the prerequisites (e.g. recursive makes and such)
|
# all of the prerequisites (e.g. recursive makes and such)
|
||||||
FORCE:
|
FORCE:
|
||||||
|
|
||||||
-$(LIBPCREDIR)/libpcre.a: $(LIBPCREDIR)/Makefile FORCE
|
-$(LIBPCREDIR)/libpcre.a: $(LIBPCREDIR)/Makefile FORCE
|
||||||
- @echo Compiling libpcre; cd $(LIBPCREDIR) && $(MAKE)
|
- @echo Compiling libpcre; cd $(LIBPCREDIR) && $(MAKE)
|
||||||
-
|
-
|
||||||
|
-$(LIBDNETDIR)/src/.libs/libdnet.a: $(LIBDNETDIR)/Makefile FORCE
|
||||||
|
- @echo Compiling libdnet; cd $(LIBDNETDIR) && $(MAKE)
|
||||||
|
-
|
||||||
-$(LIBPCAPDIR)/libpcap.a: $(LIBPCAPDIR)/Makefile FORCE
|
-$(LIBPCAPDIR)/libpcap.a: $(LIBPCAPDIR)/Makefile FORCE
|
||||||
- @echo Compiling libpcap; cd $(LIBPCAPDIR) && $(MAKE)
|
- @echo Compiling libpcap; cd $(LIBPCAPDIR) && $(MAKE)
|
||||||
-
|
-
|
||||||
|
|
|
@ -1,11 +1,11 @@
|
||||||
diff -ruN nmap-3.81-old/Makefile.in nmap-3.81-new/Makefile.in
|
diff -urN nmap-4.01.old/Makefile.in nmap-4.01.dev/Makefile.in
|
||||||
--- nmap-3.81-old/Makefile.in 2005-10-02 16:32:52.000000000 +0200
|
--- nmap-4.01.old/Makefile.in 2006-02-09 19:22:27.000000000 -0700
|
||||||
+++ nmap-3.81-new/Makefile.in 2005-10-02 16:34:46.000000000 +0200
|
+++ nmap-4.01.dev/Makefile.in 2006-03-29 23:14:12.000000000 -0700
|
||||||
@@ -262,7 +262,7 @@
|
@@ -144,7 +135,7 @@
|
||||||
|
|
||||||
install-nmap: $(TARGET)
|
install-nmap: $(TARGET)
|
||||||
$(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(nmapdatadir)
|
$(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(nmapdatadir)
|
||||||
- $(INSTALL) -c -m 755 nmap -s $(DESTDIR)$(bindir)/nmap
|
- $(INSTALL) -c -m 755 -s nmap $(DESTDIR)$(bindir)/nmap
|
||||||
+ $(INSTALL) -c -m 755 nmap $(DESTDIR)$(bindir)/nmap
|
+ $(INSTALL) -c -m 755 nmap $(DESTDIR)$(bindir)/nmap
|
||||||
$(INSTALL) -c -m 644 docs/$(TARGET).1 $(DESTDIR)$(mandir)/man1/$(TARGET).1
|
$(INSTALL) -c -m 644 docs/$(TARGET).1 $(DESTDIR)$(mandir)/man1/$(TARGET).1
|
||||||
$(INSTALL) -c -m 644 docs/nmap.xsl $(DESTDIR)$(nmapdatadir)/
|
$(INSTALL) -c -m 644 docs/nmap.xsl $(DESTDIR)$(nmapdatadir)/
|
||||||
|
|
Loading…
Reference in New Issue