mirror of https://github.com/hak5/openwrt.git
kobs-ng: add new package
Signed-off-by: Tim Harvey <tharvey@gateworks.com> Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 37894lede-17.01
parent
e01fb70f1b
commit
1eb21b87bd
|
@ -0,0 +1,45 @@
|
|||
#
|
||||
# Copyright (C) 2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=kobs-ng
|
||||
PKG_VERSION:=3.0.35-4.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://repository.timesys.com/buildsources/k/kobs-ng/kobs-ng-$(PKG_VERSION)/
|
||||
PKG_MD5SUM:=26104c577f59a6b81782a5bd16aadd82
|
||||
|
||||
PKG_LICENSE:=GPLv2
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/kobs-ng
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=Application for writing bootstreams to NAND flash
|
||||
DEPENDS:=@TARGET_imx6
|
||||
endef
|
||||
|
||||
define Package/kobs-ng/description
|
||||
The kobs-ng application writes a bootstream to NAND flash with the proper
|
||||
FCB/DBBT headers and replicated streams.
|
||||
endef
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
echo "const char* git_sha = \"$(PKG_VERSION)\";" > $(PKG_BUILD_DIR)/autoversion.h
|
||||
endef
|
||||
|
||||
define Package/kobs-ng/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/kobs-ng $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,kobs-ng))
|
|
@ -0,0 +1,76 @@
|
|||
From: Paul B. Henson <henson@acm.org>
|
||||
|
||||
Newer kernel headers renamed mtd mode defines and no longer support
|
||||
MEMSETOOBSEL. Allow code to work with both older and newer kernel
|
||||
versions.
|
||||
|
||||
Signed-off-by: Paul B. Henson <henson@acm.org>
|
||||
---
|
||||
|
||||
http://git.buildroot.net/buildroot/plain/package/kobs-ng/kobs-ng-fix-mtd-defines.patch
|
||||
|
||||
--- a/src/mtd.c
|
||||
+++ b/src/mtd.c
|
||||
@@ -852,8 +852,11 @@ void mtd_close(struct mtd_data *md)
|
||||
mp = &md->part[i];
|
||||
|
||||
if (mp->fd != -1) {
|
||||
+/* Newer kernels dropped MEMSETOOBSEL */
|
||||
+#ifdef MEMSETOOBSEL
|
||||
(void)ioctl(mp->fd, MEMSETOOBSEL,
|
||||
&mp->old_oobinfo);
|
||||
+#endif
|
||||
close(mp->fd);
|
||||
}
|
||||
|
||||
@@ -896,6 +899,8 @@ int mtd_set_ecc_mode(struct mtd_data *md
|
||||
continue;
|
||||
}
|
||||
|
||||
+/* Newer kernels dropped MEMSETOOBSEL */
|
||||
+#ifdef MEMSETOOBSEL
|
||||
if (r == -ENOTTY) {
|
||||
r = ioctl(mp->fd, MEMSETOOBSEL, &mp->old_oobinfo);
|
||||
if (r != 0) {
|
||||
@@ -904,6 +909,7 @@ int mtd_set_ecc_mode(struct mtd_data *md
|
||||
}
|
||||
mp->oobinfochanged = 0;
|
||||
}
|
||||
+#endif
|
||||
} else {
|
||||
r = ioctl(mp->fd, MTDFILEMODE, (void *)MTD_MODE_RAW);
|
||||
if (r != 0 && r != -ENOTTY) {
|
||||
@@ -911,6 +917,8 @@ int mtd_set_ecc_mode(struct mtd_data *md
|
||||
continue;
|
||||
}
|
||||
|
||||
+/* Newer kernels dropped MEMSETOOBSEL */
|
||||
+#ifdef MEMSETOOBSEL
|
||||
if (r == -ENOTTY) {
|
||||
r = ioctl(mp->fd, MEMSETOOBSEL, &none_oobinfo);
|
||||
if (r != 0) {
|
||||
@@ -920,6 +928,7 @@ int mtd_set_ecc_mode(struct mtd_data *md
|
||||
mp->oobinfochanged = 1;
|
||||
} else
|
||||
mp->oobinfochanged = 2;
|
||||
+#endif
|
||||
}
|
||||
|
||||
mp->ecc = ecc;
|
||||
--- a/src/mtd.h
|
||||
+++ b/src/mtd.h
|
||||
@@ -31,6 +31,14 @@
|
||||
#include "BootControlBlocks.h"
|
||||
#include "rom_nand_hamming_code_ecc.h"
|
||||
|
||||
+// Newer kernel headers renamed define
|
||||
+#ifndef MTD_MODE_NORMAL
|
||||
+#define MTD_MODE_NORMAL MTD_FILE_MODE_NORMAL
|
||||
+#endif
|
||||
+#ifndef MTD_MODE_RAW
|
||||
+#define MTD_MODE_RAW MTD_FILE_MODE_RAW
|
||||
+#endif
|
||||
+
|
||||
//------------------------------------------------------------------------------
|
||||
// Re-definitions of true and false, because the standard ones aren't good
|
||||
// enough?
|
Loading…
Reference in New Issue