mirror of https://github.com/hak5/openwrt.git
tools/tar: Update to 1.31
Update tar to 1.31 Fixes CVE-2018-20482 Switch to tar.xz tarball Refresh patches Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>openwrt-19.07
parent
e3311cb138
commit
1d1dabdf0a
|
@ -8,13 +8,13 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=tar
|
PKG_NAME:=tar
|
||||||
PKG_CPE_ID:=cpe:/a:gnu:tar
|
PKG_CPE_ID:=cpe:/a:gnu:tar
|
||||||
PKG_VERSION:=1.30
|
PKG_VERSION:=1.31
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/tar
|
PKG_SOURCE_URL:=@GNU/tar
|
||||||
PKG_HASH:=87592b86cb037c554375f5868bdd3cc57748aef38d6cb741c81065f0beac63b7
|
PKG_HASH:=37f3ef1ceebd8b7e1ebf5b8cc6c65bb8ebf002c7d049032bf456860f25ec2dc1
|
||||||
|
|
||||||
HOST_BUILD_PARALLEL := 1
|
HOST_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
|
|
@ -5,7 +5,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||||
---
|
---
|
||||||
--- a/src/create.c
|
--- a/src/create.c
|
||||||
+++ b/src/create.c
|
+++ b/src/create.c
|
||||||
@@ -544,17 +544,8 @@ write_gnu_long_link (struct tar_stat_inf
|
@@ -543,17 +543,8 @@ write_gnu_long_link (struct tar_stat_inf
|
||||||
union block *header;
|
union block *header;
|
||||||
|
|
||||||
header = start_private_header ("././@LongLink", size, 0);
|
header = start_private_header ("././@LongLink", size, 0);
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/create.c
|
--- a/src/create.c
|
||||||
+++ b/src/create.c
|
+++ b/src/create.c
|
||||||
@@ -1853,6 +1853,7 @@ dump_file0 (struct tar_stat_info *st, ch
|
@@ -1852,6 +1852,7 @@ dump_file0 (struct tar_stat_info *st, ch
|
||||||
#ifdef HAVE_READLINK
|
#ifdef HAVE_READLINK
|
||||||
else if (S_ISLNK (st->stat.st_mode))
|
else if (S_ISLNK (st->stat.st_mode))
|
||||||
{
|
{
|
||||||
|
|
Loading…
Reference in New Issue