update hostapd to latest development release (v0.4.5), add driver for hostap, enable wpa-psk.

SVN-Revision: 2276
lede-17.01
Nicolas Thill 2005-10-23 13:16:37 +00:00
parent 17104f2b8f
commit 1c47bcd5ec
4 changed files with 1284 additions and 14 deletions

View File

@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd PKG_NAME:=hostapd
PKG_VERSION:=0.3.9 PKG_VERSION:=0.4.5
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_MD5SUM:=c9cab38387594090a36062008b3de59e PKG_MD5SUM:=3d775a19f8071d6f8a363ef0dad58655
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/ PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

View File

@ -10,7 +10,7 @@
# to override previous values of the variables. # to override previous values of the variables.
# Driver interface for Host AP driver # Driver interface for Host AP driver
#CONFIG_DRIVER_HOSTAP=y CONFIG_DRIVER_HOSTAP=y
# Driver interface for wired authenticator # Driver interface for wired authenticator
#CONFIG_DRIVER_WIRED=y #CONFIG_DRIVER_WIRED=y
@ -48,6 +48,9 @@ CONFIG_EAP_MSCHAPV2=y
# EAP-PEAP for the integrated EAP authenticator # EAP-PEAP for the integrated EAP authenticator
CONFIG_EAP_PEAP=y CONFIG_EAP_PEAP=y
# EAP-PSK for the integrated EAP authenticator
CONFIG_EAP_PSK=y
# EAP-GTC for the integrated EAP authenticator # EAP-GTC for the integrated EAP authenticator
CONFIG_EAP_GTC=y CONFIG_EAP_GTC=y

View File

@ -19,14 +19,3 @@ diff -ruN hostapd-0.3.9-old/Makefile hostapd-0.3.9-new/Makefile
driver_conf.c: Makefile .config driver_conf.c: Makefile .config
rm -f driver_conf.c rm -f driver_conf.c
diff -ruN hostapd-0.3.9-old/driver_madwifi.c hostapd-0.3.9-new/driver_madwifi.c
--- hostapd-0.3.9-old/driver_madwifi.c 2005-05-18 05:38:57.000000000 +0200
+++ hostapd-0.3.9-new/driver_madwifi.c 2005-08-14 08:23:21.000000000 +0200
@@ -24,6 +24,7 @@
#include <include/compat.h>
#include <net80211/ieee80211.h>
#include <net80211/ieee80211_crypto.h>
+#include <net80211/_ieee80211.h>
#include <net80211/ieee80211_ioctl.h>
#include <net/if_arp.h>

File diff suppressed because it is too large Load Diff