mirror of https://github.com/hak5/openwrt.git
linux-atm: Add missing headers
This fixes compilation with -Werror=implicit-function-declaration. Signed-off-by: Rosen Penev <rosenp@gmail.com>master
parent
aa4f68ac91
commit
1b1c47577b
|
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
|
||||
PKG_NAME:=linux-atm
|
||||
PKG_VERSION:=2.5.2
|
||||
PKG_RELEASE:=6
|
||||
PKG_RELEASE:=7
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
|
|
|
@ -0,0 +1,30 @@
|
|||
--- a/src/include/atmd.h
|
||||
+++ b/src/include/atmd.h
|
||||
@@ -10,6 +10,7 @@
|
||||
|
||||
#include <stdint.h>
|
||||
#include <stdio.h>
|
||||
+#include <string.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/time.h>
|
||||
|
||||
--- a/src/lib/unix.c
|
||||
+++ b/src/lib/unix.c
|
||||
@@ -8,6 +8,7 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
+#include <string.h>
|
||||
#include <unistd.h>
|
||||
#include <errno.h>
|
||||
#include <sys/types.h>
|
||||
--- a/src/sigd/kernel.c
|
||||
+++ b/src/sigd/kernel.c
|
||||
@@ -8,6 +8,7 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
+#include <string.h>
|
||||
#include <errno.h>
|
||||
#include <assert.h>
|
||||
|
Loading…
Reference in New Issue