mirror of https://github.com/hak5/openwrt.git
lldpd: Fix compilation without fortify-headers
Upstream backport. Signed-off-by: Rosen Penev <rosenp@gmail.com>master
parent
43eb93441f
commit
121ad10601
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=lldpd
|
||||
PKG_VERSION:=1.0.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://media.luffy.cx/files/lldpd
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.ac 2019-04-30 17:04:53.542449926 +0300
|
||||
+++ b/configure.ac 2019-04-30 17:06:26.974453867 +0300
|
||||
@@ -244,7 +244,13 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -244,7 +244,13 @@ PKG_CHECK_MODULES([check], [check >= 0.9
|
||||
|
||||
# Third-party libraries
|
||||
lldp_CHECK_LIBEVENT
|
||||
|
|
|
@ -0,0 +1,19 @@
|
|||
From b2eebb31fc21b5ce12ef8944b50088119f1b9427 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
|
||||
Date: Mon, 25 Mar 2019 18:43:03 +0100
|
||||
Subject: [PATCH] priv: include limits.h for PATH_MAX
|
||||
|
||||
---
|
||||
src/daemon/priv.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
--- a/src/daemon/priv.c
|
||||
+++ b/src/daemon/priv.c
|
||||
@@ -27,6 +27,7 @@
|
||||
#include <unistd.h>
|
||||
#include <signal.h>
|
||||
#include <errno.h>
|
||||
+#include <limits.h>
|
||||
#include <sys/wait.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/socket.h>
|
Loading…
Reference in New Issue