mirror of https://github.com/hak5/openwrt.git
iptables: update to 1.8.4
Update iptables to 1.8.4 ChangeLog: https://netfilter.org/projects/iptables/files/changes-iptables-1.8.4.txt Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>master
parent
37929ddb70
commit
10cbc896c0
|
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=iptables
|
PKG_NAME:=iptables
|
||||||
PKG_VERSION:=1.8.3
|
PKG_VERSION:=1.8.4
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_URL:=https://netfilter.org/projects/iptables/files
|
PKG_SOURCE_URL:=https://netfilter.org/projects/iptables/files
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_HASH:=a23cac034181206b4545f4e7e730e76e08b5f3dd78771ba9645a6756de9cdd80
|
PKG_HASH:=993a3a5490a544c2cbf2ef15cf7e7ed21af1845baf228318d5c36ef8827e157c
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_FLAGS:=nonshared
|
PKG_FLAGS:=nonshared
|
||||||
|
|
|
@ -54,7 +54,7 @@
|
||||||
initextb_func := $(addprefix ebt_,${pfb_build_static})
|
initextb_func := $(addprefix ebt_,${pfb_build_static})
|
||||||
--- a/iptables/Makefile.am
|
--- a/iptables/Makefile.am
|
||||||
+++ b/iptables/Makefile.am
|
+++ b/iptables/Makefile.am
|
||||||
@@ -8,19 +8,22 @@ BUILT_SOURCES =
|
@@ -7,19 +7,22 @@ BUILT_SOURCES =
|
||||||
|
|
||||||
xtables_legacy_multi_SOURCES = xtables-legacy-multi.c iptables-xml.c
|
xtables_legacy_multi_SOURCES = xtables-legacy-multi.c iptables-xml.c
|
||||||
xtables_legacy_multi_CFLAGS = ${AM_CFLAGS}
|
xtables_legacy_multi_CFLAGS = ${AM_CFLAGS}
|
||||||
|
@ -80,8 +80,8 @@
|
||||||
endif
|
endif
|
||||||
xtables_legacy_multi_SOURCES += xshared.c iptables-restore.c iptables-save.c
|
xtables_legacy_multi_SOURCES += xshared.c iptables-restore.c iptables-save.c
|
||||||
xtables_legacy_multi_LDADD += ../libxtables/libxtables.la -lm
|
xtables_legacy_multi_LDADD += ../libxtables/libxtables.la -lm
|
||||||
@@ -30,7 +33,8 @@ if ENABLE_NFTABLES
|
@@ -28,7 +31,8 @@ xtables_legacy_multi_LDADD += ../libxt
|
||||||
BUILT_SOURCES += xtables-config-parser.h
|
if ENABLE_NFTABLES
|
||||||
xtables_nft_multi_SOURCES = xtables-nft-multi.c iptables-xml.c
|
xtables_nft_multi_SOURCES = xtables-nft-multi.c iptables-xml.c
|
||||||
xtables_nft_multi_CFLAGS = ${AM_CFLAGS}
|
xtables_nft_multi_CFLAGS = ${AM_CFLAGS}
|
||||||
-xtables_nft_multi_LDADD = ../extensions/libext.a ../extensions/libext_ebt.a
|
-xtables_nft_multi_LDADD = ../extensions/libext.a ../extensions/libext_ebt.a
|
||||||
|
@ -90,13 +90,13 @@
|
||||||
if ENABLE_STATIC
|
if ENABLE_STATIC
|
||||||
xtables_nft_multi_CFLAGS += -DALL_INCLUSIVE
|
xtables_nft_multi_CFLAGS += -DALL_INCLUSIVE
|
||||||
endif
|
endif
|
||||||
@@ -45,7 +49,8 @@ xtables_nft_multi_SOURCES += xtables-sav
|
@@ -42,7 +46,8 @@ xtables_nft_multi_SOURCES += xtables-sav
|
||||||
xtables-eb-standalone.c xtables-eb.c \
|
xtables-eb-standalone.c xtables-eb.c \
|
||||||
xtables-eb-translate.c \
|
xtables-eb-translate.c \
|
||||||
xtables-translate.c
|
xtables-translate.c
|
||||||
-xtables_nft_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS} ../extensions/libext4.a ../extensions/libext6.a ../extensions/libext_ebt.a ../extensions/libext_arpt.a
|
-xtables_nft_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS} ../extensions/libext4.a ../extensions/libext6.a ../extensions/libext_ebt.a ../extensions/libext_arpt.a
|
||||||
+xtables_nft_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS}
|
+xtables_nft_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS}
|
||||||
+xtables_nft_multi_LDFLAGS += -liptext4 -liptext6 -liptext_arpt
|
+xtables_nft_multi_LDFLAGS += -liptext4 -liptext6 -liptext_arpt
|
||||||
# yacc and lex generate dirty code
|
|
||||||
xtables_nft_multi-xtables-config-parser.o xtables_nft_multi-xtables-config-syntax.o: AM_CFLAGS += -Wno-missing-prototypes -Wno-missing-declarations -Wno-implicit-function-declaration -Wno-nested-externs -Wno-undef -Wno-redundant-decls
|
|
||||||
xtables_nft_multi_SOURCES += xshared.c
|
xtables_nft_multi_SOURCES += xshared.c
|
||||||
|
xtables_nft_multi_LDADD += ../libxtables/libxtables.la -lm
|
||||||
|
endif
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/extensions/libxt_conntrack.c
|
--- a/extensions/libxt_conntrack.c
|
||||||
+++ b/extensions/libxt_conntrack.c
|
+++ b/extensions/libxt_conntrack.c
|
||||||
@@ -1389,6 +1389,7 @@ static int conntrack3_mt6_xlate(struct x
|
@@ -1387,6 +1387,7 @@ static int conntrack3_mt6_xlate(struct x
|
||||||
}
|
}
|
||||||
|
|
||||||
static struct xtables_match conntrack_mt_reg[] = {
|
static struct xtables_match conntrack_mt_reg[] = {
|
||||||
|
@ -8,7 +8,7 @@
|
||||||
{
|
{
|
||||||
.version = XTABLES_VERSION,
|
.version = XTABLES_VERSION,
|
||||||
.name = "conntrack",
|
.name = "conntrack",
|
||||||
@@ -1464,6 +1465,7 @@ static struct xtables_match conntrack_mt
|
@@ -1462,6 +1463,7 @@ static struct xtables_match conntrack_mt
|
||||||
.alias = conntrack_print_name_alias,
|
.alias = conntrack_print_name_alias,
|
||||||
.x6_options = conntrack2_mt_opts,
|
.x6_options = conntrack2_mt_opts,
|
||||||
},
|
},
|
||||||
|
@ -16,7 +16,7 @@
|
||||||
{
|
{
|
||||||
.version = XTABLES_VERSION,
|
.version = XTABLES_VERSION,
|
||||||
.name = "conntrack",
|
.name = "conntrack",
|
||||||
@@ -1496,6 +1498,7 @@ static struct xtables_match conntrack_mt
|
@@ -1494,6 +1496,7 @@ static struct xtables_match conntrack_mt
|
||||||
.x6_options = conntrack3_mt_opts,
|
.x6_options = conntrack3_mt_opts,
|
||||||
.xlate = conntrack3_mt6_xlate,
|
.xlate = conntrack3_mt6_xlate,
|
||||||
},
|
},
|
||||||
|
@ -24,7 +24,7 @@
|
||||||
{
|
{
|
||||||
.family = NFPROTO_UNSPEC,
|
.family = NFPROTO_UNSPEC,
|
||||||
.name = "state",
|
.name = "state",
|
||||||
@@ -1526,6 +1529,8 @@ static struct xtables_match conntrack_mt
|
@@ -1524,6 +1527,8 @@ static struct xtables_match conntrack_mt
|
||||||
.x6_parse = state_ct23_parse,
|
.x6_parse = state_ct23_parse,
|
||||||
.x6_options = state_opts,
|
.x6_options = state_opts,
|
||||||
},
|
},
|
||||||
|
@ -33,7 +33,7 @@
|
||||||
{
|
{
|
||||||
.family = NFPROTO_UNSPEC,
|
.family = NFPROTO_UNSPEC,
|
||||||
.name = "state",
|
.name = "state",
|
||||||
@@ -1555,6 +1560,7 @@ static struct xtables_match conntrack_mt
|
@@ -1553,6 +1558,7 @@ static struct xtables_match conntrack_mt
|
||||||
.x6_parse = state_parse,
|
.x6_parse = state_parse,
|
||||||
.x6_options = state_opts,
|
.x6_options = state_opts,
|
||||||
},
|
},
|
||||||
|
|
Loading…
Reference in New Issue