mirror of https://github.com/hak5/openwrt.git
mwlwifi: Fix loading with backports v5.3
This adds a vendor command policy which is enforced since mac80211 from
kernel 5.3
Fixes: 928e893a11
("mac80211: Update to version 5.3-rc4-1")
Signed-off-by: Boris Krasnovskiy <boris.krasnovskiy@lairdtech.com>
master
parent
552c48ea43
commit
0c43219a35
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mwlwifi
|
PKG_NAME:=mwlwifi
|
||||||
PKG_RELEASE=1
|
PKG_RELEASE=2
|
||||||
|
|
||||||
PKG_LICENSE:=ISC
|
PKG_LICENSE:=ISC
|
||||||
PKG_LICENSE_FILES:=
|
PKG_LICENSE_FILES:=
|
||||||
|
|
|
@ -0,0 +1,19 @@
|
||||||
|
mac80211 from kernel 5.3 and later checks the new policy attribute.
|
||||||
|
|
||||||
|
--- a/vendor_cmd.c
|
||||||
|
+++ b/vendor_cmd.c
|
||||||
|
@@ -92,12 +92,14 @@ static const struct wiphy_vendor_command
|
||||||
|
.subcmd = MWL_VENDOR_CMD_SET_BF_TYPE},
|
||||||
|
.flags = WIPHY_VENDOR_CMD_NEED_NETDEV,
|
||||||
|
.doit = mwl_vendor_cmd_set_bf_type,
|
||||||
|
+ .policy = mwl_vendor_attr_policy,
|
||||||
|
},
|
||||||
|
{
|
||||||
|
.info = { .vendor_id = MRVL_OUI,
|
||||||
|
.subcmd = MWL_VENDOR_CMD_GET_BF_TYPE},
|
||||||
|
.flags = WIPHY_VENDOR_CMD_NEED_NETDEV,
|
||||||
|
.doit = mwl_vendor_cmd_get_bf_type,
|
||||||
|
+ .policy = mwl_vendor_attr_policy,
|
||||||
|
}
|
||||||
|
};
|
||||||
|
|
Loading…
Reference in New Issue