mirror of https://github.com/hak5/openwrt.git
mac80211: fix up ath10k led patch
Signed-off-by: John Crispin <john@phrozen.org>openwrt-18.06
parent
6e4fb77f9e
commit
04353c3af8
|
@ -83,8 +83,10 @@ v13:
|
|||
12 files changed, 314 insertions(+), 1 deletion(-)
|
||||
create mode 100644 drivers/net/wireless/ath/ath10k/leds.c
|
||||
create mode 100644 drivers/net/wireless/ath/ath10k/leds.h
|
||||
--- a/drivers/net/wireless/ath/ath10k/Kconfig
|
||||
+++ b/drivers/net/wireless/ath/ath10k/Kconfig
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/Kconfig
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/drivers/net/wireless/ath/ath10k/Kconfig
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/Kconfig
|
||||
@@ -56,6 +56,16 @@ config ATH10K_DEBUGFS
|
||||
|
||||
If unsure, say Y to make it easier to debug problems.
|
||||
|
@ -102,8 +104,10 @@ v13:
|
|||
config ATH10K_SPECTRAL
|
||||
bool "Atheros ath10k spectral scan support"
|
||||
depends on ATH10K_DEBUGFS
|
||||
--- a/drivers/net/wireless/ath/ath10k/Makefile
|
||||
+++ b/drivers/net/wireless/ath/ath10k/Makefile
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/Makefile
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/drivers/net/wireless/ath/ath10k/Makefile
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/Makefile
|
||||
@@ -18,6 +18,7 @@ ath10k_core-$(CPTCFG_ATH10K_SPECTRAL) +=
|
||||
ath10k_core-$(CPTCFG_NL80211_TESTMODE) += testmode.o
|
||||
ath10k_core-$(CPTCFG_ATH10K_TRACING) += trace.o
|
||||
|
@ -112,18 +116,22 @@ v13:
|
|||
ath10k_core-$(CPTCFG_MAC80211_DEBUGFS) += debugfs_sta.o
|
||||
ath10k_core-$(CONFIG_PM) += wow.o
|
||||
|
||||
--- a/local-symbols
|
||||
+++ b/local-symbols
|
||||
@@ -144,6 +144,7 @@ ATH10K_DEBUG=
|
||||
Index: backports-2017-11-01/local-symbols
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/local-symbols
|
||||
+++ backports-2017-11-01/local-symbols
|
||||
@@ -143,6 +143,7 @@ ATH10K_USB=
|
||||
ATH10K_DEBUG=
|
||||
ATH10K_DEBUGFS=
|
||||
ATH10K_SPECTRAL=
|
||||
ATH10K_THERMAL=
|
||||
+ATH10K_LEDS=
|
||||
ATH10K_TRACING=
|
||||
ATH10K_DFS_CERTIFIED=
|
||||
WCN36XX=
|
||||
--- a/drivers/net/wireless/ath/ath10k/core.c
|
||||
+++ b/drivers/net/wireless/ath/ath10k/core.c
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/core.c
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/drivers/net/wireless/ath/ath10k/core.c
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/core.c
|
||||
@@ -32,6 +32,7 @@
|
||||
#include "htt.h"
|
||||
#include "testmode.h"
|
||||
|
@ -211,8 +219,10 @@ v13:
|
|||
ath10k_thermal_unregister(ar);
|
||||
/* Stop spectral before unregistering from mac80211 to remove the
|
||||
* relayfs debugfs file cleanly. Otherwise the parent debugfs tree
|
||||
--- a/drivers/net/wireless/ath/ath10k/core.h
|
||||
+++ b/drivers/net/wireless/ath/ath10k/core.h
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/core.h
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/drivers/net/wireless/ath/ath10k/core.h
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/core.h
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <linux/pci.h>
|
||||
#include <linux/uuid.h>
|
||||
|
@ -243,8 +253,10 @@ v13:
|
|||
/* protected by data_lock */
|
||||
u32 fw_crash_counter;
|
||||
u32 fw_warm_reset_counter;
|
||||
--- a/drivers/net/wireless/ath/ath10k/hw.h
|
||||
+++ b/drivers/net/wireless/ath/ath10k/hw.h
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/hw.h
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/drivers/net/wireless/ath/ath10k/hw.h
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/hw.h
|
||||
@@ -490,6 +490,7 @@ struct ath10k_hw_params {
|
||||
const char *name;
|
||||
u32 patch_load_addr;
|
||||
|
@ -253,8 +265,10 @@ v13:
|
|||
u32 otp_exe_param;
|
||||
|
||||
/* Type of hw cycle counter wraparound logic, for more info
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/leds.c
|
||||
===================================================================
|
||||
--- /dev/null
|
||||
+++ b/drivers/net/wireless/ath/ath10k/leds.c
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/leds.c
|
||||
@@ -0,0 +1,103 @@
|
||||
+/*
|
||||
+ * Copyright (c) 2005-2011 Atheros Communications Inc.
|
||||
|
@ -359,8 +373,10 @@ v13:
|
|||
+ led_classdev_unregister(&ar->leds.cdev);
|
||||
+}
|
||||
+
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/leds.h
|
||||
===================================================================
|
||||
--- /dev/null
|
||||
+++ b/drivers/net/wireless/ath/ath10k/leds.h
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/leds.h
|
||||
@@ -0,0 +1,41 @@
|
||||
+/*
|
||||
+ * Copyright (c) 2018, The Linux Foundation. All rights reserved.
|
||||
|
@ -403,8 +419,10 @@ v13:
|
|||
+
|
||||
+#endif
|
||||
+#endif /* _LEDS_H_ */
|
||||
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
||||
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/mac.c
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/drivers/net/wireless/ath/ath10k/mac.c
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/mac.c
|
||||
@@ -32,6 +32,7 @@
|
||||
#include "wmi-tlv.h"
|
||||
#include "wmi-ops.h"
|
||||
|
@ -413,8 +431,10 @@ v13:
|
|||
|
||||
/*********/
|
||||
/* Rates */
|
||||
--- a/drivers/net/wireless/ath/ath10k/wmi-ops.h
|
||||
+++ b/drivers/net/wireless/ath/ath10k/wmi-ops.h
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/wmi-ops.h
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/drivers/net/wireless/ath/ath10k/wmi-ops.h
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/wmi-ops.h
|
||||
@@ -197,6 +197,10 @@ struct wmi_ops {
|
||||
(struct ath10k *ar,
|
||||
enum wmi_bss_survey_req_type type);
|
||||
|
@ -462,8 +482,10 @@ v13:
|
|||
static inline int
|
||||
ath10k_wmi_dbglog_cfg(struct ath10k *ar, u64 module_enable, u32 log_level)
|
||||
{
|
||||
--- a/drivers/net/wireless/ath/ath10k/wmi-tlv.c
|
||||
+++ b/drivers/net/wireless/ath/ath10k/wmi-tlv.c
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/wmi-tlv.c
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/drivers/net/wireless/ath/ath10k/wmi-tlv.c
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/wmi-tlv.c
|
||||
@@ -3619,6 +3619,8 @@ static const struct wmi_ops wmi_tlv_ops
|
||||
.gen_echo = ath10k_wmi_tlv_op_gen_echo,
|
||||
.gen_vdev_spectral_conf = ath10k_wmi_tlv_op_gen_vdev_spectral_conf,
|
||||
|
@ -473,8 +495,10 @@ v13:
|
|||
};
|
||||
|
||||
static const struct wmi_peer_flags_map wmi_tlv_peer_flags_map = {
|
||||
--- a/drivers/net/wireless/ath/ath10k/wmi.c
|
||||
+++ b/drivers/net/wireless/ath/ath10k/wmi.c
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/wmi.c
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/drivers/net/wireless/ath/ath10k/wmi.c
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/wmi.c
|
||||
@@ -6580,6 +6580,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
|
||||
return skb;
|
||||
}
|
||||
|
@ -571,8 +595,10 @@ v13:
|
|||
};
|
||||
|
||||
int ath10k_wmi_attach(struct ath10k *ar)
|
||||
--- a/drivers/net/wireless/ath/ath10k/wmi.h
|
||||
+++ b/drivers/net/wireless/ath/ath10k/wmi.h
|
||||
Index: backports-2017-11-01/drivers/net/wireless/ath/ath10k/wmi.h
|
||||
===================================================================
|
||||
--- backports-2017-11-01.orig/drivers/net/wireless/ath/ath10k/wmi.h
|
||||
+++ backports-2017-11-01/drivers/net/wireless/ath/ath10k/wmi.h
|
||||
@@ -2899,6 +2899,41 @@ enum wmi_10_4_feature_mask {
|
||||
|
||||
};
|
||||
|
|
Loading…
Reference in New Issue