mirror of https://github.com/hak5/openwrt.git
tools/coreutils: update to 8.32
Update coreutils to version 8.32. Remove upstreamed patch. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>master
parent
6a9c76a6c4
commit
040b625c4b
|
@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=coreutils
|
PKG_NAME:=coreutils
|
||||||
PKG_CPE_ID:=cpe:/a:gnu:coreutils
|
PKG_CPE_ID:=cpe:/a:gnu:coreutils
|
||||||
PKG_VERSION:=8.27
|
PKG_VERSION:=8.32
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/coreutils
|
PKG_SOURCE_URL:=@GNU/coreutils
|
||||||
PKG_HASH:=8891d349ee87b9ff7870f52b6d9312a9db672d2439d289bc57084771ca21656b
|
PKG_HASH:=4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa
|
||||||
|
|
||||||
HOST_BUILD_PARALLEL := 1
|
HOST_BUILD_PARALLEL := 1
|
||||||
|
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
--- a/lib/vasnprintf.c
|
|
||||||
+++ b/lib/vasnprintf.c
|
|
||||||
@@ -4858,7 +4858,11 @@ VASNPRINTF (DCHAR_T *resultbuf, size_t *
|
|
||||||
#endif
|
|
||||||
*fbp = dp->conversion;
|
|
||||||
#if USE_SNPRINTF
|
|
||||||
-# if !(((__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) && !defined __UCLIBC__) || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__))
|
|
||||||
+# if ! (((__GLIBC__ > 2 \
|
|
||||||
+ || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) \
|
|
||||||
+ && !defined __UCLIBC__) \
|
|
||||||
+ || (defined __APPLE__ && defined __MACH__) \
|
|
||||||
+ || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__))
|
|
||||||
fbp[1] = '%';
|
|
||||||
fbp[2] = 'n';
|
|
||||||
fbp[3] = '\0';
|
|
||||||
@@ -4872,6 +4876,9 @@ VASNPRINTF (DCHAR_T *resultbuf, size_t *
|
|
||||||
in format strings in writable memory may crash the program
|
|
||||||
(if compiled with _FORTIFY_SOURCE=2), so we should avoid it
|
|
||||||
in this situation. */
|
|
||||||
+ /* macOS 10.13 High Sierra behaves like glibc with
|
|
||||||
+ _FORTIFY_SOURCE=2, and older macOS releases
|
|
||||||
+ presumably do not need %n. */
|
|
||||||
/* On native Windows systems (such as mingw), we can avoid using
|
|
||||||
%n because:
|
|
||||||
- Although the gl_SNPRINTF_TRUNCATION_C99 test fails,
|
|
Loading…
Reference in New Issue