mirror of https://github.com/hak5/openwrt-owl.git
fix 2.6.30 lzma tuning patch to output file size at end of kernel, otherwise decompressor remains stuck
SVN-Revision: 21458owl
parent
bdf2a03107
commit
fa8c4aa164
|
@ -1,17 +1,17 @@
|
||||||
Index: linux-2.6.30.10/scripts/Makefile.lib
|
Index: linux-2.6.30.10/scripts/Makefile.lib
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.30.10.orig/scripts/Makefile.lib 2010-05-05 10:55:06.000000000 +0200
|
--- linux-2.6.30.10.orig/scripts/Makefile.lib 2010-05-15 16:46:57.000000000 +0200
|
||||||
+++ linux-2.6.30.10/scripts/Makefile.lib 2010-05-05 10:55:55.000000000 +0200
|
+++ linux-2.6.30.10/scripts/Makefile.lib 2010-05-15 18:53:02.000000000 +0200
|
||||||
@@ -204,4 +204,4 @@
|
@@ -204,4 +204,4 @@
|
||||||
# ---------------------------------------------------------------------------
|
# ---------------------------------------------------------------------------
|
||||||
|
|
||||||
quiet_cmd_lzma = LZMA $@
|
quiet_cmd_lzma = LZMA $@
|
||||||
-cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2 -eos
|
-cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2 -eos
|
||||||
+cmd_lzma = lzma e $< $@ -lc8 -eos
|
+cmd_lzma = (lzma e $< -lc8 -eos -so && $(size_append) $<) > $@ || (rm -f $@ ; false)
|
||||||
Index: linux-2.6.30.10/arch/x86/include/asm/boot.h
|
Index: linux-2.6.30.10/arch/x86/include/asm/boot.h
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.30.10.orig/arch/x86/include/asm/boot.h 2009-12-04 07:00:07.000000000 +0100
|
--- linux-2.6.30.10.orig/arch/x86/include/asm/boot.h 2010-05-15 16:45:57.000000000 +0200
|
||||||
+++ linux-2.6.30.10/arch/x86/include/asm/boot.h 2010-05-05 10:55:23.000000000 +0200
|
+++ linux-2.6.30.10/arch/x86/include/asm/boot.h 2010-05-15 16:46:58.000000000 +0200
|
||||||
@@ -13,7 +13,7 @@
|
@@ -13,7 +13,7 @@
|
||||||
+ (CONFIG_PHYSICAL_ALIGN - 1)) \
|
+ (CONFIG_PHYSICAL_ALIGN - 1)) \
|
||||||
& ~(CONFIG_PHYSICAL_ALIGN - 1))
|
& ~(CONFIG_PHYSICAL_ALIGN - 1))
|
||||||
|
|
Loading…
Reference in New Issue