update targets to 2.6.30.1, update patches

SVN-Revision: 16697
owl
Florian Fainelli 2009-07-05 14:39:13 +00:00
parent 62e10e7017
commit f74d16548d
15 changed files with 21 additions and 51 deletions

View File

@ -28,8 +28,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.29.2)
LINUX_KERNEL_MD5SUM:=a6839571a9e70baf821d2fb752f9c4c6
endif
ifeq ($(LINUX_VERSION),2.6.30)
LINUX_KERNEL_MD5SUM:=7a80058a6382e5108cdb5554d1609615
ifeq ($(LINUX_VERSION),2.6.30.1)
LINUX_KERNEL_MD5SUM:=7da2e2e31f1c00f2673d2dc50de76b33
endif
# disable the md5sum check for unknown kernel versions

View File

@ -10,7 +10,7 @@ ARCH:=avr32
BOARD:=avr32
BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
LINUX_VERSION:=2.6.30
LINUX_VERSION:=2.6.30.1
include $(INCLUDE_DIR)/target.mk

View File

@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
ARCH:=mipsel
BOARD:=cobalt
BOARDNAME:=Cobalt Microservers
FEATURES:=tgz pci
FEATURES:=tgz pci ext2
LINUX_VERSION:=2.6.30
LINUX_VERSION:=2.6.30.1
include $(INCLUDE_DIR)/target.mk

View File

@ -10,7 +10,7 @@ ARCH:=cris
BOARD:=etrax
BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.30
LINUX_VERSION:=2.6.30.1
DEVICE_TYPE=
include $(INCLUDE_DIR)/target.mk

View File

@ -12,7 +12,7 @@ BOARDNAME:=Cortina Systems CS351x
FEATURES:=squashfs
CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
LINUX_VERSION:=2.6.30
LINUX_VERSION:=2.6.30.1
include $(INCLUDE_DIR)/target.mk

View File

@ -6,11 +6,9 @@ precious blocks on an embedded system.
Signed-off-by: Florian Fainelli <florian@openwrt.org>
--
diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
index 65d3b19..a467ee5 100644
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -811,6 +811,17 @@ config I8259
@@ -791,6 +791,17 @@ config I8259
config MIPS_BONITO64
bool
@ -28,8 +26,6 @@ index 65d3b19..a467ee5 100644
config MIPS_MSC
bool
diff --git a/arch/mips/math-emu/Makefile b/arch/mips/math-emu/Makefile
index d547efd..7fdef24 100644
--- a/arch/mips/math-emu/Makefile
+++ b/arch/mips/math-emu/Makefile
@@ -2,12 +2,14 @@
@ -49,8 +45,6 @@ index d547efd..7fdef24 100644
+ dp_sqrt.o sp_sqrt.o
EXTRA_CFLAGS += -Werror
diff --git a/arch/mips/math-emu/cp1emu.c b/arch/mips/math-emu/cp1emu.c
index 890f779..9f4c767 100644
--- a/arch/mips/math-emu/cp1emu.c
+++ b/arch/mips/math-emu/cp1emu.c
@@ -56,6 +56,12 @@
@ -77,7 +71,7 @@ index 890f779..9f4c767 100644
/* Control registers */
#define FPCREG_RID 0 /* $0 = revision id */
@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_regs *xcp, struct mips_fpu_struct *ctx,
@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_r
return sig;
}
@ -91,11 +85,9 @@ index 890f779..9f4c767 100644
#ifdef CONFIG_DEBUG_FS
extern struct dentry *mips_debugfs_dir;
diff --git a/arch/mips/math-emu/dsemul.c b/arch/mips/math-emu/dsemul.c
index df7b9d9..9b42bfd 100644
--- a/arch/mips/math-emu/dsemul.c
+++ b/arch/mips/math-emu/dsemul.c
@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mips_instruction ir, unsigned long cpc)
@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mi
return SIGILL; /* force out of emulation loop */
}
@ -113,8 +105,6 @@ index df7b9d9..9b42bfd 100644
+ return 0;
+}
+#endif /* CONFIG_MIPS_FPU_EMU */
diff --git a/arch/mips/math-emu/kernel_linkage.c b/arch/mips/math-emu/kernel_linkage.c
index 52e6c58..211a399 100644
--- a/arch/mips/math-emu/kernel_linkage.c
+++ b/arch/mips/math-emu/kernel_linkage.c
@@ -29,6 +29,7 @@
@ -125,7 +115,7 @@ index 52e6c58..211a399 100644
void fpu_emulator_init_fpu(void)
{
static int first = 1;
@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struct sigcontext32 __user *sc)
@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struc
return err;
}

View File

@ -8,7 +8,7 @@
static int debug;
/* initially all NULL */
static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
@@ -857,7 +858,7 @@ int usb_serial_probe(struct usb_interfac
@@ -864,7 +865,7 @@ int usb_serial_probe(struct usb_interfac
dev_err(&interface->dev, "No free urbs available\n");
goto probe_error;
}
@ -17,7 +17,7 @@
port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
@@ -1312,3 +1313,5 @@ MODULE_LICENSE("GPL");
@@ -1309,3 +1310,5 @@ MODULE_LICENSE("GPL");
module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not");

View File

@ -12,7 +12,7 @@ BOARDNAME:=Goldfish (Android Emulator)
FEATURES:=
CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -funit-at-a-time
LINUX_VERSION:=2.6.30
LINUX_VERSION:=2.6.30.1
DEVICE_TYPE=phone

View File

@ -11,7 +11,7 @@ BOARD:=kirkwood
BOARDNAME:=Marvell Kirkwood
FEATURES:=tgz usb
LINUX_VERSION:=2.6.30
LINUX_VERSION:=2.6.30.1
include $(INCLUDE_DIR)/target.mk

View File

@ -16,20 +16,6 @@
err = mmc_sd_switch(card, 1, 0, 1, status);
if (err)
goto out;
--- a/drivers/mmc/host/mvsdio.c
+++ b/drivers/mmc/host/mvsdio.c
@@ -620,9 +620,11 @@ static void mvsd_set_ios(struct mmc_host
if (ios->bus_width == MMC_BUS_WIDTH_4)
ctrl_reg |= MVSD_HOST_CTRL_DATA_WIDTH_4_BITS;
+#if 0
if (ios->timing == MMC_TIMING_MMC_HS ||
ios->timing == MMC_TIMING_SD_HS)
ctrl_reg |= MVSD_HOST_CTRL_HI_SPEED_EN;
+#endif
host->ctrl = ctrl_reg;
mvsd_write(MVSD_HOST_CTRL, ctrl_reg);
--- a/drivers/mmc/core/core.c
+++ b/drivers/mmc/core/core.c
@@ -286,9 +286,9 @@ void mmc_set_data_timeout(struct mmc_dat

View File

@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Octeon
FEATURES:=squashfs jffs2 pci
CFLAGS:=-Os -pipe -funit-at-a-time
LINUX_VERSION:=2.6.30
LINUX_VERSION:=2.6.30.1
include $(INCLUDE_DIR)/target.mk

View File

@ -9,7 +9,7 @@
default:
return "";
}
--- a/drviers/staging/octeon/cvmx-helper-board.c
--- a/drivers/staging/octeon/cvmx-helper-board.c
+++ b/drivers/staging/octeon/cvmx-helper-board.c
@@ -699,6 +699,7 @@ cvmx_helper_board_usb_clock_types_t __cv
{

View File

@ -11,7 +11,7 @@ BOARD:=rb532
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2 pci tgz
LINUX_VERSION:=2.6.30
LINUX_VERSION:=2.6.30.1
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += hostapd-mini kmod-madwifi

View File

@ -12,7 +12,7 @@ BOARDNAME:=Broadcom/SiByte SB-1
FEATURES:=fpu
CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
LINUX_VERSION:=2.6.30
LINUX_VERSION:=2.6.30.1
include $(INCLUDE_DIR)/target.mk

View File

@ -103,7 +103,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
-lib-$(CONFIG_SIBYTE_CFE_CONSOLE) += console.o
--- a/arch/mips/sibyte/cfe/setup.c
+++ /dev/null
@@ -1,350 +0,0 @@
@@ -1,344 +0,0 @@
-/*
- * Copyright (C) 2000, 2001, 2002, 2003 Broadcom Corporation
- *
@ -394,13 +394,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
- */
- cfe_cons_handle = cfe_getstdhandle(CFE_STDHANDLE_CONSOLE);
- if (cfe_getenv("LINUX_CMDLINE", arcs_cmdline, CL_SIZE) < 0) {
- if (argc < 0) {
- /*
- * It's OK for direct boot to not provide a
- * command line
- */
- strcpy(arcs_cmdline, "root=/dev/ram0 ");
- } else {
- if (argc >= 0) {
- /* The loader should have set the command line */
- /* too early for panic to do any good */
- printk("LINUX_CMDLINE not defined in cfe.");