mirror of https://github.com/hak5/openwrt-owl.git
parent
ac897ce5b1
commit
f401789187
|
@ -1,8 +1,8 @@
|
||||||
Index: linux-2.6.25.1/arch/mips/Kconfig
|
Index: linux-2.6.25.4/arch/mips/Kconfig
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.1.orig/arch/mips/Kconfig 2008-05-10 01:14:39.000000000 +0100
|
--- linux-2.6.25.4.orig/arch/mips/Kconfig
|
||||||
+++ linux-2.6.25.1/arch/mips/Kconfig 2008-05-10 01:29:54.000000000 +0100
|
+++ linux-2.6.25.4/arch/mips/Kconfig
|
||||||
@@ -78,6 +78,19 @@
|
@@ -78,6 +78,19 @@ config MIPS_COBALT
|
||||||
select SYS_SUPPORTS_LITTLE_ENDIAN
|
select SYS_SUPPORTS_LITTLE_ENDIAN
|
||||||
select GENERIC_HARDIRQS_NO__DO_IRQ
|
select GENERIC_HARDIRQS_NO__DO_IRQ
|
||||||
|
|
||||||
|
@ -22,7 +22,7 @@ Index: linux-2.6.25.1/arch/mips/Kconfig
|
||||||
config MACH_DECSTATION
|
config MACH_DECSTATION
|
||||||
bool "DECstations"
|
bool "DECstations"
|
||||||
select BOOT_ELF32
|
select BOOT_ELF32
|
||||||
@@ -693,6 +706,7 @@
|
@@ -693,6 +706,7 @@ source "arch/mips/sibyte/Kconfig"
|
||||||
source "arch/mips/tx4927/Kconfig"
|
source "arch/mips/tx4927/Kconfig"
|
||||||
source "arch/mips/tx4938/Kconfig"
|
source "arch/mips/tx4938/Kconfig"
|
||||||
source "arch/mips/vr41xx/Kconfig"
|
source "arch/mips/vr41xx/Kconfig"
|
||||||
|
@ -30,11 +30,11 @@ Index: linux-2.6.25.1/arch/mips/Kconfig
|
||||||
|
|
||||||
endmenu
|
endmenu
|
||||||
|
|
||||||
Index: linux-2.6.25.1/arch/mips/Makefile
|
Index: linux-2.6.25.4/arch/mips/Makefile
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.1.orig/arch/mips/Makefile 2008-05-10 01:14:49.000000000 +0100
|
--- linux-2.6.25.4.orig/arch/mips/Makefile
|
||||||
+++ linux-2.6.25.1/arch/mips/Makefile 2008-05-10 01:14:49.000000000 +0100
|
+++ linux-2.6.25.4/arch/mips/Makefile
|
||||||
@@ -282,6 +282,13 @@
|
@@ -282,6 +282,13 @@ core-$(CONFIG_MIPS_COBALT) += arch/mips/
|
||||||
cflags-$(CONFIG_MIPS_COBALT) += -Iinclude/asm-mips/mach-cobalt
|
cflags-$(CONFIG_MIPS_COBALT) += -Iinclude/asm-mips/mach-cobalt
|
||||||
load-$(CONFIG_MIPS_COBALT) += 0xffffffff80080000
|
load-$(CONFIG_MIPS_COBALT) += 0xffffffff80080000
|
||||||
|
|
||||||
|
@ -48,10 +48,10 @@ Index: linux-2.6.25.1/arch/mips/Makefile
|
||||||
#
|
#
|
||||||
# DECstation family
|
# DECstation family
|
||||||
#
|
#
|
||||||
Index: linux-2.6.25.1/include/asm-mips/bootinfo.h
|
Index: linux-2.6.25.4/include/asm-mips/bootinfo.h
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.1.orig/include/asm-mips/bootinfo.h 2008-05-10 01:14:39.000000000 +0100
|
--- linux-2.6.25.4.orig/include/asm-mips/bootinfo.h
|
||||||
+++ linux-2.6.25.1/include/asm-mips/bootinfo.h 2008-05-10 01:14:49.000000000 +0100
|
+++ linux-2.6.25.4/include/asm-mips/bootinfo.h
|
||||||
@@ -94,6 +94,12 @@
|
@@ -94,6 +94,12 @@
|
||||||
#define MACH_MSP7120_FPGA 5 /* PMC-Sierra MSP7120 Emulation */
|
#define MACH_MSP7120_FPGA 5 /* PMC-Sierra MSP7120 Emulation */
|
||||||
#define MACH_MSP_OTHER 255 /* PMC-Sierra unknown board type */
|
#define MACH_MSP_OTHER 255 /* PMC-Sierra unknown board type */
|
||||||
|
@ -65,11 +65,11 @@ Index: linux-2.6.25.1/include/asm-mips/bootinfo.h
|
||||||
#define CL_SIZE COMMAND_LINE_SIZE
|
#define CL_SIZE COMMAND_LINE_SIZE
|
||||||
|
|
||||||
extern char *system_type;
|
extern char *system_type;
|
||||||
Index: linux-2.6.25.1/arch/mips/kernel/traps.c
|
Index: linux-2.6.25.4/arch/mips/kernel/traps.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.1.orig/arch/mips/kernel/traps.c 2008-05-10 01:14:39.000000000 +0100
|
--- linux-2.6.25.4.orig/arch/mips/kernel/traps.c
|
||||||
+++ linux-2.6.25.1/arch/mips/kernel/traps.c 2008-05-10 01:14:49.000000000 +0100
|
+++ linux-2.6.25.4/arch/mips/kernel/traps.c
|
||||||
@@ -1379,6 +1379,7 @@
|
@@ -1379,6 +1379,7 @@ void __cpuinit per_cpu_trap_init(void)
|
||||||
*/
|
*/
|
||||||
if (cpu_has_mips_r2) {
|
if (cpu_has_mips_r2) {
|
||||||
cp0_compare_irq = (read_c0_intctl() >> 29) & 7;
|
cp0_compare_irq = (read_c0_intctl() >> 29) & 7;
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
Index: linux-2.6.25/drivers/char/Makefile
|
Index: linux-2.6.25.4/drivers/char/Makefile
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.orig/drivers/char/Makefile 2008-05-07 18:58:25.000000000 +0100
|
--- linux-2.6.25.4.orig/drivers/char/Makefile
|
||||||
+++ linux-2.6.25/drivers/char/Makefile 2008-05-07 18:58:42.000000000 +0100
|
+++ linux-2.6.25.4/drivers/char/Makefile
|
||||||
@@ -112,6 +112,12 @@
|
@@ -112,6 +112,12 @@ obj-$(CONFIG_PS3_FLASH) += ps3flash.o
|
||||||
obj-$(CONFIG_JS_RTC) += js-rtc.o
|
obj-$(CONFIG_JS_RTC) += js-rtc.o
|
||||||
js-rtc-y = rtc.o
|
js-rtc-y = rtc.o
|
||||||
|
|
||||||
|
@ -15,20 +15,20 @@ Index: linux-2.6.25/drivers/char/Makefile
|
||||||
# Files generated that shall be removed upon make clean
|
# Files generated that shall be removed upon make clean
|
||||||
clean-files := consolemap_deftbl.c defkeymap.c
|
clean-files := consolemap_deftbl.c defkeymap.c
|
||||||
|
|
||||||
Index: linux-2.6.25/drivers/mtd/maps/Makefile
|
Index: linux-2.6.25.4/drivers/mtd/maps/Makefile
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.orig/drivers/mtd/maps/Makefile 2008-05-07 18:58:25.000000000 +0100
|
--- linux-2.6.25.4.orig/drivers/mtd/maps/Makefile
|
||||||
+++ linux-2.6.25/drivers/mtd/maps/Makefile 2008-05-07 18:58:42.000000000 +0100
|
+++ linux-2.6.25.4/drivers/mtd/maps/Makefile
|
||||||
@@ -68,3 +68,4 @@
|
@@ -68,3 +68,4 @@ obj-$(CONFIG_MTD_PLATRAM) += plat-ram.o
|
||||||
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
|
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
|
||||||
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
|
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
|
||||||
obj-$(CONFIG_MTD_INTEL_VR_NOR) += intel_vr_nor.o
|
obj-$(CONFIG_MTD_INTEL_VR_NOR) += intel_vr_nor.o
|
||||||
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
|
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
|
||||||
Index: linux-2.6.25/drivers/net/Kconfig
|
Index: linux-2.6.25.4/drivers/net/Kconfig
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.orig/drivers/net/Kconfig 2008-05-07 18:58:41.000000000 +0100
|
--- linux-2.6.25.4.orig/drivers/net/Kconfig
|
||||||
+++ linux-2.6.25/drivers/net/Kconfig 2008-05-07 18:58:42.000000000 +0100
|
+++ linux-2.6.25.4/drivers/net/Kconfig
|
||||||
@@ -351,6 +351,12 @@
|
@@ -351,6 +351,12 @@ config MACB
|
||||||
|
|
||||||
source "drivers/net/arm/Kconfig"
|
source "drivers/net/arm/Kconfig"
|
||||||
|
|
||||||
|
@ -41,11 +41,11 @@ Index: linux-2.6.25/drivers/net/Kconfig
|
||||||
config AX88796
|
config AX88796
|
||||||
tristate "ASIX AX88796 NE2000 clone support"
|
tristate "ASIX AX88796 NE2000 clone support"
|
||||||
depends on ARM || MIPS || SUPERH
|
depends on ARM || MIPS || SUPERH
|
||||||
Index: linux-2.6.25/drivers/serial/Kconfig
|
Index: linux-2.6.25.4/drivers/serial/Kconfig
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.orig/drivers/serial/Kconfig 2008-05-07 18:58:25.000000000 +0100
|
--- linux-2.6.25.4.orig/drivers/serial/Kconfig
|
||||||
+++ linux-2.6.25/drivers/serial/Kconfig 2008-05-08 07:53:18.000000000 +0100
|
+++ linux-2.6.25.4/drivers/serial/Kconfig
|
||||||
@@ -1327,6 +1327,14 @@
|
@@ -1327,6 +1327,14 @@ config SERIAL_OF_PLATFORM
|
||||||
Currently, only 8250 compatible ports are supported, but
|
Currently, only 8250 compatible ports are supported, but
|
||||||
others can easily be added.
|
others can easily be added.
|
||||||
|
|
||||||
|
@ -60,21 +60,21 @@ Index: linux-2.6.25/drivers/serial/Kconfig
|
||||||
config SERIAL_QE
|
config SERIAL_QE
|
||||||
tristate "Freescale QUICC Engine serial port support"
|
tristate "Freescale QUICC Engine serial port support"
|
||||||
depends on QUICC_ENGINE
|
depends on QUICC_ENGINE
|
||||||
Index: linux-2.6.25/drivers/serial/Makefile
|
Index: linux-2.6.25.4/drivers/serial/Makefile
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.orig/drivers/serial/Makefile 2008-05-07 18:58:25.000000000 +0100
|
--- linux-2.6.25.4.orig/drivers/serial/Makefile
|
||||||
+++ linux-2.6.25/drivers/serial/Makefile 2008-05-07 18:58:42.000000000 +0100
|
+++ linux-2.6.25.4/drivers/serial/Makefile
|
||||||
@@ -66,4 +66,5 @@
|
@@ -66,4 +66,5 @@ obj-$(CONFIG_SERIAL_UARTLITE) += uartlit
|
||||||
obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
|
obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
|
||||||
obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
|
obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
|
||||||
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
|
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
|
||||||
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
|
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
|
||||||
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
|
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
|
||||||
Index: linux-2.6.25/drivers/watchdog/Makefile
|
Index: linux-2.6.25.4/drivers/watchdog/Makefile
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.orig/drivers/watchdog/Makefile 2008-05-07 18:58:25.000000000 +0100
|
--- linux-2.6.25.4.orig/drivers/watchdog/Makefile
|
||||||
+++ linux-2.6.25/drivers/watchdog/Makefile 2008-05-07 18:58:42.000000000 +0100
|
+++ linux-2.6.25.4/drivers/watchdog/Makefile
|
||||||
@@ -96,6 +96,7 @@
|
@@ -96,6 +96,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
|
||||||
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
||||||
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
||||||
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
Index: linux-2.6.25/drivers/mtd/chips/cfi_cmdset_0002.c
|
Index: linux-2.6.25.4/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- linux-2.6.25.orig/drivers/mtd/chips/cfi_cmdset_0002.c 2008-05-07 18:58:41.000000000 +0100
|
--- linux-2.6.25.4.orig/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
+++ linux-2.6.25/drivers/mtd/chips/cfi_cmdset_0002.c 2008-05-07 18:58:42.000000000 +0100
|
+++ linux-2.6.25.4/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
@@ -1015,7 +1015,9 @@
|
@@ -1015,7 +1015,9 @@ static int __xipram do_write_oneword(str
|
||||||
int retry_cnt = 0;
|
int retry_cnt = 0;
|
||||||
|
|
||||||
adr += chip->start;
|
adr += chip->start;
|
||||||
|
@ -13,4 +13,3 @@ Index: linux-2.6.25/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
spin_lock(chip->mutex);
|
spin_lock(chip->mutex);
|
||||||
ret = get_chip(map, chip, adr, FL_WRITING);
|
ret = get_chip(map, chip, adr, FL_WRITING);
|
||||||
if (ret) {
|
if (ret) {
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue