mirror of https://github.com/hak5/openwrt-owl.git
parent
7cf7b7a1a8
commit
de5c50cfe4
|
@ -9,14 +9,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iproute2
|
||||
PKG_VERSION:=2.6.20-070313
|
||||
PKG_VERSION:=2.6.25
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
|
||||
PKG_MD5SUM:=7bc5883aadf740761fa2dd70b661e8cc
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
|
||||
PKG_MD5SUM:=5737bade2f5e03fad0e2c81da91e551e
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/iproute-$(PKG_VERSION)
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
Index: iproute-2.6.20-070313/doc/ip-cref.tex
|
||||
Index: iproute2-2.6.25/doc/ip-cref.tex
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/doc/ip-cref.tex 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/doc/ip-cref.tex 2007-06-09 13:53:57.000000000 +0100
|
||||
@@ -1322,6 +1322,19 @@
|
||||
--- iproute2-2.6.25.orig/doc/ip-cref.tex 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/doc/ip-cref.tex 2008-05-01 00:26:48.000000000 +0100
|
||||
@@ -1315,6 +1315,19 @@ peers are allowed to send to us.
|
||||
If it is not given, Linux uses the value selected with \verb|sysctl|
|
||||
variable \verb|net/ipv4/tcp_reordering|.
|
||||
|
||||
|
@ -22,7 +22,7 @@ Index: iproute-2.6.20-070313/doc/ip-cref.tex
|
|||
|
||||
|
||||
\item \verb|nexthop NEXTHOP|
|
||||
@@ -2651,6 +2664,9 @@
|
||||
@@ -2644,6 +2657,9 @@ http://www.cisco.com/univercd/cc/td/doc/
|
||||
\bibitem{RFC-DHCP} R.~Droms.
|
||||
``Dynamic Host Configuration Protocol.'', RFC-2131
|
||||
|
||||
|
@ -32,11 +32,11 @@ Index: iproute-2.6.20-070313/doc/ip-cref.tex
|
|||
\end{thebibliography}
|
||||
|
||||
|
||||
Index: iproute-2.6.20-070313/doc/Makefile
|
||||
Index: iproute2-2.6.25/doc/Makefile
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/doc/Makefile 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/doc/Makefile 2007-06-09 13:53:57.000000000 +0100
|
||||
@@ -14,6 +14,7 @@
|
||||
--- iproute2-2.6.25.orig/doc/Makefile 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/doc/Makefile 2008-05-01 00:26:48.000000000 +0100
|
||||
@@ -14,6 +14,7 @@ PAGESIZE=a4
|
||||
PAGESPERPAGE=2
|
||||
|
||||
HTMLFILES=$(subst .sgml,.html,$(shell echo *.sgml))
|
||||
|
@ -44,7 +44,7 @@ Index: iproute-2.6.20-070313/doc/Makefile
|
|||
DVIFILES=$(subst .ps,.dvi,$(PSFILES))
|
||||
|
||||
|
||||
@@ -23,6 +24,8 @@
|
||||
@@ -23,6 +24,8 @@ pstwocol: $(PSFILES)
|
||||
|
||||
html: $(HTMLFILES)
|
||||
|
||||
|
@ -53,7 +53,7 @@ Index: iproute-2.6.20-070313/doc/Makefile
|
|||
dvi: $(DVIFILES)
|
||||
|
||||
print: $(PSFILES)
|
||||
@@ -47,9 +50,12 @@
|
||||
@@ -47,9 +50,12 @@ print: $(PSFILES)
|
||||
%.html: %.sgml
|
||||
$(SGML2HTML) $<
|
||||
|
||||
|
@ -67,10 +67,10 @@ Index: iproute-2.6.20-070313/doc/Makefile
|
|||
clean:
|
||||
- rm -f *.aux *.log *.toc $(PSFILES) $(DVIFILES) *.html
|
||||
+ rm -f *.aux *.log *.toc $(PSFILES) $(DVIFILES) *.html $(TXTFILES)
|
||||
Index: iproute-2.6.20-070313/include/linux/pkt_sched.h
|
||||
Index: iproute2-2.6.25/include/linux/pkt_sched.h
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/include/linux/pkt_sched.h 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/include/linux/pkt_sched.h 2007-06-09 13:53:57.000000000 +0100
|
||||
--- iproute2-2.6.25.orig/include/linux/pkt_sched.h 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/include/linux/pkt_sched.h 2008-05-01 00:37:45.000000000 +0100
|
||||
@@ -1,3 +1,409 @@
|
||||
+#if 0
|
||||
+#ifndef __LINUX_PKT_SCHED_H
|
||||
|
@ -481,7 +481,7 @@ Index: iproute-2.6.20-070313/include/linux/pkt_sched.h
|
|||
#ifndef __LINUX_PKT_SCHED_H
|
||||
#define __LINUX_PKT_SCHED_H
|
||||
|
||||
@@ -466,4 +872,116 @@
|
||||
@@ -482,4 +888,116 @@ struct tc_netem_corrupt
|
||||
|
||||
#define NETEM_DIST_SCALE 8192
|
||||
|
||||
|
@ -598,20 +598,20 @@ Index: iproute-2.6.20-070313/include/linux/pkt_sched.h
|
|||
+};
|
||||
+
|
||||
#endif
|
||||
Index: iproute-2.6.20-070313/ip/iproute.c
|
||||
Index: iproute2-2.6.25/ip/iproute.c
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/ip/iproute.c 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/ip/iproute.c 2007-06-09 13:53:57.000000000 +0100
|
||||
@@ -73,7 +73,7 @@
|
||||
fprintf(stderr, "OPTIONS := FLAGS [ mtu NUMBER ] [ advmss NUMBER ]\n");
|
||||
fprintf(stderr, " [ rtt NUMBER ] [ rttvar NUMBER ]\n");
|
||||
--- iproute2-2.6.25.orig/ip/iproute.c 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/ip/iproute.c 2008-05-01 00:28:02.000000000 +0100
|
||||
@@ -73,7 +73,7 @@ static void usage(void)
|
||||
fprintf(stderr, " [ rtt TIME ] [ rttvar TIME ]\n");
|
||||
fprintf(stderr, " [ window NUMBER] [ cwnd NUMBER ] [ initcwnd NUMBER ]\n");
|
||||
- fprintf(stderr, " [ ssthresh NUMBER ] [ realms REALM ]\n");
|
||||
+ fprintf(stderr, " [ ssthresh NUMBER ] [ realms REALM ] [ hoplimit NUMBER ]\n");
|
||||
fprintf(stderr, " [ ssthresh NUMBER ] [ realms REALM ] [ src ADDRESS ]\n");
|
||||
- fprintf(stderr, " [ rto_min TIME ]\n");
|
||||
+ fprintf(stderr, " [ rto_min TIME ] [ hoplimit NUMBER ]\n");
|
||||
fprintf(stderr, "TYPE := [ unicast | local | broadcast | multicast | throw |\n");
|
||||
fprintf(stderr, " unreachable | prohibit | blackhole | nat ]\n");
|
||||
fprintf(stderr, "TABLE_ID := [ local | main | default | all | NUMBER ]\n");
|
||||
@@ -789,6 +789,30 @@
|
||||
@@ -780,6 +780,30 @@ int iproute_modify(int cmd, unsigned fla
|
||||
invarg("\"reordering\" value is invalid\n", *argv);
|
||||
rta_addattr32(mxrta, sizeof(mxbuf), RTAX_REORDERING, reord);
|
||||
#endif
|
||||
|
@ -642,24 +642,24 @@ Index: iproute-2.6.20-070313/ip/iproute.c
|
|||
} else if (strcmp(*argv, "rtt") == 0) {
|
||||
unsigned rtt;
|
||||
NEXT_ARG();
|
||||
Index: iproute-2.6.20-070313/ip/iptunnel.c
|
||||
Index: iproute2-2.6.25/ip/iptunnel.c
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/ip/iptunnel.c 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/ip/iptunnel.c 2007-06-09 13:53:57.000000000 +0100
|
||||
@@ -113,7 +113,7 @@
|
||||
--- iproute2-2.6.25.orig/ip/iptunnel.c 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/ip/iptunnel.c 2008-05-01 00:26:48.000000000 +0100
|
||||
@@ -134,7 +134,7 @@ static int parse_args(int argc, char **a
|
||||
NEXT_ARG();
|
||||
p->i_flags |= GRE_KEY;
|
||||
p->o_flags |= GRE_KEY;
|
||||
if (strchr(*argv, '.'))
|
||||
- p->o_key = get_addr32(*argv);
|
||||
+ p->i_key = get_addr32(*argv);
|
||||
else {
|
||||
if (get_unsigned(&uval, *argv, 0)<0) {
|
||||
fprintf(stderr, "invalid value of \"ikey\"\n");
|
||||
Index: iproute-2.6.20-070313/Makefile
|
||||
fprintf(stderr, "invalid value of \"okey\"\n");
|
||||
Index: iproute2-2.6.25/Makefile
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/Makefile 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/Makefile 2007-06-09 13:53:57.000000000 +0100
|
||||
@@ -48,7 +48,7 @@
|
||||
--- iproute2-2.6.25.orig/Makefile 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/Makefile 2008-05-01 00:26:48.000000000 +0100
|
||||
@@ -48,7 +48,7 @@ install: all
|
||||
$(DESTDIR)$(DOCDIR)/examples
|
||||
install -m 0644 $(shell find examples/diffserv -maxdepth 1 -type f) \
|
||||
$(DESTDIR)$(DOCDIR)/examples/diffserv
|
||||
|
@ -668,7 +668,7 @@ Index: iproute-2.6.20-070313/Makefile
|
|||
install -m 0644 $(shell find etc/iproute2 -maxdepth 1 -type f) $(DESTDIR)$(CONFDIR)
|
||||
install -m 0755 -d $(DESTDIR)$(MANDIR)/man8
|
||||
install -m 0644 $(shell find man/man8 -maxdepth 1 -type f) $(DESTDIR)$(MANDIR)/man8
|
||||
@@ -59,7 +59,7 @@
|
||||
@@ -65,7 +65,7 @@ snapshot:
|
||||
|
||||
clean:
|
||||
rm -f cscope.*
|
||||
|
@ -677,36 +677,10 @@ Index: iproute-2.6.20-070313/Makefile
|
|||
do $(MAKE) $(MFLAGS) -C $$i clean; done
|
||||
|
||||
clobber: clean
|
||||
Index: iproute-2.6.20-070313/man/man8/ip.8
|
||||
Index: iproute2-2.6.25/misc/Makefile
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/man/man8/ip.8 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/man/man8/ip.8 2007-06-09 13:53:57.000000000 +0100
|
||||
@@ -1808,6 +1808,8 @@
|
||||
.RB "IP Command reference " ip-cref.ps
|
||||
.br
|
||||
.RB "IP tunnels " ip-cref.ps
|
||||
+.br
|
||||
+.RB http://lartc.org/
|
||||
|
||||
.SH AUTHOR
|
||||
Original Manpage by Michail Litvak <mci@owl.openwall.com>
|
||||
Index: iproute-2.6.20-070313/man/man8/tc.8
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/man/man8/tc.8 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/man/man8/tc.8 2007-06-09 13:53:57.000000000 +0100
|
||||
@@ -341,7 +341,7 @@
|
||||
.BR tc-pfifo (8),
|
||||
.BR tc-bfifo (8),
|
||||
.BR tc-pfifo_fast (8),
|
||||
-.BR tc-filters (8)
|
||||
+.BR http://lartc.org/
|
||||
|
||||
.SH AUTHOR
|
||||
Manpage maintained by bert hubert (ahu@ds9a.nl)
|
||||
Index: iproute-2.6.20-070313/misc/Makefile
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/misc/Makefile 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/misc/Makefile 2007-06-09 13:53:57.000000000 +0100
|
||||
--- iproute2-2.6.25.orig/misc/Makefile 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/misc/Makefile 2008-05-01 00:26:48.000000000 +0100
|
||||
@@ -1,7 +1,8 @@
|
||||
SSOBJ=ss.o ssfilter.o
|
||||
LNSTATOBJ=lnstat.o lnstat_util.o
|
||||
|
@ -717,68 +691,22 @@ Index: iproute-2.6.20-070313/misc/Makefile
|
|||
|
||||
include ../Config
|
||||
|
||||
Index: iproute-2.6.20-070313/misc/netbug
|
||||
Index: iproute2-2.6.25/tc/Makefile
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/misc/netbug 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/misc/netbug 2007-06-09 13:53:57.000000000 +0100
|
||||
@@ -1,23 +1,16 @@
|
||||
#! /bin/bash
|
||||
|
||||
+set -e
|
||||
+
|
||||
echo -n "Send network configuration summary to [ENTER means kuznet@ms2.inr.ac.ru] "
|
||||
IFS="" read mail || exit 1
|
||||
[ -z "$mail" ] && mail=kuznet@ms2.inr.ac.ru
|
||||
|
||||
+netbug=`mktemp -d -t netbug.XXXXXX` || {echo "$0: Cannot create temporary directory" >&2; exit 1; }
|
||||
+netbugtar=`tempfile -d $netbug --suffix=tar.gz` || {echo "$0: Cannot create temporary file" >&2; exit 1; }
|
||||
+tmppath=$netbug
|
||||
+trap "/bin/rm -rf $netbug $netbugtar" 0 1 2 3 13 15
|
||||
|
||||
-netbug=""
|
||||
-while [ "$netbug" = "" ]; do
|
||||
- netbug=`echo netbug.$$.$RANDOM`
|
||||
- if [ -e /tmp/$netbug ]; then
|
||||
- netbug=""
|
||||
- fi
|
||||
-done
|
||||
-
|
||||
-tmppath=/tmp/$netbug
|
||||
-
|
||||
-trap "rm -rf $tmppath $tmppath.tar.gz" 0 SIGINT
|
||||
-
|
||||
-mkdir $tmppath
|
||||
mkdir $tmppath/net
|
||||
|
||||
cat /proc/slabinfo > $tmppath/slabinfo
|
||||
@@ -44,9 +37,8 @@
|
||||
fi
|
||||
|
||||
cd /tmp
|
||||
-tar c $netbug | gzip -9c > $netbug.tar.gz
|
||||
-
|
||||
-uuencode $netbug.tar.gz $netbug.tar.gz | mail -s $netbug "$mail"
|
||||
+tar c $tmppath | gzip -9c > $netbugtar
|
||||
+uuencode $netbugtar $netbugtar | mail -s $netbug "$mail"
|
||||
|
||||
echo "Sending to <$mail>; subject is $netbug"
|
||||
|
||||
Index: iproute-2.6.20-070313/tc/Makefile
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/tc/Makefile 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/tc/Makefile 2007-06-09 13:53:57.000000000 +0100
|
||||
@@ -11,6 +11,7 @@
|
||||
TCMODULES += q_prio.o
|
||||
TCMODULES += q_tbf.o
|
||||
--- iproute2-2.6.25.orig/tc/Makefile 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/tc/Makefile 2008-05-01 00:30:13.000000000 +0100
|
||||
@@ -13,6 +13,7 @@ TCMODULES += q_tbf.o
|
||||
TCMODULES += q_cbq.o
|
||||
TCMODULES += q_rr.o
|
||||
TCMODULES += q_netem.o
|
||||
+TCMODULES += q_wrr.o
|
||||
TCMODULES += f_rsvp.o
|
||||
TCMODULES += f_u32.o
|
||||
TCMODULES += f_route.o
|
||||
Index: iproute-2.6.20-070313/tc/q_htb.c
|
||||
Index: iproute2-2.6.25/tc/q_htb.c
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/tc/q_htb.c 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/tc/q_htb.c 2007-06-09 13:53:57.000000000 +0100
|
||||
--- iproute2-2.6.25.orig/tc/q_htb.c 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/tc/q_htb.c 2008-05-01 00:37:50.000000000 +0100
|
||||
@@ -1,3 +1,311 @@
|
||||
+#if 0
|
||||
+/*
|
||||
|
@ -1091,10 +1019,10 @@ Index: iproute-2.6.20-070313/tc/q_htb.c
|
|||
/*
|
||||
* q_htb.c HTB.
|
||||
*
|
||||
Index: iproute-2.6.20-070313/tc/q_wrr.c
|
||||
Index: iproute2-2.6.25/tc/q_wrr.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ iproute-2.6.20-070313/tc/q_wrr.c 2007-06-09 13:53:57.000000000 +0100
|
||||
+++ iproute2-2.6.25/tc/q_wrr.c 2008-05-01 00:37:17.000000000 +0100
|
||||
@@ -0,0 +1,322 @@
|
||||
+#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
Index: iproute-2.6.20-070313/ip/ipxfrm.c
|
||||
Index: iproute2-2.6.25/ip/ipxfrm.c
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/ip/ipxfrm.c 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/ip/ipxfrm.c 2007-06-09 13:53:59.000000000 +0100
|
||||
@@ -467,7 +467,6 @@
|
||||
--- iproute2-2.6.25.orig/ip/ipxfrm.c 2008-04-17 18:12:54.000000000 +0100
|
||||
+++ iproute2-2.6.25/ip/ipxfrm.c 2008-05-01 00:38:40.000000000 +0100
|
||||
@@ -490,7 +490,6 @@ void xfrm_selector_print(struct xfrm_sel
|
||||
switch (sel->proto) {
|
||||
case IPPROTO_TCP:
|
||||
case IPPROTO_UDP:
|
||||
|
@ -10,7 +10,7 @@ Index: iproute-2.6.20-070313/ip/ipxfrm.c
|
|||
case IPPROTO_DCCP:
|
||||
default: /* XXX */
|
||||
if (sel->sport_mask)
|
||||
@@ -1107,7 +1106,6 @@
|
||||
@@ -1121,7 +1120,6 @@ static int xfrm_selector_upspec_parse(st
|
||||
switch (sel->proto) {
|
||||
case IPPROTO_TCP:
|
||||
case IPPROTO_UDP:
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
Index: iproute-2.6.20-070313/tc/q_htb.c
|
||||
Index: iproute2-2.6.25/tc/q_htb.c
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/tc/q_htb.c 2007-06-09 13:53:57.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/tc/q_htb.c 2007-06-09 13:54:00.000000000 +0100
|
||||
@@ -35,10 +35,14 @@
|
||||
--- iproute2-2.6.25.orig/tc/q_htb.c 2008-05-01 00:37:50.000000000 +0100
|
||||
+++ iproute2-2.6.25/tc/q_htb.c 2008-05-01 20:30:28.000000000 +0100
|
||||
@@ -35,10 +35,14 @@ static void explain(void)
|
||||
" default minor id of class to which unclassified packets are sent {0}\n"
|
||||
" r2q DRR quantums are computed as rate in Bps/r2q {10}\n"
|
||||
" debug string of 16 numbers each 0-3 {0}\n\n"
|
||||
|
@ -18,7 +18,7 @@ Index: iproute-2.6.20-070313/tc/q_htb.c
|
|||
" ceil definite upper class rate (no borrows) {rate}\n"
|
||||
" cburst burst but for ceil {computed}\n"
|
||||
" mtu max packet size we create rate map for {1600}\n"
|
||||
@@ -103,7 +107,9 @@
|
||||
@@ -103,7 +107,9 @@ static int htb_parse_class_opt(struct qd
|
||||
struct tc_htb_opt opt;
|
||||
__u32 rtab[256],ctab[256];
|
||||
unsigned buffer=0,cbuffer=0;
|
||||
|
@ -29,7 +29,7 @@ Index: iproute-2.6.20-070313/tc/q_htb.c
|
|||
struct rtattr *tail;
|
||||
|
||||
memset(&opt, 0, sizeof(opt)); mtu = 1600; /* eth packet len */
|
||||
@@ -120,6 +126,16 @@
|
||||
@@ -120,6 +126,16 @@ static int htb_parse_class_opt(struct qd
|
||||
if (get_u32(&mtu, *argv, 10)) {
|
||||
explain1("mtu"); return -1;
|
||||
}
|
||||
|
@ -46,7 +46,7 @@ Index: iproute-2.6.20-070313/tc/q_htb.c
|
|||
} else if (matches(*argv, "quantum") == 0) {
|
||||
NEXT_ARG();
|
||||
if (get_u32(&opt.quantum, *argv, 10)) {
|
||||
@@ -191,14 +207,18 @@
|
||||
@@ -191,14 +207,18 @@ static int htb_parse_class_opt(struct qd
|
||||
if (!buffer) buffer = opt.rate.rate / HZ + mtu;
|
||||
if (!cbuffer) cbuffer = opt.ceil.rate / HZ + mtu;
|
||||
|
||||
|
@ -67,7 +67,7 @@ Index: iproute-2.6.20-070313/tc/q_htb.c
|
|||
fprintf(stderr, "htb: failed to calculate ceil rate table.\n");
|
||||
return -1;
|
||||
}
|
||||
@@ -222,6 +242,7 @@
|
||||
@@ -222,6 +242,7 @@ static int htb_print_opt(struct qdisc_ut
|
||||
double buffer,cbuffer;
|
||||
SPRINT_BUF(b1);
|
||||
SPRINT_BUF(b2);
|
||||
|
@ -75,7 +75,7 @@ Index: iproute-2.6.20-070313/tc/q_htb.c
|
|||
|
||||
if (opt == NULL)
|
||||
return 0;
|
||||
@@ -244,10 +265,16 @@
|
||||
@@ -244,10 +265,16 @@ static int htb_print_opt(struct qdisc_ut
|
||||
fprintf(f, "ceil %s ", sprint_rate(hopt->ceil.rate, b1));
|
||||
cbuffer = ((double)hopt->ceil.rate*tc_core_tick2usec(hopt->cbuffer))/1000000;
|
||||
if (show_details) {
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
diff -urN --exclude=.svn iproute2-2.6.11-050330/include/linux/pkt_sched.h iproute2-2.6.11-050330/include/linux/pkt_sched.h
|
||||
--- iproute2-2.6.11-050330/include/linux/pkt_sched.h 2007-05-04 22:21:48.000000000 -0400
|
||||
+++ iproute2-2.6.11-050330/include/linux/pkt_sched.h 2007-05-04 22:27:12.000000000 -0400
|
||||
@@ -174,8 +174,38 @@
|
||||
Index: iproute2-2.6.25/include/linux/pkt_sched.h
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/include/linux/pkt_sched.h 2008-05-01 00:37:45.000000000 +0100
|
||||
+++ iproute2-2.6.25/include/linux/pkt_sched.h 2008-05-01 20:30:49.000000000 +0100
|
||||
@@ -174,8 +174,38 @@ struct tc_sfq_qopt
|
||||
*
|
||||
* The only reason for this is efficiency, it is possible
|
||||
* to change these parameters in compile time.
|
||||
|
@ -40,7 +41,7 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/include/linux/pkt_sched.h iprout
|
|||
/* RED section */
|
||||
|
||||
enum
|
||||
@@ -551,8 +580,37 @@
|
||||
@@ -568,8 +598,37 @@ struct tc_sfq_xstats
|
||||
*
|
||||
* The only reason for this is efficiency, it is possible
|
||||
* to change these parameters in compile time.
|
||||
|
@ -78,10 +79,11 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/include/linux/pkt_sched.h iprout
|
|||
/* RED section */
|
||||
|
||||
enum
|
||||
diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/Makefile iproute2-2.6.11-050330/tc/Makefile
|
||||
--- iproute2-2.6.11-050330/tc/Makefile 2007-05-04 22:21:48.000000000 -0400
|
||||
+++ iproute2-2.6.11-050330/tc/Makefile 2007-05-04 22:27:37.000000000 -0400
|
||||
@@ -6,6 +6,7 @@
|
||||
Index: iproute2-2.6.25/tc/Makefile
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/tc/Makefile 2008-05-01 00:30:13.000000000 +0100
|
||||
+++ iproute2-2.6.25/tc/Makefile 2008-05-01 20:30:49.000000000 +0100
|
||||
@@ -7,6 +7,7 @@ include ../Config
|
||||
TCMODULES :=
|
||||
TCMODULES += q_fifo.o
|
||||
TCMODULES += q_sfq.o
|
||||
|
@ -89,9 +91,10 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/Makefile iproute2-2.6.11-0503
|
|||
TCMODULES += q_red.o
|
||||
TCMODULES += q_prio.o
|
||||
TCMODULES += q_tbf.o
|
||||
diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/q_esfq.c iproute2-2.6.11-050330/tc/q_esfq.c
|
||||
--- iproute2-2.6.11-050330/tc/q_esfq.c 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ iproute2-2.6.11-050330/tc/q_esfq.c 2007-05-04 22:37:54.000000000 -0400
|
||||
Index: iproute2-2.6.25/tc/q_esfq.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ iproute2-2.6.25/tc/q_esfq.c 2008-05-01 20:31:09.000000000 +0100
|
||||
@@ -0,0 +1,200 @@
|
||||
+/*
|
||||
+ * q_esfq.c ESFQ.
|
||||
|
|
Loading…
Reference in New Issue