target/uml: export atomic64_* functions on 32-bit x86

SVN-Revision: 29287
owl
Nicolas Thill 2011-11-21 14:28:33 +00:00
parent 16c583531a
commit c33f21ae95
1 changed files with 13 additions and 0 deletions

View File

@ -0,0 +1,13 @@
[patch] um: export atomic64_* functions on i386
--- a/arch/um/sys-i386/Makefile
+++ b/arch/um/sys-i386/Makefile
@@ -8,7 +8,7 @@ obj-y = bug.o bugs.o checksum.o delay.o
obj-$(CONFIG_BINFMT_ELF) += elfcore.o
-subarch-obj-y = lib/semaphore_32.o lib/string_32.o
+subarch-obj-y = lib/atomic64_32.o lib/semaphore_32.o lib/string_32.o
subarch-obj-$(CONFIG_HIGHMEM) += mm/highmem_32.o
subarch-obj-$(CONFIG_MODULES) += kernel/module.o