mirror of https://github.com/hak5/openwrt-owl.git
new upstream release 2.51 with some fixes, see http://www.thekelleys.org.uk/dnsmasq/CHANGELOG refreshed patches for new release
SVN-Revision: 18541owl
parent
4bfa2947ee
commit
c05ba34ba7
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dnsmasq
|
PKG_NAME:=dnsmasq
|
||||||
PKG_VERSION:=2.50
|
PKG_VERSION:=2.51
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
||||||
PKG_MD5SUM:=f7b1e17c590e493039537434c57c9de7
|
PKG_MD5SUM:=97465261a6de5258a3c3edfe51ca16a4
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,8 @@
|
||||||
--- a/src/config.h
|
Index: dnsmasq-2.51/src/config.h
|
||||||
+++ b/src/config.h
|
===================================================================
|
||||||
@@ -257,8 +257,9 @@ NOTES:
|
--- dnsmasq-2.51.orig/src/config.h
|
||||||
|
+++ dnsmasq-2.51/src/config.h
|
||||||
|
@@ -270,8 +270,9 @@ NOTES:
|
||||||
/* We assume that systems which don't have IPv6
|
/* We assume that systems which don't have IPv6
|
||||||
headers don't have ntop and pton either */
|
headers don't have ntop and pton either */
|
||||||
|
|
||||||
|
|
|
@ -1,5 +1,7 @@
|
||||||
--- a/src/netlink.c
|
Index: dnsmasq-2.51/src/netlink.c
|
||||||
+++ b/src/netlink.c
|
===================================================================
|
||||||
|
--- dnsmasq-2.51.orig/src/netlink.c
|
||||||
|
+++ dnsmasq-2.51/src/netlink.c
|
||||||
@@ -129,6 +129,7 @@ int iface_enumerate(void *parm, int (*ip
|
@@ -129,6 +129,7 @@ int iface_enumerate(void *parm, int (*ip
|
||||||
ssize_t len;
|
ssize_t len;
|
||||||
static unsigned int seq = 0;
|
static unsigned int seq = 0;
|
||||||
|
@ -31,9 +33,11 @@
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
}
|
}
|
||||||
--- a/src/network.c
|
Index: dnsmasq-2.51/src/network.c
|
||||||
+++ b/src/network.c
|
===================================================================
|
||||||
@@ -296,7 +296,7 @@ static int create_ipv6_listener(struct l
|
--- dnsmasq-2.51.orig/src/network.c
|
||||||
|
+++ dnsmasq-2.51/src/network.c
|
||||||
|
@@ -302,7 +302,7 @@ static int create_ipv6_listener(struct l
|
||||||
bind(tcpfd, (struct sockaddr *)&addr, sa_len(&addr)) == -1 ||
|
bind(tcpfd, (struct sockaddr *)&addr, sa_len(&addr)) == -1 ||
|
||||||
listen(tcpfd, 5) == -1 ||
|
listen(tcpfd, 5) == -1 ||
|
||||||
bind(fd, (struct sockaddr *)&addr, sa_len(&addr)) == -1)
|
bind(fd, (struct sockaddr *)&addr, sa_len(&addr)) == -1)
|
||||||
|
|
Loading…
Reference in New Issue