mirror of https://github.com/hak5/openwrt-owl.git
openssl: security update to 1.0.1d to address CBC TLS issue
addressing CVE-2013-0169: 4th February 2013 Signed-off-by: Tim Yardley <yardley@gmail.com> SVN-Revision: 35524owl
parent
6ff973bdda
commit
b521113aa1
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=openssl
|
PKG_NAME:=openssl
|
||||||
PKG_VERSION:=1.0.1c
|
PKG_VERSION:=1.0.1d
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
|
||||||
ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
|
ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
|
||||||
ftp://ftp.webmonster.de/pub/openssl/source/ \
|
ftp://ftp.webmonster.de/pub/openssl/source/ \
|
||||||
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
|
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
|
||||||
PKG_MD5SUM:=ae412727c8c15b67880aef7bd2999b2e
|
PKG_MD5SUM:=b92fc634f0f1f31a67ed4175adc5ba33
|
||||||
|
|
||||||
PKG_LICENSE:=SSLEAY OPENSSL
|
PKG_LICENSE:=SSLEAY OPENSSL
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Configure
|
--- a/Configure
|
||||||
+++ b/Configure
|
+++ b/Configure
|
||||||
@@ -401,6 +401,10 @@ my %table=(
|
@@ -402,6 +402,10 @@ my %table=(
|
||||||
"linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
|
"linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
|
||||||
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
|
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Configure
|
--- a/Configure
|
||||||
+++ b/Configure
|
+++ b/Configure
|
||||||
@@ -2000,6 +2000,11 @@ EOF
|
@@ -2003,6 +2003,11 @@ EOF
|
||||||
close(OUT);
|
close(OUT);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Configure
|
--- a/Configure
|
||||||
+++ b/Configure
|
+++ b/Configure
|
||||||
@@ -440,6 +440,10 @@ my %table=(
|
@@ -443,6 +443,10 @@ my %table=(
|
||||||
"beos-x86-r5", "gcc:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -mcpu=pentium -Wall::-D_REENTRANT:BEOS:-lbe -lnet:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:beos:beos-shared:-fPIC -DPIC:-shared:.so",
|
"beos-x86-r5", "gcc:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -mcpu=pentium -Wall::-D_REENTRANT:BEOS:-lbe -lnet:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:beos:beos-shared:-fPIC -DPIC:-shared:.so",
|
||||||
"beos-x86-bone", "gcc:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -mcpu=pentium -Wall::-D_REENTRANT:BEOS:-lbe -lbind -lsocket:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:beos:beos-shared:-fPIC:-shared:.so",
|
"beos-x86-bone", "gcc:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -mcpu=pentium -Wall::-D_REENTRANT:BEOS:-lbe -lbind -lsocket:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:beos:beos-shared:-fPIC:-shared:.so",
|
||||||
|
|
||||||
|
|
|
@ -1,64 +0,0 @@
|
||||||
--- a/crypto/aes/asm/aes-mips.pl
|
|
||||||
+++ b/crypto/aes/asm/aes-mips.pl
|
|
||||||
@@ -1036,9 +1036,9 @@ _mips_AES_set_encrypt_key:
|
|
||||||
nop
|
|
||||||
.end _mips_AES_set_encrypt_key
|
|
||||||
|
|
||||||
-.globl AES_set_encrypt_key
|
|
||||||
-.ent AES_set_encrypt_key
|
|
||||||
-AES_set_encrypt_key:
|
|
||||||
+.globl private_AES_set_encrypt_key
|
|
||||||
+.ent private_AES_set_encrypt_key
|
|
||||||
+private_AES_set_encrypt_key:
|
|
||||||
.frame $sp,$FRAMESIZE,$ra
|
|
||||||
.mask $SAVED_REGS_MASK,-$SZREG
|
|
||||||
.set noreorder
|
|
||||||
@@ -1060,7 +1060,7 @@ $code.=<<___ if ($flavour =~ /nubi/i); #
|
|
||||||
___
|
|
||||||
$code.=<<___ if ($flavour !~ /o32/i); # non-o32 PIC-ification
|
|
||||||
.cplocal $Tbl
|
|
||||||
- .cpsetup $pf,$zero,AES_set_encrypt_key
|
|
||||||
+ .cpsetup $pf,$zero,private_AES_set_encrypt_key
|
|
||||||
___
|
|
||||||
$code.=<<___;
|
|
||||||
.set reorder
|
|
||||||
@@ -1083,7 +1083,7 @@ ___
|
|
||||||
$code.=<<___;
|
|
||||||
jr $ra
|
|
||||||
$PTR_ADD $sp,$FRAMESIZE
|
|
||||||
-.end AES_set_encrypt_key
|
|
||||||
+.end private_AES_set_encrypt_key
|
|
||||||
___
|
|
||||||
|
|
||||||
my ($head,$tail)=($inp,$bits);
|
|
||||||
@@ -1091,9 +1091,9 @@ my ($tp1,$tp2,$tp4,$tp8,$tp9,$tpb,$tpd,$
|
|
||||||
my ($m,$x80808080,$x7f7f7f7f,$x1b1b1b1b)=($at,$t0,$t1,$t2);
|
|
||||||
$code.=<<___;
|
|
||||||
.align 5
|
|
||||||
-.globl AES_set_decrypt_key
|
|
||||||
-.ent AES_set_decrypt_key
|
|
||||||
-AES_set_decrypt_key:
|
|
||||||
+.globl private_AES_set_decrypt_key
|
|
||||||
+.ent private_AES_set_decrypt_key
|
|
||||||
+private_AES_set_decrypt_key:
|
|
||||||
.frame $sp,$FRAMESIZE,$ra
|
|
||||||
.mask $SAVED_REGS_MASK,-$SZREG
|
|
||||||
.set noreorder
|
|
||||||
@@ -1115,7 +1115,7 @@ $code.=<<___ if ($flavour =~ /nubi/i); #
|
|
||||||
___
|
|
||||||
$code.=<<___ if ($flavour !~ /o32/i); # non-o32 PIC-ification
|
|
||||||
.cplocal $Tbl
|
|
||||||
- .cpsetup $pf,$zero,AES_set_decrypt_key
|
|
||||||
+ .cpsetup $pf,$zero,private_AES_set_decrypt_key
|
|
||||||
___
|
|
||||||
$code.=<<___;
|
|
||||||
.set reorder
|
|
||||||
@@ -1226,7 +1226,7 @@ ___
|
|
||||||
$code.=<<___;
|
|
||||||
jr $ra
|
|
||||||
$PTR_ADD $sp,$FRAMESIZE
|
|
||||||
-.end AES_set_decrypt_key
|
|
||||||
+.end private_AES_set_decrypt_key
|
|
||||||
___
|
|
||||||
}}}
|
|
||||||
|
|
Loading…
Reference in New Issue