mirror of https://github.com/hak5/openwrt-owl.git
parent
c3bba7f8c6
commit
b4508ce183
|
@ -1,44 +1,12 @@
|
||||||
--- a/arch/mips/kernel/signal.c
|
--- linux-2.6.37.6.org/Makefile 2012-03-28 17:10:58.297558774 +0200
|
||||||
+++ b/arch/mips/kernel/signal.c
|
+++ linux-2.6.37.6.mod/Makefile 2012-03-28 17:15:00.161564521 +0200
|
||||||
@@ -84,7 +84,7 @@ static int protected_save_fp_context(str
|
@@ -354,7 +354,8 @@
|
||||||
|
-fno-strict-aliasing -fno-common \
|
||||||
static int protected_restore_fp_context(struct sigcontext __user *sc)
|
-Werror-implicit-function-declaration \
|
||||||
{
|
-Wno-format-security \
|
||||||
- int err, tmp;
|
- -fno-delete-null-pointer-checks
|
||||||
+ int err, tmp __maybe_unused;
|
+ -fno-delete-null-pointer-checks \
|
||||||
while (1) {
|
+ -Wno-error=unused-but-set-variable
|
||||||
lock_fpu_owner();
|
KBUILD_AFLAGS_KERNEL :=
|
||||||
own_fpu_inatomic(0);
|
KBUILD_CFLAGS_KERNEL :=
|
||||||
--- a/arch/mips/kernel/syscall.c
|
KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||||
+++ b/arch/mips/kernel/syscall.c
|
|
||||||
@@ -383,7 +383,7 @@ save_static_function(sys_sysmips);
|
|
||||||
static int __used noinline
|
|
||||||
_sys_sysmips(nabi_no_regargs struct pt_regs regs)
|
|
||||||
{
|
|
||||||
- long cmd, arg1, arg2, arg3;
|
|
||||||
+ long cmd, arg1, arg2, arg3 __maybe_unused;
|
|
||||||
|
|
||||||
cmd = regs.regs[4];
|
|
||||||
arg1 = regs.regs[5];
|
|
||||||
--- a/arch/mips/mm/init.c
|
|
||||||
+++ b/arch/mips/mm/init.c
|
|
||||||
@@ -324,7 +324,7 @@ int page_is_ram(unsigned long pagenr)
|
|
||||||
void __init paging_init(void)
|
|
||||||
{
|
|
||||||
unsigned long max_zone_pfns[MAX_NR_ZONES];
|
|
||||||
- unsigned long lastpfn;
|
|
||||||
+ unsigned long lastpfn __maybe_unused;
|
|
||||||
|
|
||||||
pagetable_init();
|
|
||||||
|
|
||||||
--- a/arch/mips/mm/c-r4k.c
|
|
||||||
+++ b/arch/mips/mm/c-r4k.c
|
|
||||||
@@ -1075,7 +1075,7 @@ static int __cpuinit probe_scache(void)
|
|
||||||
unsigned long flags, addr, begin, end, pow2;
|
|
||||||
unsigned int config = read_c0_config();
|
|
||||||
struct cpuinfo_mips *c = ¤t_cpu_data;
|
|
||||||
- int tmp;
|
|
||||||
+ int tmp __maybe_unused;
|
|
||||||
|
|
||||||
if (config & CONF_SC)
|
|
||||||
return 0;
|
|
||||||
|
|
Loading…
Reference in New Issue