mirror of https://github.com/hak5/openwrt-owl.git
toolchain/binutils: remove obsolete patches
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 41034owl
parent
b757deecad
commit
b1c3bf7cf0
|
@ -1,35 +0,0 @@
|
||||||
Source: Khem Raj <raj.khem@gmail.com>
|
|
||||||
Disposition: submit upstream.
|
|
||||||
|
|
||||||
Description:
|
|
||||||
|
|
||||||
We do not need to have the libtool patch anymore for binutils after
|
|
||||||
libtool has been updated upstream it include support for it. However
|
|
||||||
for building gas natively on uclibc systems we have to link it with
|
|
||||||
-lm so that it picks up missing symbols.
|
|
||||||
|
|
||||||
/local/build_area/BUILD/arm_v5t_le_uclibc/binutils-2.17.50/objdir/libiberty/pic/libiberty.a(floatformat.o): In function `floatformat_from_double':
|
|
||||||
floatformat.c:(.text+0x1ec): undefined reference to `frexp'
|
|
||||||
floatformat.c:(.text+0x2f8): undefined reference to `ldexp'
|
|
||||||
/local/build_area/BUILD/arm_v5t_le_uclibc/binutils-2.17.50/objdir/libiberty/pic/libiberty.a(floatformat.o): In function `floatformat_to_double':
|
|
||||||
floatformat.c:(.text+0x38a): undefined reference to `ldexp'
|
|
||||||
floatformat.c:(.text+0x3d2): undefined reference to `ldexp'
|
|
||||||
floatformat.c:(.text+0x43e): undefined reference to `ldexp' floatformat.c:(.text+0x4e2): undefined reference to `ldexp'
|
|
||||||
collect2: ld returned 1 exit status
|
|
||||||
make[4]: *** [as-new] Error 1
|
|
||||||
|
|
||||||
--- a/gas/configure.tgt
|
|
||||||
+++ b/gas/configure.tgt
|
|
||||||
@@ -431,6 +431,12 @@ case ${generic_target} in
|
|
||||||
*-*-netware) fmt=elf em=netware ;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
+case ${generic_target} in
|
|
||||||
+ arm-*-*uclibc*)
|
|
||||||
+ need_libm=yes
|
|
||||||
+ ;;
|
|
||||||
+esac
|
|
||||||
+
|
|
||||||
case ${cpu_type} in
|
|
||||||
alpha | arm | i386 | ia64 | microblaze | mips | ns32k | pdp11 | ppc | sparc | z80 | z8k)
|
|
||||||
bfd_gas=yes
|
|
|
@ -1,40 +0,0 @@
|
||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -3054,7 +3054,7 @@ case "${target}" in
|
|
||||||
am33_2.0-*-linux*)
|
|
||||||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
||||||
;;
|
|
||||||
- sh-*-linux*)
|
|
||||||
+ sh*-*-linux*)
|
|
||||||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
||||||
;;
|
|
||||||
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
|
||||||
@@ -3390,7 +3390,7 @@ case "${target}" in
|
|
||||||
romp-*-*)
|
|
||||||
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
|
||||||
;;
|
|
||||||
- sh-*-* | sh64-*-*)
|
|
||||||
+ sh*-*-* | sh64-*-*)
|
|
||||||
case "${host}" in
|
|
||||||
i[3456789]86-*-vsta) ;; # don't add gprof back in
|
|
||||||
i[3456789]86-*-go32*) ;; # don't add gprof back in
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -541,7 +541,7 @@ case "${target}" in
|
|
||||||
am33_2.0-*-linux*)
|
|
||||||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
||||||
;;
|
|
||||||
- sh-*-linux*)
|
|
||||||
+ sh*-*-linux*)
|
|
||||||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
||||||
;;
|
|
||||||
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
|
||||||
@@ -877,7 +877,7 @@ case "${target}" in
|
|
||||||
romp-*-*)
|
|
||||||
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
|
||||||
;;
|
|
||||||
- sh-*-* | sh64-*-*)
|
|
||||||
+ sh*-*-* | sh64-*-*)
|
|
||||||
case "${host}" in
|
|
||||||
i[[3456789]]86-*-vsta) ;; # don't add gprof back in
|
|
||||||
i[[3456789]]86-*-go32*) ;; # don't add gprof back in
|
|
|
@ -1,35 +0,0 @@
|
||||||
Source: Khem Raj <raj.khem@gmail.com>
|
|
||||||
Disposition: submit upstream.
|
|
||||||
|
|
||||||
Description:
|
|
||||||
|
|
||||||
We do not need to have the libtool patch anymore for binutils after
|
|
||||||
libtool has been updated upstream it include support for it. However
|
|
||||||
for building gas natively on uclibc systems we have to link it with
|
|
||||||
-lm so that it picks up missing symbols.
|
|
||||||
|
|
||||||
/local/build_area/BUILD/arm_v5t_le_uclibc/binutils-2.17.50/objdir/libiberty/pic/libiberty.a(floatformat.o): In function `floatformat_from_double':
|
|
||||||
floatformat.c:(.text+0x1ec): undefined reference to `frexp'
|
|
||||||
floatformat.c:(.text+0x2f8): undefined reference to `ldexp'
|
|
||||||
/local/build_area/BUILD/arm_v5t_le_uclibc/binutils-2.17.50/objdir/libiberty/pic/libiberty.a(floatformat.o): In function `floatformat_to_double':
|
|
||||||
floatformat.c:(.text+0x38a): undefined reference to `ldexp'
|
|
||||||
floatformat.c:(.text+0x3d2): undefined reference to `ldexp'
|
|
||||||
floatformat.c:(.text+0x43e): undefined reference to `ldexp' floatformat.c:(.text+0x4e2): undefined reference to `ldexp'
|
|
||||||
collect2: ld returned 1 exit status
|
|
||||||
make[4]: *** [as-new] Error 1
|
|
||||||
|
|
||||||
--- a/gas/configure.tgt
|
|
||||||
+++ b/gas/configure.tgt
|
|
||||||
@@ -428,6 +428,12 @@ case ${generic_target} in
|
|
||||||
*-*-netware) fmt=elf em=netware ;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
+case ${generic_target} in
|
|
||||||
+ arm-*-*uclibc*)
|
|
||||||
+ need_libm=yes
|
|
||||||
+ ;;
|
|
||||||
+esac
|
|
||||||
+
|
|
||||||
case ${cpu_type} in
|
|
||||||
alpha | arm | i386 | ia64 | microblaze | mips | ns32k | pdp11 | ppc | sparc | z80 | z8k)
|
|
||||||
bfd_gas=yes
|
|
|
@ -1,22 +0,0 @@
|
||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -3570,7 +3570,7 @@ case "${target}" in
|
|
||||||
mips*-*-*)
|
|
||||||
noconfigdirs="$noconfigdirs gprof"
|
|
||||||
;;
|
|
||||||
- sh-*-* | sh64-*-*)
|
|
||||||
+ sh*-*-* | sh64-*-*)
|
|
||||||
case "${target}" in
|
|
||||||
sh*-*-elf)
|
|
||||||
;;
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -1006,7 +1006,7 @@ case "${target}" in
|
|
||||||
mips*-*-*)
|
|
||||||
noconfigdirs="$noconfigdirs gprof"
|
|
||||||
;;
|
|
||||||
- sh-*-* | sh64-*-*)
|
|
||||||
+ sh*-*-* | sh64-*-*)
|
|
||||||
case "${target}" in
|
|
||||||
sh*-*-elf)
|
|
||||||
;;
|
|
|
@ -1,35 +0,0 @@
|
||||||
Source: Khem Raj <raj.khem@gmail.com>
|
|
||||||
Disposition: submit upstream.
|
|
||||||
|
|
||||||
Description:
|
|
||||||
|
|
||||||
We do not need to have the libtool patch anymore for binutils after
|
|
||||||
libtool has been updated upstream it include support for it. However
|
|
||||||
for building gas natively on uclibc systems we have to link it with
|
|
||||||
-lm so that it picks up missing symbols.
|
|
||||||
|
|
||||||
/local/build_area/BUILD/arm_v5t_le_uclibc/binutils-2.17.50/objdir/libiberty/pic/libiberty.a(floatformat.o): In function `floatformat_from_double':
|
|
||||||
floatformat.c:(.text+0x1ec): undefined reference to `frexp'
|
|
||||||
floatformat.c:(.text+0x2f8): undefined reference to `ldexp'
|
|
||||||
/local/build_area/BUILD/arm_v5t_le_uclibc/binutils-2.17.50/objdir/libiberty/pic/libiberty.a(floatformat.o): In function `floatformat_to_double':
|
|
||||||
floatformat.c:(.text+0x38a): undefined reference to `ldexp'
|
|
||||||
floatformat.c:(.text+0x3d2): undefined reference to `ldexp'
|
|
||||||
floatformat.c:(.text+0x43e): undefined reference to `ldexp' floatformat.c:(.text+0x4e2): undefined reference to `ldexp'
|
|
||||||
collect2: ld returned 1 exit status
|
|
||||||
make[4]: *** [as-new] Error 1
|
|
||||||
|
|
||||||
--- a/gas/configure.tgt
|
|
||||||
+++ b/gas/configure.tgt
|
|
||||||
@@ -450,6 +450,12 @@ case ${generic_target} in
|
|
||||||
*-*-netware) fmt=elf em=netware ;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
+case ${generic_target} in
|
|
||||||
+ arm-*-*uclibc*)
|
|
||||||
+ need_libm=yes
|
|
||||||
+ ;;
|
|
||||||
+esac
|
|
||||||
+
|
|
||||||
case ${cpu_type} in
|
|
||||||
aarch64 | alpha | arm | i386 | ia64 | microblaze | mips | ns32k | pdp11 | ppc | sparc | z80 | z8k)
|
|
||||||
bfd_gas=yes
|
|
|
@ -1,22 +0,0 @@
|
||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -3595,7 +3595,7 @@ case "${target}" in
|
|
||||||
mips*-*-*)
|
|
||||||
noconfigdirs="$noconfigdirs gprof"
|
|
||||||
;;
|
|
||||||
- sh-*-* | sh64-*-*)
|
|
||||||
+ sh*-*-* | sh64-*-*)
|
|
||||||
case "${target}" in
|
|
||||||
sh*-*-elf)
|
|
||||||
;;
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -1021,7 +1021,7 @@ case "${target}" in
|
|
||||||
mips*-*-*)
|
|
||||||
noconfigdirs="$noconfigdirs gprof"
|
|
||||||
;;
|
|
||||||
- sh-*-* | sh64-*-*)
|
|
||||||
+ sh*-*-* | sh64-*-*)
|
|
||||||
case "${target}" in
|
|
||||||
sh*-*-elf)
|
|
||||||
;;
|
|
|
@ -1,35 +0,0 @@
|
||||||
Source: Khem Raj <raj.khem@gmail.com>
|
|
||||||
Disposition: submit upstream.
|
|
||||||
|
|
||||||
Description:
|
|
||||||
|
|
||||||
We do not need to have the libtool patch anymore for binutils after
|
|
||||||
libtool has been updated upstream it include support for it. However
|
|
||||||
for building gas natively on uclibc systems we have to link it with
|
|
||||||
-lm so that it picks up missing symbols.
|
|
||||||
|
|
||||||
/local/build_area/BUILD/arm_v5t_le_uclibc/binutils-2.17.50/objdir/libiberty/pic/libiberty.a(floatformat.o): In function `floatformat_from_double':
|
|
||||||
floatformat.c:(.text+0x1ec): undefined reference to `frexp'
|
|
||||||
floatformat.c:(.text+0x2f8): undefined reference to `ldexp'
|
|
||||||
/local/build_area/BUILD/arm_v5t_le_uclibc/binutils-2.17.50/objdir/libiberty/pic/libiberty.a(floatformat.o): In function `floatformat_to_double':
|
|
||||||
floatformat.c:(.text+0x38a): undefined reference to `ldexp'
|
|
||||||
floatformat.c:(.text+0x3d2): undefined reference to `ldexp'
|
|
||||||
floatformat.c:(.text+0x43e): undefined reference to `ldexp' floatformat.c:(.text+0x4e2): undefined reference to `ldexp'
|
|
||||||
collect2: ld returned 1 exit status
|
|
||||||
make[4]: *** [as-new] Error 1
|
|
||||||
|
|
||||||
--- a/gas/configure.tgt
|
|
||||||
+++ b/gas/configure.tgt
|
|
||||||
@@ -468,6 +468,12 @@ case ${generic_target} in
|
|
||||||
*-*-netware) fmt=elf em=netware ;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
+case ${generic_target} in
|
|
||||||
+ arm-*-*uclibc*)
|
|
||||||
+ need_libm=yes
|
|
||||||
+ ;;
|
|
||||||
+esac
|
|
||||||
+
|
|
||||||
case ${cpu_type} in
|
|
||||||
aarch64 | alpha | arm | i386 | ia64 | microblaze | mips | ns32k | pdp11 | ppc | sparc | z80 | z8k)
|
|
||||||
bfd_gas=yes
|
|
|
@ -1,22 +0,0 @@
|
||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -3793,7 +3793,7 @@ case "${target}" in
|
|
||||||
mips*-*-*)
|
|
||||||
noconfigdirs="$noconfigdirs gprof"
|
|
||||||
;;
|
|
||||||
- sh-*-* | sh64-*-*)
|
|
||||||
+ sh*-*-* | sh64-*-*)
|
|
||||||
case "${target}" in
|
|
||||||
sh*-*-elf)
|
|
||||||
;;
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -1129,7 +1129,7 @@ case "${target}" in
|
|
||||||
mips*-*-*)
|
|
||||||
noconfigdirs="$noconfigdirs gprof"
|
|
||||||
;;
|
|
||||||
- sh-*-* | sh64-*-*)
|
|
||||||
+ sh*-*-* | sh64-*-*)
|
|
||||||
case "${target}" in
|
|
||||||
sh*-*-elf)
|
|
||||||
;;
|
|
Loading…
Reference in New Issue