mirror of https://github.com/hak5/openwrt-owl.git
ebtables: revert "disable rpath" (closes: #19088)
This reverts commit 9340723d70bce9d905c3f53b2bf415963153b34d. Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 44634owl
parent
28631b65c2
commit
a7f198b12c
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ebtables
|
PKG_NAME:=ebtables
|
||||||
PKG_VERSION:=2.0.10-4
|
PKG_VERSION:=2.0.10-4
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/ebtables
|
PKG_SOURCE_URL:=@SF/ebtables
|
||||||
|
|
|
@ -1,30 +0,0 @@
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -90,8 +90,7 @@ libebtc.so: $(OBJECTS2)
|
|
||||||
$(CC) -shared $(LDFLAGS) -Wl,-soname,libebtc.so -o libebtc.so -lc $(OBJECTS2)
|
|
||||||
|
|
||||||
ebtables: $(OBJECTS) ebtables-standalone.o libebtc.so
|
|
||||||
- $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) $(LDFLAGS) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
|
|
||||||
- -Wl,-rpath,$(LIBDIR)
|
|
||||||
+ $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) $(LDFLAGS) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
|
|
||||||
|
|
||||||
ebtablesu: ebtablesu.c
|
|
||||||
$(CC) $(CFLAGS) $(PROGSPECSD) $< -o $@
|
|
||||||
@@ -100,15 +99,13 @@ ebtablesd.o: ebtablesd.c include/ebtable
|
|
||||||
$(CC) $(CFLAGS) $(PROGSPECSD) -c $< -o $@ -I$(KERNEL_INCLUDES)
|
|
||||||
|
|
||||||
ebtablesd: $(OBJECTS) ebtablesd.o libebtc.so
|
|
||||||
- $(CC) $(CFLAGS) -o $@ ebtablesd.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
|
|
||||||
- -Wl,-rpath,$(LIBDIR)
|
|
||||||
+ $(CC) $(CFLAGS) -o $@ ebtablesd.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
|
|
||||||
|
|
||||||
ebtables-restore.o: ebtables-restore.c include/ebtables_u.h
|
|
||||||
$(CC) $(CFLAGS) $(PROGSPECS) -c $< -o $@ -I$(KERNEL_INCLUDES)
|
|
||||||
|
|
||||||
ebtables-restore: $(OBJECTS) ebtables-restore.o libebtc.so
|
|
||||||
- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ ebtables-restore.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
|
|
||||||
- -Wl,-rpath,$(LIBDIR)
|
|
||||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ ebtables-restore.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
|
|
||||||
|
|
||||||
.PHONY: daemon
|
|
||||||
daemon: ebtablesd ebtablesu
|
|
Loading…
Reference in New Issue