mirror of https://github.com/hak5/openwrt-owl.git
polarssl: security update (1.2.5) addressing CBC TLS issue
Signed-off-by: Tim Yardley <yardley@gmail.com> SVN-Revision: 35525owl
parent
b521113aa1
commit
8f54ec7ce7
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=polarssl
|
||||
PKG_VERSION:=1.2.4
|
||||
PKG_VERSION:=1.2.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
|
||||
PKG_SOURCE_URL:=http://polarssl.org/code/releases
|
||||
PKG_MD5SUM:=f23fc73b0c5ef1c51294c20f3ea0dcb0
|
||||
PKG_SOURCE_URL:=https://polarssl.org/code/releases
|
||||
PKG_MD5SUM:=f42dd79cd85384ac9ad482caa665ac8f
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/include/polarssl/config.h
|
||||
+++ b/include/polarssl/config.h
|
||||
@@ -166,8 +166,8 @@
|
||||
@@ -177,8 +177,8 @@
|
||||
* Requires: POLARSSL_BIGNUM_C, POLARSSL_RSA_C
|
||||
*
|
||||
* Enable the RSA prime-number generation code.
|
||||
|
@ -10,7 +10,7 @@
|
|||
|
||||
/**
|
||||
* \def POLARSSL_FS_IO
|
||||
@@ -224,8 +224,8 @@
|
||||
@@ -235,8 +235,8 @@
|
||||
* \def POLARSSL_SELF_TEST
|
||||
*
|
||||
* Enable the checkup functions (*_self_test).
|
||||
|
@ -19,8 +19,8 @@
|
|||
+ */
|
||||
|
||||
/**
|
||||
* \def POLARSSL_SSL_HW_RECORD_ACCEL
|
||||
@@ -384,8 +384,8 @@
|
||||
* \def POLARSSL_SSL_ALL_ALERT_MESSAGES
|
||||
@@ -425,8 +425,8 @@
|
||||
* TLS_RSA_WITH_CAMELLIA_256_CBC_SHA256
|
||||
* TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA256
|
||||
* TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA256
|
||||
|
@ -30,7 +30,7 @@
|
|||
|
||||
/**
|
||||
* \def POLARSSL_CERTS_C
|
||||
@@ -396,8 +396,8 @@
|
||||
@@ -437,8 +437,8 @@
|
||||
* Caller:
|
||||
*
|
||||
* This module is used for testing (ssl_client/server).
|
||||
|
@ -40,7 +40,7 @@
|
|||
|
||||
/**
|
||||
* \def POLARSSL_CIPHER_C
|
||||
@@ -436,8 +436,8 @@
|
||||
@@ -477,8 +477,8 @@
|
||||
* library/ssl_tls.c
|
||||
*
|
||||
* This module provides debugging functions.
|
||||
|
@ -50,7 +50,7 @@
|
|||
|
||||
/**
|
||||
* \def POLARSSL_DES_C
|
||||
@@ -519,8 +519,8 @@
|
||||
@@ -560,8 +560,8 @@
|
||||
* enabled as well):
|
||||
* TLS_RSA_WITH_AES_128_GCM_SHA256
|
||||
* TLS_RSA_WITH_AES_256_GCM_SHA384
|
||||
|
@ -60,7 +60,7 @@
|
|||
|
||||
/**
|
||||
* \def POLARSSL_HAVEGE_C
|
||||
@@ -533,8 +533,8 @@
|
||||
@@ -574,8 +574,8 @@
|
||||
* Requires: POLARSSL_TIMING_C
|
||||
*
|
||||
* This module enables the HAVEGE random number generator.
|
||||
|
@ -70,7 +70,7 @@
|
|||
|
||||
/**
|
||||
* \def POLARSSL_MD_C
|
||||
@@ -608,8 +608,8 @@
|
||||
@@ -649,8 +649,8 @@
|
||||
* Caller: library/aes.c
|
||||
*
|
||||
* This modules adds support for the VIA PadLock on x86.
|
||||
|
@ -80,7 +80,7 @@
|
|||
|
||||
/**
|
||||
* \def POLARSSL_PBKDF2_C
|
||||
@@ -722,8 +722,8 @@
|
||||
@@ -763,8 +763,8 @@
|
||||
* Caller:
|
||||
*
|
||||
* Requires: POLARSSL_SSL_CACHE_C
|
||||
|
@ -90,7 +90,7 @@
|
|||
|
||||
/**
|
||||
* \def POLARSSL_SSL_CLI_C
|
||||
@@ -777,8 +777,8 @@
|
||||
@@ -818,8 +818,8 @@
|
||||
* Caller: library/havege.c
|
||||
*
|
||||
* This module is used by the HAVEGE random number generator.
|
||||
|
@ -100,7 +100,7 @@
|
|||
|
||||
/**
|
||||
* \def POLARSSL_VERSION_C
|
||||
@@ -827,8 +827,8 @@
|
||||
@@ -868,8 +868,8 @@
|
||||
*
|
||||
* Module: library/xtea.c
|
||||
* Caller:
|
||||
|
|
Loading…
Reference in New Issue