mirror of https://github.com/hak5/openwrt-owl.git
ppp: add missing -fPIC to rp-pppoe.so CFLAGS
Fixes build error with LTO Signed-off-by: Felix Fietkau <nbd@nbd.name>master
parent
2601e34fad
commit
888a15ff83
|
@ -30,3 +30,14 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
|
||||||
OBJS = pppdump.o bsd-comp.o deflate.o zlib.o
|
OBJS = pppdump.o bsd-comp.o deflate.o zlib.o
|
||||||
|
|
||||||
INSTALL= install
|
INSTALL= install
|
||||||
|
--- a/pppd/plugins/rp-pppoe/Makefile.linux
|
||||||
|
+++ b/pppd/plugins/rp-pppoe/Makefile.linux
|
||||||
|
@@ -39,7 +39,7 @@ debug.o: debug.c
|
||||||
|
$(CC) $(CFLAGS) -c -o debug.o debug.c
|
||||||
|
|
||||||
|
rp-pppoe.so: plugin.o discovery.o if.o common.o
|
||||||
|
- $(CC) $(CFLAGS) -o rp-pppoe.so -shared plugin.o discovery.o if.o common.o
|
||||||
|
+ $(CC) $(CFLAGS) -fPIC -o rp-pppoe.so -shared plugin.o discovery.o if.o common.o
|
||||||
|
|
||||||
|
install: all
|
||||||
|
$(INSTALL) -d -m 755 $(LIBDIR)
|
||||||
|
|
Loading…
Reference in New Issue