mirror of https://github.com/hak5/openwrt-owl.git
parent
ed957f7c84
commit
7314de1e5d
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2007-2011 OpenWrt.org
|
# Copyright (C) 2007-2012 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=acx-mac80211
|
PKG_NAME:=acx-mac80211
|
||||||
PKG_REV:=09bebfda18d7000bfeaa4d5d49db90ef601f23a3
|
PKG_REV:=15bbffeadc1928a21a8a5f6519a5aea13b50678a
|
||||||
PKG_VERSION:=20111030
|
PKG_VERSION:=20120422
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
|
|
@ -1,11 +1,13 @@
|
||||||
--- a/Makefile
|
Index: acx-mac80211-20120422/Makefile
|
||||||
+++ b/Makefile
|
===================================================================
|
||||||
@@ -29,7 +29,7 @@ ifneq ($(KERNELRELEASE),)
|
--- acx-mac80211-20120422.orig/Makefile 2012-04-23 17:35:13.000000000 +0200
|
||||||
|
+++ acx-mac80211-20120422/Makefile 2012-04-23 17:36:55.386257951 +0200
|
||||||
|
@@ -30,7 +30,7 @@
|
||||||
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_PCI) += pci.o
|
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_PCI) += pci.o
|
||||||
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
|
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
|
||||||
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_MEM) += mem.o
|
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_MEM) += mem.o
|
||||||
- acx-mac80211-objs := common.o $(acx-mac80211-obj-y)
|
- acx-mac80211-objs := common.o $(acx-mac80211-obj-y) merge.o
|
||||||
+ acx-mac80211-objs := common.o $(acx-mac80211-obj-m)
|
+ acx-mac80211-objs := common.o $(acx-mac80211-obj-m) merge.o
|
||||||
|
|
||||||
else
|
else
|
||||||
# Otherwise we were called directly from the command line: the kernel build
|
# Otherwise we were called directly from the command line: the kernel build
|
||||||
|
|
|
@ -1,6 +1,8 @@
|
||||||
--- a/common.c
|
Index: acx-mac80211-20120422/common.c
|
||||||
+++ b/common.c
|
===================================================================
|
||||||
@@ -31,6 +31,7 @@
|
--- acx-mac80211-20120422.orig/common.c 2012-04-23 17:35:13.000000000 +0200
|
||||||
|
+++ acx-mac80211-20120422/common.c 2012-04-23 17:37:02.818257747 +0200
|
||||||
|
@@ -33,6 +33,7 @@
|
||||||
#include <linux/ethtool.h>
|
#include <linux/ethtool.h>
|
||||||
#include <linux/nl80211.h>
|
#include <linux/nl80211.h>
|
||||||
#include <linux/ieee80211.h>
|
#include <linux/ieee80211.h>
|
||||||
|
|
Loading…
Reference in New Issue