mirror of https://github.com/hak5/openwrt-owl.git
parent
d3092630a8
commit
655b43acc4
|
@ -1,27 +1,8 @@
|
||||||
commit e09dd7ae2076782c47a8b729b989e20af882415f
|
--- a/arch/mips/ar7/platform.c
|
||||||
Author: Florian Fainelli <florian@openwrt.org>
|
+++ b/arch/mips/ar7/platform.c
|
||||||
Date: Sat May 8 16:03:34 2010 +0200
|
@@ -606,4 +606,4 @@ static int __init ar7_register_devices(v
|
||||||
|
|
||||||
AR7: prevent race between clocks and devices initialization
|
return res;
|
||||||
|
}
|
||||||
ar7_clocks_init and ar7_register_devices are both called at arch_initcall
|
-arch_initcall(ar7_register_devices);
|
||||||
however, ar7_register_devices relies on clocks to be initialized, and clock.o
|
+device_initcall(ar7_register_devices);
|
||||||
is to be linked later. Fix this by making clock.o be linked earlier.
|
|
||||||
|
|
||||||
Reported-by: Michael J. Evans <mjevans1983@gmail.com>
|
|
||||||
Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
|
||||||
|
|
||||||
diff --git a/arch/mips/ar7/Makefile b/arch/mips/ar7/Makefile
|
|
||||||
index 26bc5da..2df8910 100644
|
|
||||||
--- a/arch/mips/ar7/Makefile
|
|
||||||
+++ b/arch/mips/ar7/Makefile
|
|
||||||
@@ -5,7 +5,7 @@ obj-y := \
|
|
||||||
memory.o \
|
|
||||||
irq.o \
|
|
||||||
time.o \
|
|
||||||
+ clock.o \
|
|
||||||
platform.o \
|
|
||||||
- gpio.o \
|
|
||||||
- clock.o
|
|
||||||
+ gpio.o
|
|
||||||
EXTRA_CFLAGS += -Werror
|
|
||||||
|
|
Loading…
Reference in New Issue