mirror of https://github.com/hak5/openwrt-owl.git
ar71xx: add kernel support for the Oolite v1 board
Patch-by: Lars Bøgild Thomsen <lth@cow.dk> Patchwork: http://patchwork.openwrt.org/patch/4922/ [juhosg: - use a separate patch for kernel changes, - reorder Kconfig and Makefile entries, - change function and variable names to be lowercase only and fix misaligned tabs in mach-gs-oolite.c, ... ] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 40032owl
parent
f0dc89b46f
commit
5256bbdc56
|
@ -48,6 +48,7 @@ CONFIG_ATH79_MACH_DIR_825_C1=y
|
||||||
CONFIG_ATH79_MACH_DRAGINO2=y
|
CONFIG_ATH79_MACH_DRAGINO2=y
|
||||||
CONFIG_ATH79_MACH_EAP7660D=y
|
CONFIG_ATH79_MACH_EAP7660D=y
|
||||||
CONFIG_ATH79_MACH_EW_DORIN=y
|
CONFIG_ATH79_MACH_EW_DORIN=y
|
||||||
|
CONFIG_ATH79_MACH_GS_OOLITE=y
|
||||||
CONFIG_ATH79_MACH_HORNET_UB=y
|
CONFIG_ATH79_MACH_HORNET_UB=y
|
||||||
CONFIG_ATH79_MACH_JA76PF=y
|
CONFIG_ATH79_MACH_JA76PF=y
|
||||||
CONFIG_ATH79_MACH_JWAP003=y
|
CONFIG_ATH79_MACH_JWAP003=y
|
||||||
|
|
|
@ -0,0 +1,103 @@
|
||||||
|
/*
|
||||||
|
* Oolite board support
|
||||||
|
*
|
||||||
|
*
|
||||||
|
* This program is free software; you can redistribute it and/or modify it
|
||||||
|
* under the terms of the GNU General Public License version 2 as published
|
||||||
|
* by the Free Software Foundation.
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include <linux/gpio.h>
|
||||||
|
|
||||||
|
#include <asm/mach-ath79/ath79.h>
|
||||||
|
#include <asm/mach-ath79/ar71xx_regs.h>
|
||||||
|
|
||||||
|
#include "common.h"
|
||||||
|
#include "dev-eth.h"
|
||||||
|
#include "dev-gpio-buttons.h"
|
||||||
|
#include "dev-leds-gpio.h"
|
||||||
|
#include "dev-m25p80.h"
|
||||||
|
#include "dev-wmac.h"
|
||||||
|
#include "machtypes.h"
|
||||||
|
#include "dev-usb.h"
|
||||||
|
|
||||||
|
#define GS_OOLITE_GPIO_BTN6 6
|
||||||
|
#define GS_OOLITE_GPIO_BTN7 7
|
||||||
|
#define GS_OOLITE_GPIO_BTN_RESET 11
|
||||||
|
|
||||||
|
#define GS_OOLITE_GPIO_LED_SYSTEM 27
|
||||||
|
|
||||||
|
#define GS_OOLITE_KEYS_POLL_INTERVAL 20 /* msecs */
|
||||||
|
#define GS_OOLITE_KEYS_DEBOUNCE_INTERVAL (3 * GS_OOLITE_KEYS_POLL_INTERVAL)
|
||||||
|
|
||||||
|
static const char *gs_oolite_part_probes[] = {
|
||||||
|
"tp-link",
|
||||||
|
NULL,
|
||||||
|
};
|
||||||
|
|
||||||
|
static struct flash_platform_data gs_oolite_flash_data = {
|
||||||
|
.part_probes = gs_oolite_part_probes,
|
||||||
|
};
|
||||||
|
|
||||||
|
static struct gpio_led gs_oolite_leds_gpio[] __initdata = {
|
||||||
|
{
|
||||||
|
.name = "oolite:red:system",
|
||||||
|
.gpio = GS_OOLITE_GPIO_LED_SYSTEM,
|
||||||
|
.active_low = 1,
|
||||||
|
},
|
||||||
|
};
|
||||||
|
|
||||||
|
static struct gpio_keys_button gs_oolite_gpio_keys[] __initdata = {
|
||||||
|
{
|
||||||
|
.desc = "reset",
|
||||||
|
.type = EV_KEY,
|
||||||
|
.code = KEY_RESTART,
|
||||||
|
.debounce_interval = GS_OOLITE_KEYS_DEBOUNCE_INTERVAL,
|
||||||
|
.gpio = GS_OOLITE_GPIO_BTN_RESET,
|
||||||
|
.active_low = 1,
|
||||||
|
},
|
||||||
|
{
|
||||||
|
.desc = "BTN_6",
|
||||||
|
.type = EV_KEY,
|
||||||
|
.code = BTN_6,
|
||||||
|
.debounce_interval = GS_OOLITE_KEYS_DEBOUNCE_INTERVAL,
|
||||||
|
.gpio = GS_OOLITE_GPIO_BTN6,
|
||||||
|
.active_low = 1,
|
||||||
|
},
|
||||||
|
{
|
||||||
|
.desc = "BTN_7",
|
||||||
|
.type = EV_KEY,
|
||||||
|
.code = BTN_7,
|
||||||
|
.debounce_interval = GS_OOLITE_KEYS_DEBOUNCE_INTERVAL,
|
||||||
|
.gpio = GS_OOLITE_GPIO_BTN7,
|
||||||
|
.active_low = 1,
|
||||||
|
},
|
||||||
|
};
|
||||||
|
|
||||||
|
static void __init gs_oolite_setup(void)
|
||||||
|
{
|
||||||
|
u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
|
||||||
|
u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
|
||||||
|
|
||||||
|
ath79_register_leds_gpio(-1, ARRAY_SIZE(gs_oolite_leds_gpio),
|
||||||
|
gs_oolite_leds_gpio);
|
||||||
|
|
||||||
|
ath79_register_gpio_keys_polled(-1, GS_OOLITE_KEYS_POLL_INTERVAL,
|
||||||
|
ARRAY_SIZE(gs_oolite_gpio_keys),
|
||||||
|
gs_oolite_gpio_keys);
|
||||||
|
|
||||||
|
ath79_register_usb();
|
||||||
|
|
||||||
|
ath79_register_m25p80(&gs_oolite_flash_data);
|
||||||
|
ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
|
||||||
|
ath79_init_mac(ath79_eth1_data.mac_addr, mac, -1);
|
||||||
|
|
||||||
|
ath79_register_mdio(0, 0x0);
|
||||||
|
ath79_register_eth(1);
|
||||||
|
ath79_register_eth(0);
|
||||||
|
|
||||||
|
ath79_register_wmac(ee, mac);
|
||||||
|
}
|
||||||
|
|
||||||
|
MIPS_MACHINE(ATH79_MACH_GS_OOLITE, "GS-OOLITE",
|
||||||
|
"Oolite V1.0", gs_oolite_setup);
|
|
@ -0,0 +1,39 @@
|
||||||
|
--- a/arch/mips/ath79/machtypes.h
|
||||||
|
+++ b/arch/mips/ath79/machtypes.h
|
||||||
|
@@ -49,6 +49,7 @@ enum ath79_mach_type {
|
||||||
|
ATH79_MACH_EW_DORIN, /* embedded wireless Dorin Platform */
|
||||||
|
ATH79_MACH_EW_DORIN_ROUTER, /* embedded wireless Dorin Router Platform */
|
||||||
|
ATH79_MACH_EAP7660D, /* Senao EAP7660D */
|
||||||
|
+ ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */
|
||||||
|
ATH79_MACH_JA76PF, /* jjPlus JA76PF */
|
||||||
|
ATH79_MACH_JA76PF2, /* jjPlus JA76PF2 */
|
||||||
|
ATH79_MACH_JWAP003, /* jjPlus JWAP003 */
|
||||||
|
--- a/arch/mips/ath79/Kconfig
|
||||||
|
+++ b/arch/mips/ath79/Kconfig
|
||||||
|
@@ -337,6 +337,16 @@ config ATH79_MACH_EW_DORIN
|
||||||
|
Say 'Y' here if you want your kernel to support the
|
||||||
|
Dorin Platform from www.80211.de .
|
||||||
|
|
||||||
|
+config ATH79_MACH_GS_OOLITE
|
||||||
|
+ bool "GS Oolite V1 support"
|
||||||
|
+ select SOC_AR933X
|
||||||
|
+ select ARH79_DEV_ETH
|
||||||
|
+ select ARH79_DEV_GPIO_BUTTONS
|
||||||
|
+ select ATH79_DEV_LEDS_GPIO
|
||||||
|
+ select ATH79_DEV_M25P80
|
||||||
|
+ select ATH79_DEV_USB
|
||||||
|
+ select ATH79_DEV_WMAC
|
||||||
|
+
|
||||||
|
config ATH79_MACH_JA76PF
|
||||||
|
bool "jjPlus JA76PF board support"
|
||||||
|
select SOC_AR71XX
|
||||||
|
--- a/arch/mips/ath79/Makefile
|
||||||
|
+++ b/arch/mips/ath79/Makefile
|
||||||
|
@@ -62,6 +62,7 @@ obj-$(CONFIG_ATH79_MACH_DIR_825_C1) += m
|
||||||
|
obj-$(CONFIG_ATH79_MACH_DRAGINO2) += mach-dragino2.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mach-ew-dorin.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
|
||||||
|
+obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_JA76PF) += mach-ja76pf.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_JWAP003) += mach-jwap003.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
|
Loading…
Reference in New Issue