mirror of https://github.com/hak5/openwrt-owl.git
parent
f124358722
commit
458716389c
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
||||||
FEATURES:=ext4 audio
|
FEATURES:=ext4 audio
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.39.2
|
LINUX_VERSION:=3.0.1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/arch/um/Makefile-i386
|
||||||
|
+++ b/arch/um/Makefile-i386
|
||||||
|
@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
|
||||||
|
# Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
|
||||||
|
# a lot more stack due to the lack of sharing of stacklots. Also, gcc
|
||||||
|
# 4.3.0 needs -funit-at-a-time for extern inline functions.
|
||||||
|
-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
|
||||||
|
+KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
|
||||||
|
echo $(call cc-option,-fno-unit-at-a-time); \
|
||||||
|
else echo $(call cc-option,-funit-at-a-time); fi ;)
|
||||||
|
|
|
@ -0,0 +1,14 @@
|
||||||
|
diff --git a/arch/um/os-Linux/user_syms.c b/arch/um/os-Linux/user_syms.c
|
||||||
|
index 05f5ea8..9e71e7e 100644
|
||||||
|
--- a/arch/um/os-Linux/user_syms.c
|
||||||
|
+++ b/arch/um/os-Linux/user_syms.c
|
||||||
|
@@ -18,6 +18,9 @@ extern void *memmove(void *, const void *, size_t);
|
||||||
|
extern void *memset(void *, int, size_t);
|
||||||
|
extern int printf(const char *, ...);
|
||||||
|
|
||||||
|
+extern int __sprintf_chk(char *str, int flag, size_t strlen, const char *format);
|
||||||
|
+EXPORT_SYMBOL(__sprintf_chk);
|
||||||
|
+
|
||||||
|
/* If it's not defined, the export is included in lib/string.c.*/
|
||||||
|
#ifdef __HAVE_ARCH_STRSTR
|
||||||
|
EXPORT_SYMBOL(strstr);
|
|
@ -0,0 +1,14 @@
|
||||||
|
make ZLIB_DEFLATE visible, so that we can choose whether we want it built-in
|
||||||
|
or as a module
|
||||||
|
|
||||||
|
--- a/lib/Kconfig
|
||||||
|
+++ b/lib/Kconfig
|
||||||
|
@@ -98,7 +98,7 @@ config ZLIB_INFLATE
|
||||||
|
tristate
|
||||||
|
|
||||||
|
config ZLIB_DEFLATE
|
||||||
|
- tristate
|
||||||
|
+ tristate "Zlib compression"
|
||||||
|
|
||||||
|
config LZO_COMPRESS
|
||||||
|
tristate
|
Loading…
Reference in New Issue