mirror of https://github.com/hak5/openwrt-owl.git
parent
0ddeec5cd5
commit
3dbe2e1093
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006-2008 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -9,12 +9,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ebtables
|
PKG_NAME:=ebtables
|
||||||
PKG_VERSION:=2.0.8-rc2
|
PKG_VERSION:=2.0.8-2
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/ebtables
|
PKG_SOURCE_URL:=@SF/ebtables
|
||||||
PKG_MD5SUM:=f07111fcc1966be669278433c35dcc28
|
PKG_MD5SUM:=66bcbcb2dcf3b981ad4e86e1720e796e
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
|
||||||
|
|
||||||
|
@ -27,6 +27,13 @@ define Package/ebtables
|
||||||
URL:=http://ebtables.sourceforge.net/
|
URL:=http://ebtables.sourceforge.net/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/ebtables/description
|
||||||
|
The ebtables program is a filtering tool for a bridging firewall. The
|
||||||
|
filtering is focussed on the Link Layer Ethernet frame fields. Apart
|
||||||
|
from filtering, it also gives the ability to alter the Ethernet MAC
|
||||||
|
addresses and implement a brouter.
|
||||||
|
endef
|
||||||
|
|
||||||
MAKE_FLAGS += \
|
MAKE_FLAGS += \
|
||||||
CFLAGS="$(TARGET_CFLAGS)"
|
CFLAGS="$(TARGET_CFLAGS)"
|
||||||
|
|
||||||
|
|
|
@ -1,13 +0,0 @@
|
||||||
Index: ebtables-v2.0.8-rc2/include/linux/netfilter_bridge.h
|
|
||||||
===================================================================
|
|
||||||
--- ebtables-v2.0.8-rc2.orig/include/linux/netfilter_bridge.h 2007-06-04 13:22:27.306704032 +0200
|
|
||||||
+++ ebtables-v2.0.8-rc2/include/linux/netfilter_bridge.h 2007-06-04 13:22:27.372694000 +0200
|
|
||||||
@@ -4,7 +4,7 @@
|
|
||||||
/* bridge-specific defines for netfilter.
|
|
||||||
*/
|
|
||||||
|
|
||||||
-#include <linux/config.h>
|
|
||||||
+#include <linux/autoconf.h>
|
|
||||||
#include <linux/netfilter.h>
|
|
||||||
#if defined(__KERNEL__) && defined(CONFIG_BRIDGE_NETFILTER)
|
|
||||||
#include <asm/atomic.h>
|
|
Loading…
Reference in New Issue