mtd-utils: refresh the cygwin_fixes patch

SVN-Revision: 19159
owl
Felix Fietkau 2010-01-16 00:11:47 +00:00
parent 5c8bfc0c17
commit 393835a5d9
1 changed files with 24 additions and 33 deletions

View File

@ -1,7 +1,6 @@
diff -urN mtd-20090505/Makefile mtd-20090505.new/Makefile --- a/Makefile
--- mtd-20090505/Makefile 2009-06-05 16:59:08.000000000 +0200 +++ b/Makefile
+++ mtd-20090505.new/Makefile 2010-01-05 11:11:24.000000000 +0100 @@ -7,6 +7,11 @@ ifeq ($(WITHOUT_XATTR), 1)
@@ -7,6 +7,11 @@
CPPFLAGS += -DWITHOUT_XATTR CPPFLAGS += -DWITHOUT_XATTR
endif endif
@ -13,7 +12,7 @@ diff -urN mtd-20090505/Makefile mtd-20090505.new/Makefile
SUBDIRS = ubi-utils mkfs.ubifs SUBDIRS = ubi-utils mkfs.ubifs
TARGETS = ftl_format flash_erase flash_eraseall nanddump doc_loadbios \ TARGETS = ftl_format flash_erase flash_eraseall nanddump doc_loadbios \
@@ -17,6 +22,10 @@ @@ -17,6 +22,10 @@ TARGETS = ftl_format flash_erase flash_e
rfddump rfdformat \ rfddump rfdformat \
serve_image recv_image \ serve_image recv_image \
sumtool #jffs2reader sumtool #jffs2reader
@ -24,9 +23,8 @@ diff -urN mtd-20090505/Makefile mtd-20090505.new/Makefile
SYMLINKS = SYMLINKS =
diff -urN mtd-20090505/include/cygwin/bits-byteswap.h mtd-20090505.new/include/cygwin/bits-byteswap.h --- /dev/null
--- mtd-20090505/include/cygwin/bits-byteswap.h 1970-01-01 01:00:00.000000000 +0100 +++ b/include/cygwin/bits-byteswap.h
+++ mtd-20090505.new/include/cygwin/bits-byteswap.h 2010-01-05 11:09:45.000000000 +0100
@@ -0,0 +1,132 @@ @@ -0,0 +1,132 @@
+/* Macros to swap the order of bytes in integer values. +/* Macros to swap the order of bytes in integer values.
+ Copyright (C) 1997, 1998, 2000, 2002 Free Software Foundation, Inc. + Copyright (C) 1997, 1998, 2000, 2002 Free Software Foundation, Inc.
@ -160,9 +158,8 @@ diff -urN mtd-20090505/include/cygwin/bits-byteswap.h mtd-20090505.new/include/c
+#endif +#endif
+ +
+#endif /* _BITS_BYTESWAP_H */ +#endif /* _BITS_BYTESWAP_H */
diff -urN mtd-20090505/include/cygwin/byteswap.h mtd-20090505.new/include/cygwin/byteswap.h --- /dev/null
--- mtd-20090505/include/cygwin/byteswap.h 1970-01-01 01:00:00.000000000 +0100 +++ b/include/cygwin/byteswap.h
+++ mtd-20090505.new/include/cygwin/byteswap.h 2010-01-05 11:09:45.000000000 +0100
@@ -0,0 +1,40 @@ @@ -0,0 +1,40 @@
+/* Copyright (C) 1997 Free Software Foundation, Inc. +/* Copyright (C) 1997 Free Software Foundation, Inc.
+ This file is part of the GNU C Library. + This file is part of the GNU C Library.
@ -204,9 +201,8 @@ diff -urN mtd-20090505/include/cygwin/byteswap.h mtd-20090505.new/include/cygwin
+#endif +#endif
+ +
+#endif /* byteswap.h */ +#endif /* byteswap.h */
diff -urN mtd-20090505/include/cygwin/endian.h mtd-20090505.new/include/cygwin/endian.h --- /dev/null
--- mtd-20090505/include/cygwin/endian.h 1970-01-01 01:00:00.000000000 +0100 +++ b/include/cygwin/endian.h
+++ mtd-20090505.new/include/cygwin/endian.h 2010-01-05 11:43:10.000000000 +0100
@@ -0,0 +1,26 @@ @@ -0,0 +1,26 @@
+#ifndef _CYGENDIAN_H_ +#ifndef _CYGENDIAN_H_
+#define _CYGENDIAN_H_ +#define _CYGENDIAN_H_
@ -234,9 +230,8 @@ diff -urN mtd-20090505/include/cygwin/endian.h mtd-20090505.new/include/cygwin/e
+#endif /* __CYGWIN__ */ +#endif /* __CYGWIN__ */
+ +
+#endif /* _CYGENDIAN_H_ */ +#endif /* _CYGENDIAN_H_ */
diff -urN mtd-20090505/include/cygwin/ioctl.h mtd-20090505.new/include/cygwin/ioctl.h --- /dev/null
--- mtd-20090505/include/cygwin/ioctl.h 1970-01-01 01:00:00.000000000 +0100 +++ b/include/cygwin/ioctl.h
+++ mtd-20090505.new/include/cygwin/ioctl.h 2010-01-05 11:09:45.000000000 +0100
@@ -0,0 +1,38 @@ @@ -0,0 +1,38 @@
+#ifndef _CYGIOCTL_H_ +#ifndef _CYGIOCTL_H_
+#define _CYGIOCTL_H_ +#define _CYGIOCTL_H_
@ -276,9 +271,8 @@ diff -urN mtd-20090505/include/cygwin/ioctl.h mtd-20090505.new/include/cygwin/io
+#endif /* __CYGWIN__ */ +#endif /* __CYGWIN__ */
+ +
+#endif /* _CYGIOCTL_H_ */ +#endif /* _CYGIOCTL_H_ */
diff -urN mtd-20090505/include/cygwin/pread.c mtd-20090505.new/include/cygwin/pread.c --- /dev/null
--- mtd-20090505/include/cygwin/pread.c 1970-01-01 01:00:00.000000000 +0100 +++ b/include/cygwin/pread.c
+++ mtd-20090505.new/include/cygwin/pread.c 2010-01-05 11:09:45.000000000 +0100
@@ -0,0 +1,41 @@ @@ -0,0 +1,41 @@
+#ifdef __CYGWIN__ +#ifdef __CYGWIN__
+ +
@ -321,9 +315,8 @@ diff -urN mtd-20090505/include/cygwin/pread.c mtd-20090505.new/include/cygwin/pr
+} +}
+ +
+#endif /* __CYGWIN__ */ +#endif /* __CYGWIN__ */
diff -urN mtd-20090505/lnconf.sh mtd-20090505.new/lnconf.sh --- /dev/null
--- mtd-20090505/lnconf.sh 1970-01-01 01:00:00.000000000 +0100 +++ b/lnconf.sh
+++ mtd-20090505.new/lnconf.sh 2010-01-05 11:09:45.000000000 +0100
@@ -0,0 +1,53 @@ @@ -0,0 +1,53 @@
+#!/bin/sh +#!/bin/sh
+# +#
@ -378,9 +371,8 @@ diff -urN mtd-20090505/lnconf.sh mtd-20090505.new/lnconf.sh
+ +
+lndir "$tdir" +lndir "$tdir"
+ +
diff -urN mtd-20090505/mkfs.jffs2.c mtd-20090505.new/mkfs.jffs2.c --- a/mkfs.jffs2.c
--- mtd-20090505/mkfs.jffs2.c 2009-06-05 16:59:08.000000000 +0200 +++ b/mkfs.jffs2.c
+++ mtd-20090505.new/mkfs.jffs2.c 2010-01-05 11:25:52.000000000 +0100
@@ -75,6 +75,14 @@ @@ -75,6 +75,14 @@
#include "crc32.h" #include "crc32.h"
#include "rbtree.h" #include "rbtree.h"
@ -396,7 +388,7 @@ diff -urN mtd-20090505/mkfs.jffs2.c mtd-20090505.new/mkfs.jffs2.c
/* Do not use the weird XPG version of basename */ /* Do not use the weird XPG version of basename */
#undef basename #undef basename
@@ -474,7 +482,7 @@ @@ -474,7 +482,7 @@ static struct filesystem_entry *recursiv
the following macros use it if available or use a hacky workaround... the following macros use it if available or use a hacky workaround...
*/ */
@ -405,7 +397,7 @@ diff -urN mtd-20090505/mkfs.jffs2.c mtd-20090505.new/mkfs.jffs2.c
#define SCANF_PREFIX "a" #define SCANF_PREFIX "a"
#define SCANF_STRING(s) (&s) #define SCANF_STRING(s) (&s)
#define GETCWD_SIZE 0 #define GETCWD_SIZE 0
@@ -557,6 +565,14 @@ @@ -557,6 +565,14 @@ static int interpret_table_entry(struct
} }
entry = find_filesystem_entry(root, name, mode); entry = find_filesystem_entry(root, name, mode);
if (entry) { if (entry) {
@ -420,7 +412,7 @@ diff -urN mtd-20090505/mkfs.jffs2.c mtd-20090505.new/mkfs.jffs2.c
/* Ok, we just need to fixup the existing entry /* Ok, we just need to fixup the existing entry
* and we will be all done... */ * and we will be all done... */
entry->sb.st_uid = uid; entry->sb.st_uid = uid;
@@ -566,11 +582,21 @@ @@ -566,11 +582,21 @@ static int interpret_table_entry(struct
entry->sb.st_rdev = makedev(major, minor); entry->sb.st_rdev = makedev(major, minor);
} }
} else { } else {
@ -443,7 +435,7 @@ diff -urN mtd-20090505/mkfs.jffs2.c mtd-20090505.new/mkfs.jffs2.c
free(tmp); free(tmp);
if (parent == NULL) { if (parent == NULL) {
error_msg ("skipping device_table entry '%s': no parent directory!", name); error_msg ("skipping device_table entry '%s': no parent directory!", name);
@@ -584,6 +610,7 @@ @@ -584,6 +610,7 @@ static int interpret_table_entry(struct
add_host_filesystem_entry(name, hostpath, uid, gid, mode, 0, parent); add_host_filesystem_entry(name, hostpath, uid, gid, mode, 0, parent);
break; break;
case 'f': case 'f':
@ -451,9 +443,8 @@ diff -urN mtd-20090505/mkfs.jffs2.c mtd-20090505.new/mkfs.jffs2.c
add_host_filesystem_entry(name, hostpath, uid, gid, mode, 0, parent); add_host_filesystem_entry(name, hostpath, uid, gid, mode, 0, parent);
break; break;
case 'p': case 'p':
diff -urN mtd-20090505/ubi-utils/src/libubi.c mtd-20090505.new/ubi-utils/src/libubi.c --- a/ubi-utils/src/libubi.c
--- mtd-20090505/ubi-utils/src/libubi.c 2009-06-05 16:59:08.000000000 +0200 +++ b/ubi-utils/src/libubi.c
+++ mtd-20090505.new/ubi-utils/src/libubi.c 2010-01-05 11:46:24.000000000 +0100
@@ -30,6 +30,9 @@ @@ -30,6 +30,9 @@
#include <sys/ioctl.h> #include <sys/ioctl.h>
#include <sys/stat.h> #include <sys/stat.h>