mirror of https://github.com/hak5/openwrt-owl.git
gdb: update to version 7.8, fix musl build
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42979owl
parent
35232039c0
commit
338892ddf8
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gdb
|
||||
PKG_VERSION:=7.5
|
||||
PKG_VERSION:=7.8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/gdb
|
||||
PKG_MD5SUM:=24a6779a9fe0260667710de1b082ef61
|
||||
PKG_MD5SUM:=bd958fe9019d7c7896f29f6724a764ed
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
See http://sourceware.org/bugzilla/show_bug.cgi?id=14523
|
||||
---
|
||||
--- gdb-7.5.org/gdb/common/signals.c 2012-05-24 18:51:37.000000000 +0200
|
||||
+++ gdb-7.5.org/gdb/common/signals.c 2012-08-29 22:32:07.000000000 +0200
|
||||
@@ -346,6 +346,11 @@
|
||||
--- a/gdb/common/signals.c
|
||||
+++ b/gdb/common/signals.c
|
||||
@@ -350,6 +350,11 @@ gdb_signal_from_host (int hostsig)
|
||||
else if (64 <= hostsig && hostsig <= 127)
|
||||
return (enum gdb_signal)
|
||||
(hostsig - 64 + (int) GDB_SIGNAL_REALTIME_64);
|
||||
|
|
|
@ -0,0 +1,28 @@
|
|||
--- a/gdb/linux-nat.c
|
||||
+++ b/gdb/linux-nat.c
|
||||
@@ -17,6 +17,7 @@
|
||||
You should have received a copy of the GNU General Public License
|
||||
along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||
|
||||
+#include "stopcode.h"
|
||||
#include "defs.h"
|
||||
#include "inferior.h"
|
||||
#include "infrun.h"
|
||||
@@ -81,6 +82,10 @@
|
||||
# endif
|
||||
#endif /* HAVE_PERSONALITY */
|
||||
|
||||
+#ifndef __SIGRTMIN
|
||||
+#define __SIGRTMIN SIGRTMIN
|
||||
+#endif
|
||||
+
|
||||
/* This comment documents high-level logic of this file.
|
||||
|
||||
Waiting for events in sync mode
|
||||
--- /dev/null
|
||||
+++ b/gdb/stopcode.h
|
||||
@@ -0,0 +1,4 @@
|
||||
+#ifndef W_STOPCODE
|
||||
+#define W_STOPCODE(sig) ((sig) << 8 | 0x7f)
|
||||
+#endif
|
||||
+
|
Loading…
Reference in New Issue