refresh 2.6.24 patches

SVN-Revision: 14451
owl
Gabor Juhos 2009-02-08 19:17:40 +00:00
parent 09de82989a
commit 27dee35f99
10 changed files with 63 additions and 80 deletions

View File

@ -1,7 +1,6 @@
diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/maps/Kconfig --- a/drivers/mtd/maps/Kconfig
--- linux-2.6.17/drivers/mtd/maps/Kconfig 2006-06-18 03:49:35.000000000 +0200 +++ b/drivers/mtd/maps/Kconfig
+++ linux-2.6.17.new/drivers/mtd/maps/Kconfig 2006-09-24 20:28:11.000000000 +0200 @@ -117,6 +117,50 @@ config MTD_PNC2000
@@ -76,6 +76,50 @@
PNC-2000 is the name of Network Camera product from PHOTRON PNC-2000 is the name of Network Camera product from PHOTRON
Ltd. in Japan. It uses CFI-compliant flash. Ltd. in Japan. It uses CFI-compliant flash.
@ -52,11 +51,10 @@ diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/map
config MTD_SC520CDP config MTD_SC520CDP
tristate "CFI Flash device mapped on AMD SC520 CDP" tristate "CFI Flash device mapped on AMD SC520 CDP"
depends on X86 && MTD_CFI && MTD_CONCAT depends on X86 && MTD_CFI && MTD_CONCAT
diff -urN linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17.new/drivers/mtd/maps/Makefile --- a/drivers/mtd/maps/Makefile
--- linux-2.6.17/drivers/mtd/maps/Makefile 2006-06-18 03:49:35.000000000 +0200 +++ b/drivers/mtd/maps/Makefile
+++ linux-2.6.17.new/drivers/mtd/maps/Makefile 2006-09-24 20:26:10.000000000 +0200 @@ -30,6 +30,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM) += pmcms
@@ -28,6 +28,7 @@ obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcmsp-ramroot.o
obj-$(CONFIG_MTD_PHYSMAP) += physmap.o
obj-$(CONFIG_MTD_PNC2000) += pnc2000.o obj-$(CONFIG_MTD_PNC2000) += pnc2000.o
obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
+obj-$(CONFIG_MTD_RDC3210) += rdc3210.o +obj-$(CONFIG_MTD_RDC3210) += rdc3210.o

View File

@ -1,15 +1,13 @@
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
index 97b64d7..f8c1d32 100644
--- a/arch/x86/Kconfig --- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig +++ b/arch/x86/Kconfig
@@ -79,6 +79,10 @@ config GENERIC_BUG @@ -81,6 +81,10 @@ config GENERIC_BUG
default y default y
depends on BUG depends on BUG
+config GENERIC_GPIO +config GENERIC_GPIO
+ bool + bool
+ default n + default n
+ +
config GENERIC_HWEIGHT config GENERIC_HWEIGHT
bool bool
default y default y

View File

@ -1,9 +1,8 @@
diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig --- a/drivers/net/Kconfig
--- linux-2.6.17/drivers/net/Kconfig 2006-06-18 03:49:35.000000000 +0200 +++ b/drivers/net/Kconfig
+++ linux-2.6.17.new/drivers/net/Kconfig 2006-09-25 13:14:27.000000000 +0200 @@ -1449,6 +1449,24 @@ config APRICOT
@@ -1358,6 +1358,24 @@ To compile this driver as a module, choose M here. The module
<file:Documentation/networking/net-modules.txt>. The module will be will be called apricot.
called apricot.
+config R6040 +config R6040
+ tristate "RDC Fast-Ethernet support (EXPERIMENTAL)" + tristate "RDC Fast-Ethernet support (EXPERIMENTAL)"
@ -24,16 +23,15 @@ diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
+ depends on R6040 + depends on R6040
+ default y + default y
config B44 config B44
tristate "Broadcom 4400 ethernet support (EXPERIMENTAL)" tristate "Broadcom 440x/47xx ethernet support"
depends on NET_PCI && PCI && EXPERIMENTAL depends on SSB_POSSIBLE
diff -urN linux-2.6.17/drivers/net/Makefile linux-2.6.17.new/drivers/net/Makefile --- a/drivers/net/Makefile
--- linux-2.6.17/drivers/net/Makefile 2006-06-18 03:49:35.000000000 +0200 +++ b/drivers/net/Makefile
+++ linux-2.6.17.new/drivers/net/Makefile 2006-09-25 13:14:45.000000000 +0200 @@ -116,6 +116,7 @@ obj-$(CONFIG_LNE390) += lne390.o 8390.o
@@ -106,6 +106,7 @@
obj-$(CONFIG_NE3210) += ne3210.o 8390.o obj-$(CONFIG_NE3210) += ne3210.o 8390.o
obj-$(CONFIG_NET_SB1250_MAC) += sb1250-mac.o obj-$(CONFIG_SB1250_MAC) += sb1250-mac.o
obj-$(CONFIG_B44) += b44.o obj-$(CONFIG_B44) += b44.o
+obj-$(CONFIG_R6040) += r6040.o +obj-$(CONFIG_R6040) += r6040.o
obj-$(CONFIG_FORCEDETH) += forcedeth.o obj-$(CONFIG_FORCEDETH) += forcedeth.o
obj-$(CONFIG_NE_H8300) += ne-h8300.o 8390.o obj-$(CONFIG_NE_H8300) += ne-h8300.o
obj-$(CONFIG_AX88796) += ax88796.o

View File

@ -1,6 +1,6 @@
--- linux-2.6.19.2/init/do_mounts.c 2007-01-10 11:10:37.000000000 -0800 --- a/init/do_mounts.c
+++ foo/init/do_mounts.c 2007-04-05 13:15:37.000000000 -0700 +++ b/init/do_mounts.c
@@ -243,6 +243,8 @@ @@ -256,6 +256,8 @@ static void __init get_fs_names(char *pa
{ {
char *s = page; char *s = page;

View File

@ -1,7 +1,6 @@
diff -urN linux-2.6.24/arch/x86/Kconfig linux-2.6.24.new/arch/x86/Kconfig --- a/arch/x86/Kconfig
--- linux-2.6.24/arch/x86/Kconfig 2008-01-24 23:58:37.000000000 +0100 +++ b/arch/x86/Kconfig
+++ linux-2.6.24.new/arch/x86/Kconfig 2008-02-11 18:24:27.000000000 +0100 @@ -304,6 +304,17 @@ config X86_VSMP
@@ -300,6 +300,17 @@
supposed to run on these EM64T-based machines. Only choose this option supposed to run on these EM64T-based machines. Only choose this option
if you have one of these machines. if you have one of these machines.
@ -19,10 +18,9 @@ diff -urN linux-2.6.24/arch/x86/Kconfig linux-2.6.24.new/arch/x86/Kconfig
endchoice endchoice
config SCHED_NO_NO_OMIT_FRAME_POINTER config SCHED_NO_NO_OMIT_FRAME_POINTER
diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c --- a/arch/x86/kernel/reboot_fixups_32.c
--- linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c 2008-01-24 23:58:37.000000000 +0100 +++ b/arch/x86/kernel/reboot_fixups_32.c
+++ linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c 2008-02-11 18:26:18.000000000 +0100 @@ -30,6 +30,17 @@ static void cs5536_warm_reset(struct pci
@@ -30,6 +30,17 @@
udelay(50); /* shouldn't get here but be safe and spin a while */ udelay(50); /* shouldn't get here but be safe and spin a while */
} }
@ -40,7 +38,7 @@ diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/
struct device_fixup { struct device_fixup {
unsigned int vendor; unsigned int vendor;
unsigned int device; unsigned int device;
@@ -40,6 +51,7 @@ @@ -40,6 +51,7 @@ static struct device_fixup fixups_table[
{ PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset }, { PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
{ PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset }, { PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
{ PCI_VENDOR_ID_NS, PCI_DEVICE_ID_NS_SC1100_BRIDGE, cs5530a_warm_reset }, { PCI_VENDOR_ID_NS, PCI_DEVICE_ID_NS_SC1100_BRIDGE, cs5530a_warm_reset },
@ -48,10 +46,9 @@ diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/
}; };
/* /*
diff -urN linux-2.6.24/arch/x86/Makefile_32 linux-2.6.24.new/arch/x86/Makefile_32 --- a/arch/x86/Makefile_32
--- linux-2.6.24/arch/x86/Makefile_32 2008-01-24 23:58:37.000000000 +0100 +++ b/arch/x86/Makefile_32
+++ linux-2.6.24.new/arch/x86/Makefile_32 2008-02-11 18:25:12.000000000 +0100 @@ -99,6 +99,11 @@ mflags-$(CONFIG_X86_ES7000) := -Iinclude
@@ -99,6 +99,11 @@
mcore-$(CONFIG_X86_ES7000) := arch/x86/mach-default mcore-$(CONFIG_X86_ES7000) := arch/x86/mach-default
core-$(CONFIG_X86_ES7000) := arch/x86/mach-es7000/ core-$(CONFIG_X86_ES7000) := arch/x86/mach-es7000/
@ -63,9 +60,8 @@ diff -urN linux-2.6.24/arch/x86/Makefile_32 linux-2.6.24.new/arch/x86/Makefile_3
# Xen paravirtualization support # Xen paravirtualization support
core-$(CONFIG_XEN) += arch/x86/xen/ core-$(CONFIG_XEN) += arch/x86/xen/
diff -urN linux-2.6.24/include/asm-x86/timex.h linux-2.6.24.new/include/asm-x86/timex.h --- a/include/asm-x86/timex.h
--- linux-2.6.24/include/asm-x86/timex.h 2008-01-24 23:58:37.000000000 +0100 +++ b/include/asm-x86/timex.h
+++ linux-2.6.24.new/include/asm-x86/timex.h 2008-02-11 18:25:43.000000000 +0100
@@ -7,6 +7,8 @@ @@ -7,6 +7,8 @@
#ifdef CONFIG_X86_ELAN #ifdef CONFIG_X86_ELAN

View File

@ -1,6 +1,6 @@
--- linux-2.6.24.7.orig/drivers/pcmcia/yenta_socket.c 2008-10-26 08:30:07.000000000 -0700 --- a/drivers/pcmcia/yenta_socket.c
+++ linux-2.6.24.7/drivers/pcmcia/yenta_socket.c 2008-10-26 08:54:27.000000000 -0700 +++ b/drivers/pcmcia/yenta_socket.c
@@ -1171,6 +1171,17 @@ @@ -1171,6 +1171,17 @@ static int __devinit yenta_probe (struct
/* We must finish initialization here */ /* We must finish initialization here */

View File

@ -1,6 +1,6 @@
--- linux-2.6.24.7/arch/x86/kernel/setup_32.c 2008-05-07 01:22:34.000000000 +0200 --- a/arch/x86/kernel/setup_32.c
+++ linux-2.6.24.7.new/arch/x86/kernel/setup_32.c 2008-08-05 14:54:58.000000000 +0200 +++ b/arch/x86/kernel/setup_32.c
@@ -609,6 +609,7 @@ @@ -609,6 +609,7 @@ void __init setup_arch(char **cmdline_p)
print_memory_map("user"); print_memory_map("user");
} }

View File

@ -1,7 +1,6 @@
diff -ru linux-2.6.24.7.orig/arch/x86/boot/boot.h linux-2.6.24.7/arch/x86/boot/boot.h --- a/arch/x86/boot/boot.h
--- linux-2.6.24.7.orig/arch/x86/boot/boot.h 2008-10-26 20:18:14.000000000 -0700 +++ b/arch/x86/boot/boot.h
+++ linux-2.6.24.7/arch/x86/boot/boot.h 2008-10-26 20:18:36.000000000 -0700 @@ -60,7 +60,7 @@ static inline void outl(u32 v, u16 port)
@@ -60,7 +60,7 @@
{ {
asm volatile("outl %0,%1" : : "a" (v), "dN" (port)); asm volatile("outl %0,%1" : : "a" (v), "dN" (port));
} }
@ -10,9 +9,8 @@ diff -ru linux-2.6.24.7.orig/arch/x86/boot/boot.h linux-2.6.24.7/arch/x86/boot/b
{ {
u32 v; u32 v;
asm volatile("inl %1,%0" : "=a" (v) : "dN" (port)); asm volatile("inl %1,%0" : "=a" (v) : "dN" (port));
diff -ru linux-2.6.24.7.orig/arch/x86/boot/pm.c linux-2.6.24.7/arch/x86/boot/pm.c --- a/arch/x86/boot/pm.c
--- linux-2.6.24.7.orig/arch/x86/boot/pm.c 2008-10-26 19:55:50.000000000 -0700 +++ b/arch/x86/boot/pm.c
+++ linux-2.6.24.7/arch/x86/boot/pm.c 2008-10-26 21:38:12.000000000 -0700
@@ -16,6 +16,9 @@ @@ -16,6 +16,9 @@
#include "boot.h" #include "boot.h"
@ -23,7 +21,7 @@ diff -ru linux-2.6.24.7.orig/arch/x86/boot/pm.c linux-2.6.24.7/arch/x86/boot/pm.
/* /*
* Invoke the realmode switch hook if present; otherwise * Invoke the realmode switch hook if present; otherwise
@@ -160,6 +163,16 @@ @@ -160,6 +163,16 @@ void go_to_protected_mode(void)
die(); die();
} }

View File

@ -1,8 +1,6 @@
diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
index 55f307f..4a1aa34 100644
--- a/include/linux/pci_ids.h --- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h +++ b/include/linux/pci_ids.h
@@ -2076,6 +2076,13 @@ @@ -2106,6 +2106,13 @@
#define PCI_DEVICE_ID_HERC_WIN 0x5732 #define PCI_DEVICE_ID_HERC_WIN 0x5732
#define PCI_DEVICE_ID_HERC_UNI 0x5832 #define PCI_DEVICE_ID_HERC_UNI 0x5832

View File

@ -1,7 +1,6 @@
diff -urN linux-2.6.19.2/scripts/Makefile.lib linux-2.6.19.2.new/scripts/Makefile.lib --- a/scripts/Makefile.lib
--- linux-2.6.19.2/scripts/Makefile.lib 2007-01-10 20:10:37.000000000 +0100 +++ b/scripts/Makefile.lib
+++ linux-2.6.19.2.new/scripts/Makefile.lib 2007-04-15 23:51:54.000000000 +0200 @@ -166,4 +166,9 @@ cmd_objcopy = $(OBJCOPY) $(OBJCOPYFLAGS)
@@ -162,4 +162,9 @@
quiet_cmd_gzip = GZIP $@ quiet_cmd_gzip = GZIP $@
cmd_gzip = gzip -f -9 < $< > $@ cmd_gzip = gzip -f -9 < $< > $@
@ -12,17 +11,15 @@ diff -urN linux-2.6.19.2/scripts/Makefile.lib linux-2.6.19.2.new/scripts/Makefil
+cmd_lzma = bash -e scripts/lzma_kern $< $@ -lc7 -lp0 -pb0 +cmd_lzma = bash -e scripts/lzma_kern $< $@ -lc7 -lp0 -pb0
+# to use lzmacomp, +# to use lzmacomp,
+# cmd_lzma = lzmacomp $< 700 > $@ +# cmd_lzma = lzmacomp $< 700 > $@
diff -u linux/scripts/lzma_kern linux/scripts/lzma_kern --- /dev/null
--- linux/scripts/lzma_kern 2007-07-27 20:18:17.013014750 -0700 +++ b/scripts/lzma_kern
+++ linux/scripts/lzma_kern 2007-07-27 20:18:17.013014750 -0700
@@ -0,0 +1,4 @@ @@ -0,0 +1,4 @@
+get-size() { echo "$5" ;} +get-size() { echo "$5" ;}
+printf -v len '%.8x' "$(get-size $(ls -l "$1"))" +printf -v len '%.8x' "$(get-size $(ls -l "$1"))"
+lzma e "$@" +lzma e "$@"
+echo -ne "\x$(echo $len | cut -c 7,8)\x$(echo $len | cut -c 5,6)\x$(echo $len | cut -c 3,4)\x$(echo $len | cut -c 1,2)" >> "$2" +echo -ne "\x$(echo $len | cut -c 7,8)\x$(echo $len | cut -c 5,6)\x$(echo $len | cut -c 3,4)\x$(echo $len | cut -c 1,2)" >> "$2"
diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arch/x86/boot/compressed/Makefile_32 --- a/arch/x86/boot/compressed/Makefile_32
--- linux-2.6.24/arch/x86/boot/compressed/Makefile_32 2008-01-24 23:58:37.000000000 +0100 +++ b/arch/x86/boot/compressed/Makefile_32
+++ linux-2.6.24.new/arch/x86/boot/compressed/Makefile_32 2008-02-13 15:21:03.000000000 +0100
@@ -4,8 +4,8 @@ @@ -4,8 +4,8 @@
# create a compressed vmlinux image from the original vmlinux # create a compressed vmlinux image from the original vmlinux
# #
@ -34,7 +31,7 @@ diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arc
EXTRA_AFLAGS := -traditional EXTRA_AFLAGS := -traditional
LDFLAGS_vmlinux := -T LDFLAGS_vmlinux := -T
@@ -17,7 +17,7 @@ @@ -17,7 +17,7 @@ KBUILD_CFLAGS := -m32 -D__KERNEL__ $(LI
$(call cc-option,-fno-stack-protector) $(call cc-option,-fno-stack-protector)
LDFLAGS := -m elf_i386 LDFLAGS := -m elf_i386
@ -43,7 +40,7 @@ diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arc
$(call if_changed,ld) $(call if_changed,ld)
@: @:
@@ -37,14 +37,14 @@ @@ -37,14 +37,14 @@ $(obj)/vmlinux.bin.all: $(vmlinux.bin.al
$(call if_changed,relocbin) $(call if_changed,relocbin)
ifdef CONFIG_RELOCATABLE ifdef CONFIG_RELOCATABLE