mirror of https://github.com/hak5/openwrt-owl.git
OpenVPN: Update to 2.4.1
Update OpenVPN to 2.4.1 Remove 200-small_build_enable_occ.patch as it's included upstream. Refresh patches Add mirror and switch to HTTPS Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>owl
parent
2c6b8e4631
commit
210e96d4cf
|
@ -9,12 +9,14 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=openvpn
|
PKG_NAME:=openvpn
|
||||||
|
|
||||||
PKG_VERSION:=2.4.0
|
PKG_VERSION:=2.4.1
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://swupdate.openvpn.net/community/releases
|
PKG_SOURCE_URL:=\
|
||||||
|
https://build.openvpn.net/downloads/releases/ \
|
||||||
|
https://swupdate.openvpn.net/community/releases/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_HASH:=6f23ba49a1dbeb658f49c7ae17d9ea979de6d92c7357de3d55cd4525e1b2f87e
|
PKG_HASH:=fde9e22c6df7a335d2d58c6a4d5967be76df173c766a5c51ece57fd044c76ee5
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/openvpn/ssl_mbedtls.c
|
--- a/src/openvpn/ssl_mbedtls.c
|
||||||
+++ b/src/openvpn/ssl_mbedtls.c
|
+++ b/src/openvpn/ssl_mbedtls.c
|
||||||
@@ -1333,7 +1333,7 @@ const char *
|
@@ -1337,7 +1337,7 @@ const char *
|
||||||
get_ssl_library_version(void)
|
get_ssl_library_version(void)
|
||||||
{
|
{
|
||||||
static char mbedtls_version[30];
|
static char mbedtls_version[30];
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
--- a/src/openvpn/syshead.h
|
|
||||||
+++ b/src/openvpn/syshead.h
|
|
||||||
@@ -589,9 +589,7 @@ socket_defined (const socket_descriptor_
|
|
||||||
/*
|
|
||||||
* Should we include OCC (options consistency check) code?
|
|
||||||
*/
|
|
||||||
-#ifndef ENABLE_SMALL
|
|
||||||
#define ENABLE_OCC
|
|
||||||
-#endif
|
|
||||||
|
|
||||||
/*
|
|
||||||
* Should we include NTLM proxy functionality
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -1014,37 +1014,14 @@ dnl
|
@@ -1058,37 +1058,14 @@ dnl
|
||||||
AC_ARG_VAR([LZ4_CFLAGS], [C compiler flags for lz4])
|
AC_ARG_VAR([LZ4_CFLAGS], [C compiler flags for lz4])
|
||||||
AC_ARG_VAR([LZ4_LIBS], [linker flags for lz4])
|
AC_ARG_VAR([LZ4_LIBS], [linker flags for lz4])
|
||||||
if test "$enable_lz4" = "yes" && test "$enable_comp_stub" = "no"; then
|
if test "$enable_lz4" = "yes" && test "$enable_comp_stub" = "no"; then
|
||||||
|
@ -39,3 +39,5 @@
|
||||||
AC_DEFINE(ENABLE_LZ4, 1, [Enable LZ4 compression library])
|
AC_DEFINE(ENABLE_LZ4, 1, [Enable LZ4 compression library])
|
||||||
- CFLAGS="${saved_CFLAGS}"
|
- CFLAGS="${saved_CFLAGS}"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue