mirror of https://github.com/hak5/openwrt-owl.git
lantiq: ltq-vdsl-app: update to version 4.16.6.3
In this upstream dsl driver app version the autoboot is deactivated activate it again. In addition to the update this also fixes some build warnings and makes it use the same configure option as used in Lantiq UGW. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@lantiq.com> SVN-Revision: 47637owl
parent
41587675ec
commit
11f2007895
|
@ -1,4 +1,5 @@
|
|||
# Copyright (C) 2010 OpenWrt.org
|
||||
# Copyright (C) 2015 Lantiq Beteiligungs GmbH & Co KG.
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -7,12 +8,12 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=ltq-vdsl-app
|
||||
PKG_VERSION:=4.16.2.4
|
||||
PKG_VERSION:=4.16.6.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_BASE_NAME:=dsl_cpe_control_vrx
|
||||
PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/xdarklight/$(PKG_BASE_NAME)/archive/v$(PKG_VERSION)
|
||||
PKG_MD5SUM:=487925ef5327ea38c544035b388de8bb
|
||||
PKG_BASE_NAME:=dsl_cpe_control
|
||||
PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||
PKG_MD5SUM:=8bedf330a456fe0864844e61b57da627
|
||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
|
||||
PKG_LICENSE:=BSD-2-Clause
|
||||
|
||||
|
@ -39,21 +40,12 @@ CONFIGURE_ARGS += \
|
|||
--enable-vrx \
|
||||
--enable-driver-include="-I$(STAGING_DIR)/usr/include/drv_vdsl_cpe_api" \
|
||||
--enable-device-driver-include="-I$(STAGING_DIR)/usr/include/vdsl/" \
|
||||
--enable-add-appl-cflags="-DMAX_CLI_PIPES=2" \
|
||||
--enable-add-appl-cflags="-DMAX_CLI_PIPES=1" \
|
||||
--enable-ifxos \
|
||||
--enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos" \
|
||||
--enable-ifxos-library="-I$(STAGING_DIR)/usr/lib" \
|
||||
--disable-dsl-ceoc \
|
||||
--enable-dsl-pm-total \
|
||||
--enable-dsl-pm-showtime \
|
||||
--enable-dsl-pm-line-counters \
|
||||
--enable-dsl-pm-line-failure-counters \
|
||||
--enable-dsl-pm-datapath-counters \
|
||||
--enable-dsl-pm-datapath-failure-counters \
|
||||
--enable-deprecated \
|
||||
--disable-soap-support \
|
||||
--enable-dsl-bonding=no \
|
||||
--enable-debug-prints=err \
|
||||
--enable-dsl-ceoc=no \
|
||||
--enable-vrx-device=vr9 \
|
||||
--disable-dti \
|
||||
--enable-debug
|
||||
|
||||
|
|
|
@ -0,0 +1,23 @@
|
|||
--- a/src/dsl_cpe_os.h
|
||||
+++ b/src/dsl_cpe_os.h
|
||||
@@ -31,15 +31,15 @@
|
||||
#ifndef _lint
|
||||
#ifdef LINUX
|
||||
#include "dsl_cpe_linux.h"
|
||||
-#elif WIN32
|
||||
+#elif defined(WIN32)
|
||||
#include "dsl_cpe_win32.h"
|
||||
-#elif VXWORKS
|
||||
+#elif defined(VXWORKS)
|
||||
#include "dsl_cpe_vxworks.h"
|
||||
-#elif ECOS
|
||||
+#elif defined(ECOS)
|
||||
#include "dsl_cpe_ecos.h"
|
||||
-#elif RTEMS
|
||||
+#elif defined(RTEMS)
|
||||
#include "dsl_cpe_rtems.h"
|
||||
-#elif GENERIC_OS
|
||||
+#elif defined(GENERIC_OS)
|
||||
#include "dsl_cpe_generic_os.h"
|
||||
#else
|
||||
#error please define your OS for the CPE Control adaptation
|
|
@ -8,10 +8,10 @@
|
|||
+ 0x1E116000, 0x3f, -1),
|
||||
DSL_CPE_SIC_SET(DSL_TC_ATM, DSL_EMF_TC_CLEANED, DSL_EMF_TC_CLEANED, DSL_SYSTEMIF_MII, \
|
||||
DSL_TC_EFM, DSL_EMF_TC_CLEANED, DSL_EMF_TC_CLEANED, DSL_SYSTEMIF_MII),
|
||||
}
|
||||
DSL_CPE_MAC_CFG_SET(DSL_EFM_SPEED_100, DSL_EFM_DUPLEX_FULL, DSL_EFM_FLOWCTRL_ON, DSL_EFM_AUTONEG_OFF, \
|
||||
--- a/src/dsl_cpe_control.c
|
||||
+++ b/src/dsl_cpe_control.c
|
||||
@@ -6856,7 +6856,7 @@ DSL_int_t dsl_cpe_daemon (
|
||||
@@ -6871,7 +6871,7 @@ DSL_int_t dsl_cpe_daemon (
|
||||
for (nDevice = 0; nDevice < DSL_CPE_MAX_DSL_ENTITIES; nDevice++)
|
||||
{
|
||||
#if defined(INCLUDE_DSL_CPE_API_VRX)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/dsl_cpe_control.c
|
||||
+++ b/src/dsl_cpe_control.c
|
||||
@@ -12,6 +12,7 @@
|
||||
@@ -11,6 +11,7 @@
|
||||
/*
|
||||
Includes
|
||||
*/
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- a/src/dsl_cpe_init_cfg.c
|
||||
+++ b/src/dsl_cpe_init_cfg.c
|
||||
@@ -27,7 +27,7 @@ DSL_InitData_t gInitCfgData =
|
||||
DSL_CPE_FW2_SET(DSL_NULL, 0x0),
|
||||
DSL_CPE_XTU_SET(0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x7),
|
||||
DSL_CPE_LINE_INV_NE_SET(DSL_NULL),
|
||||
- DSL_CPE_AUTOBOOT_CTRL_SET(DSL_AUTOBOOT_CTRL_STOP),
|
||||
+ DSL_CPE_AUTOBOOT_CTRL_SET(DSL_AUTOBOOT_CTRL_START),
|
||||
DSL_CPE_AUTOBOOT_CFG_SET(DSL_FALSE, DSL_FALSE, DSL_FALSE),
|
||||
DSL_CPE_TEST_MODE_CTRL_SET(DSL_TESTMODE_DISABLE),
|
||||
DSL_CPE_LINE_ACTIVATE_CTRL_SET(DSL_G997_INHIBIT_LDSF, DSL_G997_INHIBIT_ACSF, DSL_G997_NORMAL_STARTUP),
|
Loading…
Reference in New Issue