refresh 2.6.32 patches with -rc7

SVN-Revision: 18440
owl
Imre Kaloz 2009-11-17 10:06:15 +00:00
parent 294551ca73
commit 0b27fefa62
12 changed files with 29 additions and 19 deletions

View File

@ -88,6 +88,7 @@ CONFIG_ASK_IP_FIB_HASH=y
# CONFIG_ATA_OVER_ETH is not set # CONFIG_ATA_OVER_ETH is not set
# CONFIG_ATARI_PARTITION is not set # CONFIG_ATARI_PARTITION is not set
CONFIG_ATA_SFF=y CONFIG_ATA_SFF=y
# CONFIG_ATA_VERBOSE_ERROR is not set
# CONFIG_ATH5K is not set # CONFIG_ATH5K is not set
# CONFIG_ATH9K is not set # CONFIG_ATH9K is not set
# CONFIG_ATL1C is not set # CONFIG_ATL1C is not set
@ -149,6 +150,7 @@ CONFIG_BCM43XX_DMA=y
# CONFIG_BCM43XX is not set # CONFIG_BCM43XX is not set
# CONFIG_BCM43XX_PIO_MODE is not set # CONFIG_BCM43XX_PIO_MODE is not set
CONFIG_BCM43XX_PIO=y CONFIG_BCM43XX_PIO=y
# CONFIG_BE2ISCSI is not set
# CONFIG_BEFS_FS is not set # CONFIG_BEFS_FS is not set
# CONFIG_BFS_FS is not set # CONFIG_BFS_FS is not set
# CONFIG_BINARY_PRINTF is not set # CONFIG_BINARY_PRINTF is not set
@ -1035,10 +1037,10 @@ CONFIG_JOLIET=y
# CONFIG_KALLSYMS_EXTRA_PASS is not set # CONFIG_KALLSYMS_EXTRA_PASS is not set
# CONFIG_KALLSYMS is not set # CONFIG_KALLSYMS is not set
# CONFIG_KARMA_PARTITION is not set # CONFIG_KARMA_PARTITION is not set
# CONFIG_KEXEC is not set
# CONFIG_KERNEL_GZIP is not set # CONFIG_KERNEL_GZIP is not set
CONFIG_KERNEL_LZMA=y CONFIG_KERNEL_LZMA=y
# CONFIG_KERNEL_LZO is not set # CONFIG_KERNEL_LZO is not set
# CONFIG_KEXEC is not set
# CONFIG_KEYBOARD_LM8323 is not set # CONFIG_KEYBOARD_LM8323 is not set
# CONFIG_KEYS is not set # CONFIG_KEYS is not set
# CONFIG_KMEMTRACE is not set # CONFIG_KMEMTRACE is not set
@ -1531,6 +1533,7 @@ CONFIG_PARTITION_ADVANCED=y
# CONFIG_PATA_AMD is not set # CONFIG_PATA_AMD is not set
# CONFIG_PATA_ARTOP is not set # CONFIG_PATA_ARTOP is not set
# CONFIG_PATA_ATIIXP is not set # CONFIG_PATA_ATIIXP is not set
# CONFIG_PATA_ATP867X is not set
# CONFIG_PATA_CMD640_PCI is not set # CONFIG_PATA_CMD640_PCI is not set
# CONFIG_PATA_CMD64X is not set # CONFIG_PATA_CMD64X is not set
# CONFIG_PATA_CS5520 is not set # CONFIG_PATA_CS5520 is not set
@ -1563,6 +1566,7 @@ CONFIG_PARTITION_ADVANCED=y
# CONFIG_PATA_PLATFORM is not set # CONFIG_PATA_PLATFORM is not set
# CONFIG_PATA_QDI is not set # CONFIG_PATA_QDI is not set
# CONFIG_PATA_RADISYS is not set # CONFIG_PATA_RADISYS is not set
# CONFIG_PATA_RDC is not set
# CONFIG_PATA_RZ1000 is not set # CONFIG_PATA_RZ1000 is not set
# CONFIG_PATA_SC1200 is not set # CONFIG_PATA_SC1200 is not set
# CONFIG_PATA_SCH is not set # CONFIG_PATA_SCH is not set
@ -1802,6 +1806,7 @@ CONFIG_SCHED_CFS=y
# CONFIG_SCSI_AIC7XXX_OLD is not set # CONFIG_SCSI_AIC7XXX_OLD is not set
# CONFIG_SCSI_AIC94XX is not set # CONFIG_SCSI_AIC94XX is not set
# CONFIG_SCSI_ARCMSR is not set # CONFIG_SCSI_ARCMSR is not set
# CONFIG_SCSI_BFA_FC is not set
# CONFIG_SCSI_BNX2_ISCSI is not set # CONFIG_SCSI_BNX2_ISCSI is not set
# CONFIG_SCSI_BUSLOGIC is not set # CONFIG_SCSI_BUSLOGIC is not set
# CONFIG_SCSI_CONSTANTS is not set # CONFIG_SCSI_CONSTANTS is not set
@ -1840,6 +1845,7 @@ CONFIG_SCSI_MULTI_LUN=y
# CONFIG_SCSI_NSP32 is not set # CONFIG_SCSI_NSP32 is not set
# CONFIG_SCSI_OSD_INITIATOR is not set # CONFIG_SCSI_OSD_INITIATOR is not set
# CONFIG_SCSI_PAS16 is not set # CONFIG_SCSI_PAS16 is not set
# CONFIG_SCSI_PMCRAID is not set
CONFIG_SCSI_PROC_FS=y CONFIG_SCSI_PROC_FS=y
# CONFIG_SCSI_PSI240I is not set # CONFIG_SCSI_PSI240I is not set
# CONFIG_SCSI_QLA_FC is not set # CONFIG_SCSI_QLA_FC is not set
@ -2353,6 +2359,7 @@ CONFIG_USB_HIDINPUT=y
# CONFIG_USB_ISIGHTFW is not set # CONFIG_USB_ISIGHTFW is not set
# CONFIG_USB is not set # CONFIG_USB is not set
# CONFIG_USB_ISP116X_HCD is not set # CONFIG_USB_ISP116X_HCD is not set
# CONFIG_USB_ISP1362_HCD is not set
# CONFIG_USB_ISP1760_HCD is not set # CONFIG_USB_ISP1760_HCD is not set
# CONFIG_USB_KAWETH is not set # CONFIG_USB_KAWETH is not set
# CONFIG_USB_KBD is not set # CONFIG_USB_KBD is not set
@ -2615,6 +2622,7 @@ CONFIG_VLAN_8021Q=y
# CONFIG_VMSPLIT_2G is not set # CONFIG_VMSPLIT_2G is not set
CONFIG_VMSPLIT_3G=y CONFIG_VMSPLIT_3G=y
# CONFIG_VT6655 is not set # CONFIG_VT6655 is not set
# CONFIG_VT6656 is not set
# CONFIG_VT is not set # CONFIG_VT is not set
# CONFIG_VXFS_FS is not set # CONFIG_VXFS_FS is not set
# CONFIG_W1 is not set # CONFIG_W1 is not set

View File

@ -811,7 +811,7 @@
extern void kfree_skb(struct sk_buff *skb); extern void kfree_skb(struct sk_buff *skb);
extern void consume_skb(struct sk_buff *skb); extern void consume_skb(struct sk_buff *skb);
extern void __kfree_skb(struct sk_buff *skb); extern void __kfree_skb(struct sk_buff *skb);
@@ -1970,6 +1988,10 @@ static inline void __nf_copy(struct sk_b @@ -1972,6 +1990,10 @@ static inline void __nf_copy(struct sk_b
dst->nfct_reasm = src->nfct_reasm; dst->nfct_reasm = src->nfct_reasm;
nf_conntrack_get_reasm(src->nfct_reasm); nf_conntrack_get_reasm(src->nfct_reasm);
#endif #endif

View File

@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (dev_net(dev) != sock_net(sk)) if (dev_net(dev) != sock_net(sk))
goto drop; goto drop;
@@ -1384,6 +1387,7 @@ static int packet_create(struct net *net @@ -1381,6 +1384,7 @@ static int packet_create(struct net *net
spin_lock_init(&po->bind_lock); spin_lock_init(&po->bind_lock);
mutex_init(&po->pg_vec_lock); mutex_init(&po->pg_vec_lock);
po->prot_hook.func = packet_rcv; po->prot_hook.func = packet_rcv;
@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (sock->type == SOCK_PACKET) if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt; po->prot_hook.func = packet_rcv_spkt;
@@ -1731,6 +1735,16 @@ packet_setsockopt(struct socket *sock, i @@ -1728,6 +1732,16 @@ packet_setsockopt(struct socket *sock, i
ret = packet_mc_drop(sk, &mreq); ret = packet_mc_drop(sk, &mreq);
return ret; return ret;
} }
@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
#ifdef CONFIG_PACKET_MMAP #ifdef CONFIG_PACKET_MMAP
case PACKET_RX_RING: case PACKET_RX_RING:
@@ -1876,6 +1890,13 @@ static int packet_getsockopt(struct sock @@ -1873,6 +1887,13 @@ static int packet_getsockopt(struct sock
data = &val; data = &val;
break; break;

View File

@ -1,6 +1,6 @@
--- a/drivers/input/misc/Kconfig --- a/drivers/input/misc/Kconfig
+++ b/drivers/input/misc/Kconfig +++ b/drivers/input/misc/Kconfig
@@ -316,4 +316,20 @@ config INPUT_PCAP @@ -317,4 +317,20 @@ config INPUT_PCAP
To compile this driver as a module, choose M here: the To compile this driver as a module, choose M here: the
module will be called pcap_keys. module will be called pcap_keys.

View File

@ -1,7 +1,7 @@
--- a/init/main.c --- a/init/main.c
+++ b/init/main.c +++ b/init/main.c
@@ -819,7 +819,7 @@ static noinline int init_post(void) @@ -817,7 +817,7 @@ static noinline int init_post(void)
printk(KERN_INFO"Running BFS CPU scheduler v0.302 by Con Kolivas.\n"); numa_default_policy();
if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0) if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
- printk(KERN_WARNING "Warning: unable to open an initial console.\n"); - printk(KERN_WARNING "Warning: unable to open an initial console.\n");

View File

@ -829,7 +829,7 @@
+be done automatically. +be done automatically.
--- a/MAINTAINERS --- a/MAINTAINERS
+++ b/MAINTAINERS +++ b/MAINTAINERS
@@ -2354,6 +2354,11 @@ T: git git://git.kernel.org/pub/scm/linu @@ -2348,6 +2348,11 @@ T: git git://git.kernel.org/pub/scm/linu
S: Maintained S: Maintained
F: drivers/media/video/gspca/ F: drivers/media/video/gspca/

View File

@ -1,6 +1,6 @@
--- a/lib/Kconfig --- a/lib/Kconfig
+++ b/lib/Kconfig +++ b/lib/Kconfig
@@ -148,16 +148,16 @@ config REED_SOLOMON_DEC16 @@ -152,16 +152,16 @@ config REED_SOLOMON_DEC16
# Textsearch support is select'ed if needed # Textsearch support is select'ed if needed
# #
config TEXTSEARCH config TEXTSEARCH

View File

@ -40,7 +40,7 @@
{ {
--- a/kernel/exit.c --- a/kernel/exit.c
+++ b/kernel/exit.c +++ b/kernel/exit.c
@@ -510,6 +510,7 @@ struct files_struct *get_files_struct(st @@ -507,6 +507,7 @@ struct files_struct *get_files_struct(st
return files; return files;
} }
@ -48,7 +48,7 @@
void put_files_struct(struct files_struct *files) void put_files_struct(struct files_struct *files)
{ {
@@ -529,6 +530,7 @@ void put_files_struct(struct files_struc @@ -526,6 +527,7 @@ void put_files_struct(struct files_struc
free_fdtable(fdt); free_fdtable(fdt);
} }
} }
@ -68,7 +68,7 @@
* macro override instead of weak attribute alias, to workaround * macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c --- a/kernel/sched.c
+++ b/kernel/sched.c +++ b/kernel/sched.c
@@ -6046,6 +6046,7 @@ int can_nice(const struct task_struct *p @@ -6075,6 +6075,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur || return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
capable(CAP_SYS_NICE)); capable(CAP_SYS_NICE));
} }
@ -78,7 +78,7 @@
--- a/mm/memory.c --- a/mm/memory.c
+++ b/mm/memory.c +++ b/mm/memory.c
@@ -1097,6 +1097,7 @@ unsigned long zap_page_range(struct vm_a @@ -1100,6 +1100,7 @@ unsigned long zap_page_range(struct vm_a
tlb_finish_mmu(tlb, address, end); tlb_finish_mmu(tlb, address, end);
return end; return end;
} }
@ -86,7 +86,7 @@
/** /**
* zap_vma_ptes - remove ptes mapping the vma * zap_vma_ptes - remove ptes mapping the vma
@@ -2483,6 +2484,7 @@ int vmtruncate_range(struct inode *inode @@ -2486,6 +2487,7 @@ int vmtruncate_range(struct inode *inode
return 0; return 0;
} }

View File

@ -1,12 +1,14 @@
--- a/scripts/Makefile.lib --- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib +++ b/scripts/Makefile.lib
@@ -228,5 +228,5 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^) @@ -228,7 +228,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
quiet_cmd_lzma = LZMA $@ quiet_cmd_lzma = LZMA $@
cmd_lzma = (cat $(filter-out FORCE,$^) | \ cmd_lzma = (cat $(filter-out FORCE,$^) | \
- lzma -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \ - lzma -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ lzma e -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \ + lzma e -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
(rm -f $@ ; false) (rm -f $@ ; false)
quiet_cmd_lzo = LZO $@
--- a/scripts/gen_initramfs_list.sh --- a/scripts/gen_initramfs_list.sh
+++ b/scripts/gen_initramfs_list.sh +++ b/scripts/gen_initramfs_list.sh
@@ -225,7 +225,7 @@ cpio_list= @@ -225,7 +225,7 @@ cpio_list=

View File

@ -1,6 +1,6 @@
--- a/init/main.c --- a/init/main.c
+++ b/init/main.c +++ b/init/main.c
@@ -843,10 +843,7 @@ static noinline int init_post(void) @@ -841,10 +841,7 @@ static noinline int init_post(void)
printk(KERN_WARNING "Failed to execute %s. Attempting " printk(KERN_WARNING "Failed to execute %s. Attempting "
"defaults...\n", execute_command); "defaults...\n", execute_command);
} }

View File

@ -1,6 +1,6 @@
--- a/arch/arm/Kconfig --- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig +++ b/arch/arm/Kconfig
@@ -415,7 +415,6 @@ config ARCH_IXP4XX @@ -418,7 +418,6 @@ config ARCH_IXP4XX
select GENERIC_GPIO select GENERIC_GPIO
select GENERIC_TIME select GENERIC_TIME
select GENERIC_CLOCKEVENTS select GENERIC_CLOCKEVENTS

View File

@ -50,7 +50,7 @@
--- a/arch/arm/Kconfig --- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig +++ b/arch/arm/Kconfig
@@ -415,6 +415,7 @@ config ARCH_IXP4XX @@ -418,6 +418,7 @@ config ARCH_IXP4XX
select GENERIC_GPIO select GENERIC_GPIO
select GENERIC_TIME select GENERIC_TIME
select GENERIC_CLOCKEVENTS select GENERIC_CLOCKEVENTS