mirror of https://github.com/hak5/openwrt-owl.git
ubi-utils: mini version of mtd-utils that only includes ubi tools
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 40367owl
parent
69519ed75f
commit
08b4924401
|
@ -53,12 +53,19 @@ run_ramfs() { # <command> [...]
|
|||
install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount \
|
||||
/sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd \
|
||||
/bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" \
|
||||
/bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump \
|
||||
/bin/sleep /bin/zcat /usr/bin/bzcat /usr/bin/printf /usr/bin/wc
|
||||
/bin/dd /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump \
|
||||
/bin/sleep /bin/zcat /usr/bin/bzcat /usr/bin/printf /usr/bin/wc \
|
||||
/bin/cut /usr/bin/printf /bin/sync
|
||||
|
||||
install_bin /sbin/mtd
|
||||
install_bin /sbin/fs-state
|
||||
install_bin /sbin/snapshot
|
||||
install_bin /usr/sbin/ubiupdatevol
|
||||
install_bin /usr/sbin/ubiattach
|
||||
install_bin /usr/sbin/ubidetach
|
||||
install_bin /usr/sbin/ubirsvol
|
||||
install_bin /usr/sbin/ubirmvol
|
||||
install_bin /usr/sbin/ubimkvol
|
||||
for file in $RAMFS_COPY_BIN; do
|
||||
install_bin $file
|
||||
done
|
||||
|
|
|
@ -0,0 +1,93 @@
|
|||
#
|
||||
# Copyright (C) 2009-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mtd-utils
|
||||
PKG_REV:=ab8c6fb93ce9db0f09401c4b819b0b277dc00340
|
||||
PKG_VERSION:=1.5.0
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=git://git.infradead.org/ubi-utils.git
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
PKG_BUILD_DEPENDS:=util-linux liblzo
|
||||
|
||||
PKG_LICENSE:=GPLv2
|
||||
PKG_LICENSE_FILES:=
|
||||
|
||||
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/usb-utils/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
FILES:= \
|
||||
ubiattach \
|
||||
ubicrc32 \
|
||||
ubidetach \
|
||||
ubiformat \
|
||||
ubimkvol \
|
||||
ubinfo \
|
||||
ubinize \
|
||||
ubirename \
|
||||
ubirmvol \
|
||||
ubirsvol \
|
||||
ubiupdatevol
|
||||
|
||||
define PartGen
|
||||
define Package/ubi-utils-$(subst _,-,$(firstword $(subst :, ,$(1))))
|
||||
TITLE:=$(firstword $(subst :, ,$(1))) package from ubi-utils
|
||||
URL:=http://www.linux-mtd.infradead.org/
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=ubi-utils $(wordlist 2,$(words $(subst :, ,$(1))),$(subst :, ,$(1)))
|
||||
endef
|
||||
endef
|
||||
|
||||
define Package/ubi-utils
|
||||
TITLE:=Utilities for ubi info/debug
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
URL:=http://www.linux-mtd.infradead.org/
|
||||
MENU:=1
|
||||
endef
|
||||
|
||||
define Package/ubi-utils/description
|
||||
Utilities for manipulating memory technology devices.
|
||||
endef
|
||||
|
||||
define Package/ubi-utils/install
|
||||
true
|
||||
endef
|
||||
|
||||
$(foreach file,$(FILES),$(eval $(call PartGen,$(file))))
|
||||
|
||||
MAKE_FLAGS += \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
BUILDDIR="$(PKG_BUILD_DIR)" \
|
||||
LDLIBS+="$(LIBGCC_S)" \
|
||||
WITHOUT_XATTR=1 \
|
||||
WITHOUT_LZO=1
|
||||
|
||||
define PartInstall
|
||||
define Package/ubi-utils-$(subst _,-,$(firstword $(subst :, ,$(1))))/install
|
||||
$(INSTALL_DIR) $$(1)/usr/sbin
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/sbin/$(firstword $(subst :, ,$(1))) \
|
||||
$$(1)/usr/sbin/
|
||||
endef
|
||||
endef
|
||||
|
||||
$(foreach file,$(FILES),$(eval $(call PartInstall,$(file))))
|
||||
|
||||
$(eval $(call BuildPackage,ubi-utils))
|
||||
$(foreach file,$(FILES),$(eval $(call BuildPackage,ubi-utils-$(subst _,-,$(firstword $(subst :, ,$(file)))))))
|
|
@ -0,0 +1,19 @@
|
|||
--- a/include/common.h
|
||||
+++ b/include/common.h
|
||||
@@ -122,10 +122,12 @@
|
||||
}
|
||||
|
||||
if (strcmp("\n", line) != 0) {
|
||||
- switch (rpmatch(line)) {
|
||||
- case 0: ret = false; break;
|
||||
- case 1: ret = true; break;
|
||||
- case -1:
|
||||
+ switch (line[0]) {
|
||||
+ case 'N':
|
||||
+ case 'n': ret = false; break;
|
||||
+ case 'Y':
|
||||
+ case 'y': ret = true; break;
|
||||
+ default:
|
||||
puts("unknown response; please try again");
|
||||
continue;
|
||||
}
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue